Thanks Thanks:  10
Seite 8 von 9 ErsteErste ... 6789 LetzteLetzte
Ergebnis 71 bis 80 von 87
  1. #71
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    So, des sleep auf 30 gesetzt - Kein Erfolg.

    blkid:
    root@et10000:~# blkid
    /dev/ubi0_0: UUID="ce5f28dc-da63-42a5-9fec-77bbbb43007f" TYPE="ubifs"
    /dev/sdd1: LABEL="hdd" UUID="06985978-07e9-45fe-a2d7-10dfac5e833e" TYPE="ext4" P
    ARTLABEL="primary" PARTUUID="db13ea0b-6fde-44bd-8d39-8ac5c953be6c"

    mount:
    root@et10000:~# mount
    rootfs on / type rootfs (rw)
    ubi0:rootfs on / type ubifs (rw,relatime)
    devtmpfs on /dev type devtmpfs (rw,relatime,size=643428k,nr_inodes=125107,mode=7
    55)
    proc on /proc type proc (rw,relatime)
    sysfs on /sys type sysfs (rw,relatime)
    tmpfs on /media type tmpfs (rw,relatime,size=64k)
    /dev/sda1 on /media/hdd type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utime
    =0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
    tmpfs on /var/volatile type tmpfs (rw,relatime)
    devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620)
    nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
    /etc/auto.network on /media/autofs type autofs (rw,relatime,fd=6,pgrp=597,timeou
    t=5,minproto=5,maxproto=5,indirect)
    //192.168.178.1/FRITZ.NAS on /media/net/FRITZNASFRITZNAS type cifs (rw,relatime,
    vers=1.0,cache=strict,domain=FRITZ-NAS,uid=0,noforceuid,gid=0,noforcegid,addr=19
    2.168.178.1,iocharset=utf8,unix,posixpaths,serveri no,acl,rsize=61440,wsize=65536
    ,actimeo=1)
    root@et10000:~#

    Das Problem ist schon, das der Rahmen VOR der Platte gefunden wird...
    Angehängte Dateien Angehängte Dateien
    Geändert von Klaus_Günther (25.06.2014 um 09:42 Uhr)

    •   Alt Advertising

       

  2. #72
    Anfänger
    Registriert seit
    01.05.2013
    Beiträge
    21
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Ich würde mal folgendes testen:
    1. Verzeichnis lcd auf der hdd erstellen
    2. in der fstab die hdd vor dem lcd eintragen und mit der uuid statt partuuid nach /media/hdd
    3. in der fstab das lcd nach /media/hdd/lcd

  3. #73
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    Was?
    /media/jdd/lcd anlegen?
    /media/lcd existiert ja.

    2. NEIN - auf gar keinen Fall! Wenn Du die vorrige blkid anschaust, wirst Du feststellen, dass der Rahmen VOR der HDD nach /media/hdd gemountet wird.
    Deswegen lasse cih ERST den Rahmen woandersthin mountetn, damit /media/hdd NORMALERWEISE auf jeden Fall frei sein sollte...
    UUID bringt nichts. Mir wurde ja hier dazu geraten, die PARTUUID zu verwenden.

    3. ja, kann ich noch machen

  4. #74
    Avatar von -=niki=-
    Registriert seit
    07.04.2013
    Beiträge
    827
    Total Downloaded
    19,78 MB
    Total Downloaded
    19,78 MB
    ReceiverDankeAktivitäten
    Box 1:
    Gigablue Solo @ ATV4
     
     
    Box 2:
    Sogno 8800HD @ ATV4 / PLI4
     
     
    Box 3:
    diverse
     
     
    Das ubi Device ist dein interner in der Box verbauter Flash und kein Bilderrahmen!

    mit welcher Methode hast du dein Bilderrahmen gehacked?

    Das mit der automounts.xml ist ein guter Ansatz... /etc/enigma2/automounts.xml sollte hier leer sein.

    LG Niki

  5. #75
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    Der Bilderrahmen ist GAR NICHT gehackt! ist ein Samsung 105. Die müssen ja nicht gehackt werden...

    Dass das ubi Device der interne Speicher ist, mag schon sein, davon habe ich aber nicht gesprochen!
    /dev/sda1 on /media/hdd type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utime
    =0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
    - DAS ist der Bilderrahmen!!!
    UND DER ist nunmal sda1 - WARUM auch immer...

    HOI!?
    Jetzt hab ich eine automounts.xml...
    Da steht meine netzwerkfreigabe drin.
    HDD REplacement = false!
    Code:
    <?xml version="1.0"?>
    <mountmanager><fstab><cifs><mount><active>True</active><hdd_replacement>False</hdd_replacement><ip>192.168.178.1</ip><sharename>FRITZNASFRITZNAS</sharename><sharedir>FRITZ.NAS</sharedir><options>rw,utf8</options><username/>
    <password/></mount></cifs></fstab></mountmanager>

  6. #76
    Avatar von -=niki=-
    Registriert seit
    07.04.2013
    Beiträge
    827
    Total Downloaded
    19,78 MB
    Total Downloaded
    19,78 MB
    ReceiverDankeAktivitäten
    Box 1:
    Gigablue Solo @ ATV4
     
     
    Box 2:
    Sogno 8800HD @ ATV4 / PLI4
     
     
    Box 3:
    diverse
     
     
    Verzeih mir meine Unwissenheit, mir war bisher net bekannt welchen Bilderrahmen du überhaupt einsetzt.

    Dein BLKID von oben erkennt genau 2 Geräte. /dev/ubi0_0 (internal Flash) und /dev/sdd1 (internal HDD [wenn ich dem Label glauben schenken darf] )

    In deiner fstab mountest du dein internen Flash nach /media/lcd .... Warum auch immer, ich wollte dich lediglich darauf hinweisen dass dies etwas falsch ist und nicht den LCD. Wenn dies Absicht war habe ich den größeren Gedanken dahinter nicht erfassen können.

    Die Frage ist nun eigentlich was dein /dev/sda1 veranlasst nach /media/hdd zu mounten. Sind wir mal wieder beim mdev. (Wenn sda nun als den bilderrahmen nach hdd gemountet wird)

    root@et10000:~# cat /sys/block/sda/removable # 0=fest 1=removable

    root@et10000:~# readlink -fn /sys/block/sda/device | grep -qs 'pci\|ahci'
    root@et10000:~# echo $?

    Kommt bei beiden Ausgaben Null raus so denkt mdev das es sich um eine interne HDD handelt da sie kein removable flag hat und über den PCI/ahci Bus angesprochen wird.
    Dann ist auch klar das diese als HDD gemountet wird weil sie vor deiner HDD verarbeitet wird. Die Erkennung geschieht wie schon mehrfach geschrieben auf Kernelebene, da haben wir keinerlei Einfluss drauf.... höchstens Linus Torwalds ^^.

    Nun sollte das wirklich so sein bei dir müssen wir halt über eine alternative Erkennungsmethode nachdenken die dein Rahmen als Rahmen erkennen lässt
    Da ich einen solchen Rahmen nicht besitze, muss ich an dieser Stelle wohl passen nach einer geeigneteren Methode zu suchen.

    LG Niki

  7. #77
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    OH!
    Ja Ne, der interne soll natürlich NICHT gemountet werden.
    Dies ist dann natürlich falsch...

    Werde ich demnach umgehend ändern....

    root@et10000:~# cat /sys/block/sda/removable # 0=fest 1=removable
    0
    root@et10000:~#

    und

    root@et10000:~# readlink -fn /sys/block/sda/device | grep -qs 'pci\|ahci'
    root@et10000:~# echo $?
    0
    root@et10000:~#

    ABER:
    JETZT ist sda wieder die Platte...
    root@et10000:~# blkid
    /dev/ubi0_0: UUID="ce5f28dc-da63-42a5-9fec-77bbbb43007f" TYPE="ubifs"
    /dev/sda1: LABEL="hdd" UUID="06985978-07e9-45fe-a2d7-10dfac5e833e" TYPE="ext4" P
    ARTLABEL="primary" PARTUUID="db13ea0b-6fde-44bd-8d39-8ac5c953be6c"
    root@et10000:~#

    Die Befehle müsste ich demnach DANN eintippen, WENN die Platte NICHT sda ist oder?

    WENN der Rahmen sda1 ist und nach hdd gemountet wird, dann ist dies ja nur während des Bootens der Fall.
    Sobald L4L aktiv wird, fehlt mir dann der Eintrag /media/hdd!
    Das sollte ja soweit klar sein und O.K. gehen...

    Aber das kann ja nicht auf Kernel Ebene passieren, denn mit dem ATV3 gabs dieses problem ja nicht!?
    Da wurde die interne IMMER als sda erkannt und korrekt gemountet!
    Geändert von Klaus_Günther (25.06.2014 um 17:10 Uhr)

  8. #78
    Avatar von -=niki=-
    Registriert seit
    07.04.2013
    Beiträge
    827
    Total Downloaded
    19,78 MB
    Total Downloaded
    19,78 MB
    ReceiverDankeAktivitäten
    Box 1:
    Gigablue Solo @ ATV4
     
     
    Box 2:
    Sogno 8800HD @ ATV4 / PLI4
     
     
    Box 3:
    diverse
     
     
    ja in den Befehlen musst du natürlich dein bilderrahmen erwischen.... also vorher mal mit mount die Gerätedatei herrausfinden und dann die Befehle entsprechend abändern. also statt sda geht nat. aus sdb oder sdd oder was immer erkannt wird.

    LG Niki

    Edit: Gab es für die 10k überhaupt jemals ein 3.0 Image? Falls du an einer anderen Box den Rahmen hattest solltest du auch bedenken dass diese evtl auch einen anderen Kernel nutzte!
    Geändert von -=niki=- (25.06.2014 um 18:15 Uhr)

  9. #79
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    Achso O.K.
    Der Rahmen war vorher an einer 9100 mit ATV3.0

    DAS wäre auch was... Testweise ein ATV3 Image für die 10000...
    Die Treiber austauschen wird da nicht reichen oder???

    Hm, wer macht denn die kernel??
    Vielleicht sollte der dann auch mal informiert werden... ;-)

    Wie krieg ich denn die UUID des Bilderrahmens raus?
    Die wurde mir ja bisher nirgendwo angezeigt...
    Wenn ich mir die ganzen blkid-Ausgaben und Mount-Ausgaben hier ansehe...

    O.K. der hat wohl keine...
    root@et10000:~# blkid
    /dev/ubi0_0: UUID="ce5f28dc-da63-42a5-9fec-77bbbb43007f" TYPE="ubifs"
    /dev/sda1: LABEL="hdd" UUID="06985978-07e9-45fe-a2d7-10dfac5e833e" TYPE="ext4" P
    ARTLABEL="primary" PARTUUID="db13ea0b-6fde-44bd-8d39-8ac5c953be6c"
    /dev/sdb1: LABEL="SPF-105P" TYPE="vfat"
    root@et10000:~#

    Jetzt hat er die Platte als sdb1 erkannt und nach sdb1 gemountet. (Nachdem ich mit dem WM Plugin nen Spinner bekommen habe, musste ich den Schalter umlegen)
    root@et10000:~# cat /sys/block/sda/removable # 0=fest 1=removable
    cat: can't open '/sys/block/sda/removable': No such file or directory
    root@et10000:~#
    Geändert von Klaus_Günther (25.06.2014 um 18:47 Uhr)

  10. #80
    Avatar von -=niki=-
    Registriert seit
    07.04.2013
    Beiträge
    827
    Total Downloaded
    19,78 MB
    Total Downloaded
    19,78 MB
    ReceiverDankeAktivitäten
    Box 1:
    Gigablue Solo @ ATV4
     
     
    Box 2:
    Sogno 8800HD @ ATV4 / PLI4
     
     
    Box 3:
    diverse
     
     
    /dev/sdb1: LABEL="SPF-105P" TYPE="vfat"

    Das ist doch dein Bilderrahmen... oder? der hat keine UUID weil er net unter Linux formatiert wurde und obendrein ein vfat Dateisystem ist. Aber es gibt ein Label... ist fast mit UUID gleichzusetzen. Demnach würde ich nun die fstab folgendermaßen gestalten:

    Code:
    PARTUUID=db13ea0b-6fde-44bd-8d39-8ac5c953be6c    /media/hdd    ext4    defaults    0 0
    LABEL=SPF-105P                                   /media/lcd    vfat   rw,noatime   0 0
    Nun aber mal meine alles entscheidene Preisfrage... warum gab blkid jetzt erst das display mit aus??? hast du das sonst immer abgeklemmt gehabt?


    Jetzt hat er die Platte als sdb1 erkannt und nach sdb1 gemountet. (Nachdem ich mit dem WM Plugin nen Spinner bekommen habe, musste ich den Schalter umlegen)
    root@et10000:~# cat /sys/block/sda/removable # 0=fest 1=removable
    cat: can't open '/sys/block/sda/removable': No such file or directory
    root@et10000:~#
    Könntest du wenigstens nach jedem neustart mal schauen was wie wo gemountet oder erkannt wurde.... hier wird man noch ganz wirr weil man nie weiß über welches gerät wir grad reden. Andernfalls sind diese outputs für uns rein informativ sinnlos.

    Also erst ein

    ~# mount |grep vfat
    die Gerätedatei nehmen und in für die beiden Befehle verwenden. Sonszt drehen wir weiter im Kreis

    LG niki
    Geändert von -=niki=- (25.06.2014 um 19:57 Uhr)


Seite 8 von 9 ErsteErste ... 6789 LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 20:10 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,11%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com