Thanks Thanks:  0
Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 21

Thema: USB Automount

  1. #1
    Mitglied
    Registriert seit
    12.05.2013
    Beiträge
    48
    Total Downloaded
    17,21 MB
    Total Downloaded
    17,21 MB
    ReceiverDankeAktivitäten

    USB Automount

    Hi,

    an meiner Solo hab ich über einen USB Hub 2 Festplatten an einem USB Port angeschlossen. Die Geräte sdb und sdc wurden korrekt erkannt. Wenn ich in der fstab die Platten anhand der UUID nach Media/USB1 und USB2 mounte, funkt mir die Automount Funktion immer weder da zwischen und mountet eine Platte nach media/USB. In welcher Datei kann ich die automount Funktion verändern, so dass diese beiden Platten nach USB1 und USB2 gemountet werden?

    Gruß Stucki

    •   Alt Advertising

       

  2. #2
    Avatar von Topfi
    Registriert seit
    05.04.2013
    Beiträge
    587
    Total Downloaded
    5,76 MB
    Total Downloaded
    5,76 MB
    ReceiverDankeAktivitäten
    Du kannst das mit dem Mountmanager im Image interaktiv erledigen.
    Allerdings meine ich, dass der auch nur die entsprechenden Einträge in der fstab vornimmt. Aber Du kannst es ja dennoch mal versuchen.

  3. #3
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.825
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Hi,

    Allerdings meine ich, dass der auch nur die entsprechenden Einträge in der fstab vornimmt
    Ja genauso siehts aus.

    Wenn ich in der fstab die Platten anhand der UUID nach Media/USB1 und USB2 mounte, funkt mir die Automount Funktion immer weder da zwischen und mountet eine Platte nach media/USB
    Was genau heisst funkt dazwischen ?
    Hier mounte ich auch alles mittels uuid per fstab und das klappt - zwar kanns sein das der Automounter auch noch irgendwas irgendwohin mountet (also quasi zusätzlich)
    aber die Mounts in der fstab halten bombenfest und das der Automounter zusätzlich noch irgendwo hinmountet stört nicht weiter.

    Allerdings kanns ein Problem geben wenn man nicht die vorgekauten Mountpoints verwendet wie usb,usb1 usw.. und hdd,hdd1 usw..
    dann kanns sein das es nicht klappt (war hier nämlich so der Fall als ich mal die Externe Usb Platte nach /media/ext_hdd1 mounten wollte)
    dabei wurde tatsächlich der Mountpoint /media/ext_hdd1 völlig ignoriert.
    Danach hab ich mal gesehen wohin der Mountmanager mountet und mich dann an dieses gehalten also usb,usb1 usw.. und hdd,hdd1 usw.. dann klappte es auch wieder mit fstab und uuid.

    Wenn du also nach USB1 und USB2 mounten möchtest (also gross geschrieben) hast vielleicht genau das Problem auch, und für mich siehts auch eher
    danach aus als funkt nicht der Automounter dazwischen sondern der Mountmanager denn in nem PLI ist ja auch der Automounter
    aber da kann ich per uuid und fstab hinmounten wohin ich will und es gibt keinerlei Probleme dann.

    Grüsse
    Biki3
    Geändert von Pike_Bishop (10.12.2013 um 19:27 Uhr)

  4. #4
    Mitglied
    Registriert seit
    12.05.2013
    Beiträge
    48
    Themenstarter
    Total Downloaded
    17,21 MB
    Total Downloaded
    17,21 MB
    ReceiverDankeAktivitäten
    Irgendwie komisch, wenn ich in der Mountverwaltung folgende Einstellungen vornehme und diese auch speichere:

    sdc1 /media/usb
    sdb1 /media/usb1

    Dann ist nur eine platte in /media/usb gemounted, dass Verzeichnis für /media/usb1 wurde erstellt und ist leer. Geh ich nun wieder in die Mountverwaltung, dann ist für beide Platten /media/usb eingetragen. Ich vermute das die Box nicht damit zurecht kommt, dass an einem USB Port 2 Platten angeschlossen sind.

    In der Fstab sind keine Einträgen zum mounten der Platten eingetragen.

  5. #5
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.825
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Und was sagt der telnet Befehl;
    Code:
    mount
    und auch;
    Code:
    blkid
    in deinem jetzigen Fall ?

    In der Fstab sind keine Einträgen zum mounten der Platten eingetragen.
    Jetzt auch nicht - sicher ?
    Denn die Mountverwaltung macht ja Einträge in der fstab -poste die doch auch mal.

    Grüsse
    Biki3

  6. #6
    Mitglied
    Registriert seit
    12.05.2013
    Beiträge
    48
    Themenstarter
    Total Downloaded
    17,21 MB
    Total Downloaded
    17,21 MB
    ReceiverDankeAktivitäten
    USB Automount-mount.jpg

    Komisch:
    /dev/sdb1 on /media/hdd
    /dev/sda1 on /media/hdd
    In der fstab /hdd und /usb2

    Das Verzeichnis usb2 ist leer, dafür ist in /hdd der Inhalt von /usb2.

    /dev/sdb1: UUID="77d25802-0177-4b3b-abcd-5347463482a3" Ist nicht gemounted<---- Der Stick dient als HDD

    sda1 = 3 Tb ntfs Usb 3.0 Platte
    sdb1 = 15 Gb Usb Stick
    sdc1 = 3 Tb ntfs Usb 3.0 Platte

    Sobald drei USB Geräte angeschlossen sind, scheint es Probleme zu geben.
    Geändert von stucki (10.12.2013 um 21:36 Uhr)

  7. #7
    Mitglied
    Registriert seit
    12.05.2013
    Beiträge
    48
    Themenstarter
    Total Downloaded
    17,21 MB
    Total Downloaded
    17,21 MB
    ReceiverDankeAktivitäten
    Hab jetzt mal alle drei Einträge in der fstab gelöscht. Solo ohne USB Anhängsel gestartet.

    1. UUID="77d25802-0177-4b3b-abcd-5347463482a3" 15 GB angeschlossen und zu /hdd gemounted. (mountmanager)
    2.Neustart Solo = /hdd OK!
    3. UUID="188E60CF4DD3549C" und UUID=445E8A205E8A0ABE angeschlossen zu /usb bzw /usb2 gemounted. (mountmanager)
    4. Neustart Solo : /hdd = Inhalt einer Platte, /hdd2=leer, /usb=Inhalt der anderen Platte, Der Stick fehlt nun.
    USB Automount-mount2.jpg

  8. #8
    Avatar von -=niki=-
    Registriert seit
    07.04.2013
    Beiträge
    826
    Total Downloaded
    19,78 MB
    Total Downloaded
    19,78 MB
    ReceiverDankeAktivitäten
    Box 1:
    Gigablue Solo @ ATV4
     
     
    Box 2:
    Sogno 8800HD @ ATV4 / PLI4
     
     
    Box 3:
    diverse
     
     
    bevor du dein System noch weiter zerstörst verwende bitte einen unixfähigen Editor wie notepad++ oder pspad und nicht den schei* Windowseditor!

    Den NTFS Treiber hast du schon installiert??

    ~# opkg install ntfs-3g

    Die fstab sollte am Ende so ausschauen:

    Code:
    UUID=77d25802-0177-4b3b-abcd-5347463482a3 /media/hdd ext4 defaults,noatime 0 0
    UUID=188E60CF4DD3549C /media/USB1 ntfs defaults 0 0 
    UUID=445E8A205E8A0ABE /media/USB2 ntfs defaults 0 0
    Am ende mal alle 3 Geräte aushängen per umount /Mount/punkt bzw. umount /Geräte/datei
    Sambaserver vorher notfalls stoppen ... dann nach fstab mounten lassen

    ~# /etc/init.d/samba stop
    ~# umount /dev/sd*
    ~# mount -a
    ~# /etc/init.d/samba start

    Kontolle durch:

    ~# mount

    Das sollte es eigentlich tun

    Lg Niki

    Edit:

    Die UUIDs bitte nochmals kontrollieren ich hab die vom Bild abgetippt... dabei passieren manchmal Fehler
    Die fstab bitte auf das richtige Zeilenende konvertieren lassen. Im Notepad++ unter Bearbeiten->Zeilenede->Unix konvertieren
    Geändert von -=niki=- (11.12.2013 um 00:03 Uhr)

  9. #9
    Mitglied
    Registriert seit
    12.05.2013
    Beiträge
    48
    Themenstarter
    Total Downloaded
    17,21 MB
    Total Downloaded
    17,21 MB
    ReceiverDankeAktivitäten

    Cool

    Zitat Zitat von -=niki=- Beitrag anzeigen
    bevor du dein System noch weiter zerstörst verwende bitte einen unixfähigen Editor wie notepad++ oder pspad und nicht den schei* Windowseditor!

    Den NTFS Treiber hast du schon installiert??

    ~# opkg install ntfs-3g

    Die fstab sollte am Ende so ausschauen:

    Code:
    UUID=77d25802-0177-4b3b-abcd-5347463482a3 /media/hdd ext4 defaults,noatime 0 0
    UUID=188E60CF4DD3549C /media/USB1 ntfs defaults 0 0 
    UUID=445E8A205E8A0ABE /media/USB2 ntfs defaults 0 0
    Am ende mal alle 3 Geräte aushängen per umount /Mount/punkt bzw. umount /Geräte/datei
    Sambaserver vorher notfalls stoppen ... dann nach fstab mounten lassen

    ~# /etc/init.d/samba stop
    ~# umount /dev/sd*
    ~# mount -a
    ~# /etc/init.d/samba start

    Kontolle durch:

    ~# mount

    Das sollte es eigentlich tun

    Lg Niki

    Edit:

    Die UUIDs bitte nochmals kontrollieren ich hab die vom Bild abgetippt... dabei passieren manchmal Fehler
    Die fstab bitte auf das richtige Zeilenende konvertieren lassen. Im Notepad++ unter Bearbeiten->Zeilenede->Unix konvertieren
    Danke, ich teste die Tage mal.

  10. #10
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.825
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Ich würd mal auf den MountManager pfeifen also alle Einträge die der gemacht hat raus aus der fstab
    und alle Datenträger manuell per uuid in die fstab eintragen wobei ich aber die beiden davon;
    Code:
    UUID=188E60CF4DD3549C /media/USB1 ntfs defaults 0 0
    UUID=445E8A205E8A0ABE /media/USB2 ntfs defaults 0 0
    eher so machen würde;
    Code:
    UUID=188E60CF4DD3549C /media/usb1 ntfs defaults 0 0
    UUID=445E8A205E8A0ABE /media/usb2 ntfs defaults 0 0
    also Mountpoints kleingeschrieben.

    Wenns dann nach nem Neustart immer noch nicht perfekt will - ja das kann dann auch am Hub liegen
    jedenfalls hatte ich hier mit nem bestimmten aktiven Hub auch sehr seltsames beobachtet.
    Mit nem anderen passiven Hub hingegen klappt hier ein USB Stick und eine USB Patte gemeinsam an einem USB Port der Box tadellos.

    Grüsse
    Biki3
    Geändert von Pike_Bishop (11.12.2013 um 20:18 Uhr)


Seite 1 von 3 123 LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 23:48 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,11%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com