Thanks Thanks:  7
Seite 2 von 9 ErsteErste 1234 ... LetzteLetzte
Ergebnis 11 bis 20 von 83
  1. #11
    Avatar von betacentauri
    Registriert seit
    15.06.2013
    Beiträge
    1.573
    Total Downloaded
    1,32 MB
    Total Downloaded
    1,32 MB
    ReceiverDankeAktivitäten
    Box 1:
    ET-9200
     
     
    Box 2:
    ET-10000
     
     
    Box 3:
    ET-8500
     
     
    Box 4:
    ET-8000
     
     
    Box 5:
    Gigablue Quad+
     
     
    Geht wohl leider nicht, da ich eine Xtrend 9200 habe...

    @Captain: Habt ihr noch alte Images für die 9x00 irgendwo rumliegen? Irgendein Image vor dem sagen wir mal besser 20.05.. (um ganz sicher zu gehen).

    •   Alt Advertising

       

  2. #12
    Anfänger
    Registriert seit
    25.04.2013
    Ort
    Erzgebirge
    Beiträge
    24
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    GIGABLUE 800 SOLO
     
     
    Box 2:
    VU+ Solo 2
     
     
    Zitat Zitat von betacentauri Beitrag anzeigen
    Geht wohl leider nicht, da ich eine Xtrend 9200 habe...

    @Captain: Habt ihr noch alte Images für die 9x00 irgendwo rumliegen? Irgendein Image vor dem sagen wir mal besser 20.05.. (um ganz sicher zu gehen).

    sorry, war der meinung du hast eine solo2
    im downloadbereich ist noch ein images vom 01.06. vorhanden,das sollte eigentlich funktionieren, fehler ist lt. @Captain
    ab dem 02.06. vorhanden. einfach mal testen
    Geändert von wuschel85 (18.06.2013 um 22:22 Uhr)

  3. #13
    Avatar von betacentauri
    Registriert seit
    15.06.2013
    Beiträge
    1.573
    Total Downloaded
    1,32 MB
    Total Downloaded
    1,32 MB
    ReceiverDankeAktivitäten
    Box 1:
    ET-9200
     
     
    Box 2:
    ET-10000
     
     
    Box 3:
    ET-8500
     
     
    Box 4:
    ET-8000
     
     
    Box 5:
    Gigablue Quad+
     
     
    Image teste ich mal gleich...


    Ich habe das gerade mal versucht zu debuggen. Es sieht für mich so aus, dass 16bit flac Dateien generell abgespielt werden können. Das funktioniert bei mir aber auch nicht immer aber häufig (ist schon sehr komisch).
    Dann habe ich noch welche mit 24bit (laut gstreamer 32 width und 24 depth) und die können nicht abgespielt werden.
    Da habe ich folgende Meldung im Debug gesehen:
    <resample> transform could not transform audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)32, depth=(int)24, rate=(int)96000, channels=(int)2 in anything we support
    Angeblich kann er also das Format nicht in ein unterstütztes Format wie beispielsweise width = 16 depth=16 umwandeln.


    Das Interessante dabei ist, dass wenn ich die gleiche flac Datei auf der Box mit gst-launch verarbeite, kann ich ein resample ohne Probleme durchführen:
    gst-launch-0.10 filesrc location="./xyz.flac" ! decodebin2 ! audioconvert ! audioresample ! audio/x-raw-int,depth=16,width=16,rate=44100 ! dvbaudiosink -v
    Da kommt keine Fehlermeldung und laut Log sieht es auch gut aus:
    /GstPipelinepipeline0/GstAudioConvert:audioconvert0.GstPad:sink: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)32, depth=(int)24, rate=(int)96000, channels=(int)2
    /GstPipelinepipeline0/GstAudioResample:audioresample0.GstPad:src: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
    /GstPipelinepipeline0/GstAudioResample:audioresample0.GstPad:sink: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)96000, channels=(int)2
    /GstPipelinepipeline0/GstCapsFilter:capsfilter0.GstPad:src: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
    /GstPipelinepipeline0/GstCapsFilter:capsfilter0.GstPad:sink: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
    /GstPipelinepipeline0/GstDVBAudioSink:dvbaudiosink0.GstPad:sink: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2

    Also irgendetwas stimmt da nicht. Ich würde mal tippen, dass die einzelnen Elemente auf der Box nicht in der richtigen Reihenfolge hintereinanderhängen. Also beispielsweise die dvbaudiosink irgendwo vor dem audioresample...

  4. #14
    Avatar von betacentauri
    Registriert seit
    15.06.2013
    Beiträge
    1.573
    Total Downloaded
    1,32 MB
    Total Downloaded
    1,32 MB
    ReceiverDankeAktivitäten
    Box 1:
    ET-9200
     
     
    Box 2:
    ET-10000
     
     
    Box 3:
    ET-8500
     
     
    Box 4:
    ET-8000
     
     
    Box 5:
    Gigablue Quad+
     
     
    Also das Image vom 01.06. spielt meine flac-Dateien auch nicht ab...

    Na ja, ich versuch mal den Fehler zu finden...

  5. #15
    Avatar von Captain
    Registriert seit
    03.04.2013
    Beiträge
    10.769
    Total Downloaded
    162,35 MB
    Total Downloaded
    162,35 MB
    ReceiverDankeAktivitäten
    ich kann erst zum we mit checken bin unterwegs, ich hatte aber flac files schon getestet und zwar erfolgreich welches format die hatten ?

    das 1.6 image hat klar den alten gst, kannst du mal das blackhole image testen ob es da geht die haben den subsink vom dream original genommen

  6. #16
    Avatar von betacentauri
    Registriert seit
    15.06.2013
    Beiträge
    1.573
    Total Downloaded
    1,32 MB
    Total Downloaded
    1,32 MB
    ReceiverDankeAktivitäten
    Box 1:
    ET-9200
     
     
    Box 2:
    ET-10000
     
     
    Box 3:
    ET-8500
     
     
    Box 4:
    ET-8000
     
     
    Box 5:
    Gigablue Quad+
     
     
    Ich habe das Problem gefunden und eine Lösung dazu

    Also meine Testdateien hatten relativ hohe Sampleraten. Dateien mit 44100Hz und 48000Hz spielt die Box ab. Ich habe aber welche mit 96000Hz. Und die werden nicht abgespielt. Das liegt daran, dass die Audiosink behauptet, dass sie alle Sampleraten (1-MAX) abspielen kann. Kann sie aber scheinbar nicht.

    Also einfach in der gstdvbaudiosink.c die MAX durch 48000 ersetzen und schon werden die Dateien automatisch auf 48000Hz runtergesampelt:

    Code:
    "audio/x-raw-int, " \
            "endianness = (int) { " G_STRINGIFY(G_BYTE_ORDER) " }, " \
            "signed = (boolean) { TRUE, FALSE }, " \
            "width = (int) 32, " \
            "depth = (int) 32, " \
            "rate = (int) [ 1, MAX ], " "channels = (int) [ 1, 2 ]; " \
            "audio/x-raw-int, " \
            "endianness = (int) { " G_STRINGIFY(G_BYTE_ORDER) " }, " \
            "signed = (boolean) { TRUE, FALSE }, " \
            "width = (int) 24, " \
            "depth = (int) 24, " \
            "rate = (int) [ 1, MAX ], " "channels = (int) [ 1, 2 ]; " \
            "audio/x-raw-int, " \
            "endianness = (int) { " G_STRINGIFY(G_BYTE_ORDER) " }, " \
            "signed = (boolean) { TRUE, FALSE }, " \
            "width = (int) 16, " \
            "depth = (int) 16, " \
            "rate = (int) [ 1, MAX ], " "channels = (int) [ 1, 2 ]; " \
            "audio/x-raw-int, " \
            "signed = (boolean) { TRUE, FALSE }, " \
            "width = (int) 8, " \
            "depth = (int) 8, " \
            "rate = (int) [ 1, MAX ], " "channels = (int) [ 1, 2 ];"
    Neu
    Code:
    "audio/x-raw-int, " \
            "endianness = (int) { " G_STRINGIFY(G_BYTE_ORDER) " }, " \
            "signed = (boolean) { TRUE, FALSE }, " \
            "width = (int) 32, " \
            "depth = (int) 32, " \
            "rate = (int) [ 1, 48000 ], " "channels = (int) [ 1, 2 ]; " \
            "audio/x-raw-int, " \
            "endianness = (int) { " G_STRINGIFY(G_BYTE_ORDER) " }, " \
            "signed = (boolean) { TRUE, FALSE }, " \
            "width = (int) 24, " \
            "depth = (int) 24, " \
            "rate = (int) [ 1, 48000 ], " "channels = (int) [ 1, 2 ]; " \
            "audio/x-raw-int, " \
            "endianness = (int) { " G_STRINGIFY(G_BYTE_ORDER) " }, " \
            "signed = (boolean) { TRUE, FALSE }, " \
            "width = (int) 16, " \
            "depth = (int) 16, " \
            "rate = (int) [ 1, 48000 ], " "channels = (int) [ 1, 2 ]; " \
            "audio/x-raw-int, " \
            "signed = (boolean) { TRUE, FALSE }, " \
            "width = (int) 8, " \
            "depth = (int) 8, " \
            "rate = (int) [ 1, 48000 ], " "channels = (int) [ 1, 2 ];"
    Edit: Patch angehängt.
    Angehängte Dateien Angehängte Dateien
    Geändert von betacentauri (19.06.2013 um 22:14 Uhr)

  7. Thanks schwallobert, Captain, giopet, Black_64 bedankten sich
  8. #17
    Anfänger
    Registriert seit
    14.04.2013
    Beiträge
    23
    Themenstarter
    Total Downloaded
    31,9 KB
    Total Downloaded
    31,9 KB
    ReceiverDankeAktivitäten
    Also bei mir werden die FLAC-Dateien eigentlich schon problemlos abgespielt, man kann aber nicht zum nächsten Titel springen oder die Wiedergabe stoppen.
    Es ist halt immer sofort der Spinner zu sehen. Nur ganz selten geht der mal kurz aus, und das ist dann der Moment, wo man das ganze stoppen kann.

    Habt Ihr das auch, oder werden die Titel bei Euch gar nicht erst gespielt?

  9. #18
    Avatar von betacentauri
    Registriert seit
    15.06.2013
    Beiträge
    1.573
    Total Downloaded
    1,32 MB
    Total Downloaded
    1,32 MB
    ReceiverDankeAktivitäten
    Box 1:
    ET-9200
     
     
    Box 2:
    ET-10000
     
     
    Box 3:
    ET-8500
     
     
    Box 4:
    ET-8000
     
     
    Box 5:
    Gigablue Quad+
     
     
    Ne die Probleme habe ich nicht. Habe aber auch ein OpenPli am laufen. Muss aber nicht damit zusammenhängen.
    Kannst du mal die Codecinformationen also samplerate und so weiter mal posten?

  10. #19
    Anfänger
    Registriert seit
    14.04.2013
    Beiträge
    23
    Themenstarter
    Total Downloaded
    31,9 KB
    Total Downloaded
    31,9 KB
    ReceiverDankeAktivitäten
    ...ich habe Blackhole und VTI getestet: Keine Probleme!

    ...mit openATV vom 21.05.2013 (Driver 20130508) ebenfalls alles klar!
    Geändert von GerdMueller (22.06.2013 um 19:15 Uhr)

  11. #20
    Senior Mitglied
    Registriert seit
    24.04.2013
    Ort
    TR
    Beiträge
    115
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    vu+/solo2
     
     
    Seit der wechsel zu oe2.1 haben einige imagen probleme mit FLAC / WAV / OGG. Test mit Media Player und Yamp Player. Bei flac und wave dateien, beim start begint bei 10 sekunden an zu zahlen. Bei ogg begint bei 5 sekunden an zu zehlen. Damit wird 5 oder 10 sekunden zu früh beendet. Habe getestet Black Hole/Vti/orginal images 1.6 und 2.1 . Das einzige was keine probleme mit flac / wave / ogg hat ist Orginal images 1.6 oder man muss vor der wechsel zu oe2.1 image benutzen.
    İch mache das problem etwas deutlicher. Mit nur ein lied wird mann das problem nicht unbedingt merken. Wen mann aber im pleilist mehrere music hatt. Nun startet das music, es wird von anfang korekt abgespielt. Aber der ZEHLER begint bei 10 sekunden oder 5 sekunden bei ogg datei an zu zehlen. Somit wird 10 odr 5 sekunden zu früh zu nehsten lied gewechselt. Damit ist flac/wave/ogg nicht zu gebrauchen.
    Leider konnte ich mit Openatv nicht testen, Weil ich mit Yamp Player instalieren problem hatte. Yamp Player ist für mich ein Muss.

    Hoffe das das problem bald ein ende hatt. Leider, hoffe schon bereits seit minestens 4 monaten...


Seite 2 von 9 ErsteErste 1234 ... LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 23:54 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 10,53%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com