Thanks Thanks:  13
Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 24
  1. #11
    +++Teletexter+++ Avatar von willy01
    Registriert seit
    05.04.2013
    Beiträge
    5.702
    Total Downloaded
    6,34 MB
    Total Downloaded
    6,34 MB
    ReceiverDankeAktivitäten
    Box 1:
    VuUno4K SE
     
     
    Box 2:
    Dinobot 4K
     
     
    Ja genau, Rechte 755


    VuUno4kSE / Hisense H55MEC3050

    Unicable Dur-line DCR 5-1-8

    •   Alt Advertising

       

  2. #12
    Senior Mitglied
    Registriert seit
    19.09.2014
    Ort
    Thüringer
    Beiträge
    1.809
    Total Downloaded
    229,02 MB
    Total Downloaded
    229,02 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mut@nt HD 51 UHD
     
     
    Box 2:
    Mut@nt HD 51 UHD
     
     
    Box 3:
    Mut@nt HD 51 UHD
     
     
    Box 4:
    GB Quad Plus
     
     
    Box 5:
    Octagon SF8008
     
     
    Bin auf Spätschicht, denke aber das die zu kopierenden Dateien nur 644 haben.
    Hatte nach Flash in die Ordner geschaut.
    Es waren nicht die neuen sondern die originalen.

    MfG

  3. #13
    Avatar von Papi2000
    Registriert seit
    20.04.2013
    Beiträge
    14.260
    Total Downloaded
    593,97 MB
    Total Downloaded
    593,97 MB
    ReceiverDankeAktivitäten
    Box 1:
    GB Q4K-SC / UE4K-SC / UE4K-C
     
     
    Box 2:
    GigaBlue Q-SSC / Q+-SSC
     
     
    Box 3:
    DM900uhd-SS / Vu+Duo
     
     
    Box 4:
    E4HD FormF3 AX Triplex VIP2-CC
     
     
    Box 5:
    diverse andere . . .
     
     
    @Anskar:
    wechsele mal in deiner /media/hdd/images/config/myrestore.sh in der ersten Zeile das "#!/bin/sh" gegen das aktuelle "#!/bin/bash".
    Das sollte Wunder gegen die Fehlermeldung "Interpreter nicht gefunden" bewirken.
    Testweise kannst du das Script vorher/ nachher auch mal auf der Konsole aufrufen:
    Code:
    /media/hdd/images/config/myrestore.sh
    Dann siehst du gleich, ob es überhaupt laufen kann.
    Wenn das geht, wird es auch beim "fast restore" gehen. Ist mir nach dem Wechsel des Interpreters im Image auch erst passiert.

    EDIT:
    Seltsamerweise gibt es einen neuen Fehler.
    Jeder der beiden verlinkten Aliases (sh und bash zur /bin/bash.bash) bringen Fehler...
    Code:
    ...
    Package bash (5.0-r0) installed in root is up to date.
    root@GBQuad4k-3:~# opkg install --force-reinstall bash
    Downloading http://feeds2.mynonpublic.com/6.4/gb7252/cortexa15hf-neon-vfpv4/bash_5.0-r0_cortexa15hf-neon-vfpv4.ipk.
    Reinstalling bash (5.0-r0) on root.
    Installing bash (5.0) on root.
    update-alternatives: removing /bin/bash as no more alternatives exist for it
    update-alternatives: Linking /bin/sh to /bin/busybox.nosuid
    Configuring bash.
    update-alternatives: Linking /bin/bash to /bin/bash.bash
    update-alternatives: Linking /bin/sh to /bin/bash.bash
    root@GBQuad4k-3:~# /usr/script/HDD_Sleep.sh
    /usr/script/HDD_Sleep.sh: line 1: #!/bin/bash: No such file or directory
    ...
    Script wird aber abgearbeitet...
    und:
    ...
    root@GBQuad4k-3:~# /usr/script/HDD_Sleep.sh
    /usr/script/HDD_Sleep.sh: line 1: #!/bin/sh: No such file or directory
    ...
    Script wird aber abgearbeitet...
    Geändert von Papi2000 (25.01.2020 um 16:24 Uhr) Grund: erweitert, korrigiert
    Grüßle
    Ralf
    ------------------------------------------------------------------------------------------------------------------------
    Gigablue Quad 4K-multi,Quad+-SSC,Quad-SSC, andere Gigas, Astra 19.2E, UniCable & KabelBW, oATV/ teamBlue
    (weitere: DM900uhd,Vu+Duo,Technisat,Edision),PC-DVB-S/C/T,PCH-A110,Xtreamer,BDP5200
    UE32C5700,UE65HU7590,LG42R51
    ---- Einen Receiver kann sich jeder kaufen - Eine stabile E²-Box muß man sich verdienen! ----



  4. #14
    Senior Mitglied
    Registriert seit
    19.09.2014
    Ort
    Thüringer
    Beiträge
    1.809
    Total Downloaded
    229,02 MB
    Total Downloaded
    229,02 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mut@nt HD 51 UHD
     
     
    Box 2:
    Mut@nt HD 51 UHD
     
     
    Box 3:
    Mut@nt HD 51 UHD
     
     
    Box 4:
    GB Quad Plus
     
     
    Box 5:
    Octagon SF8008
     
     
    Was mich halt wundert ist das die .py wegen dem VMC Plugin schon ewig zuverlässig getauscht wird.
    Das war ja bis heute meine myrestore.sh.
    Siehe #5 erster Code.

    MfG

  5. #15
    Mitglied
    Registriert seit
    18.11.2014
    Beiträge
    83
    Themenstarter
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    Dreambox 900
     
     
    Hallo Anskar !

    Ich bin leider nur ein Autodidakt und habe alles durch "try and error" hinbekommen, daher weiß ich nicht, ob ich Dir noch weiterhelfen kann. Zwei Sachen würde ich Dir unter diesen Umständen noch vorschlagen:

    1.) Bei der Angabe des Zielordners würde ich, wie in meinem Skript, das abschließende "/"-Zeichen setzen, also
    cp -rf /media/hdd/flashdateien/subservices.xml /etc/enigma2/
    und nicht wie bei Dir
    cp -rf /media/hdd/flashdateien/subservices.xml /etc/enigma2

    2.) Bei notepad++ würde ich auf das Format beim Zeilenende achten, also
    Bearbeiten/Format Zeilenende/UNIX !

    Vielleicht hilft das ja weiter.

    Dir ein schönes Wochenende,
    Aumag

  6. Thanks Anskar bedankten sich
  7. #16
    Senior Mitglied
    Registriert seit
    19.09.2014
    Ort
    Thüringer
    Beiträge
    1.809
    Total Downloaded
    229,02 MB
    Total Downloaded
    229,02 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mut@nt HD 51 UHD
     
     
    Box 2:
    Mut@nt HD 51 UHD
     
     
    Box 3:
    Mut@nt HD 51 UHD
     
     
    Box 4:
    GB Quad Plus
     
     
    Box 5:
    Octagon SF8008
     
     
    Auch noch wach ;-)
    Ich danke Dir, denke das könnte das Problem sein.
    Werde ich heute zeitnah testen und berichten.
    Hatte ich wohl gestern beim erstellen "meiner" myrestore.sh einen Denkfehler.

    MfG

  8. #17
    +++Teletexter+++ Avatar von willy01
    Registriert seit
    05.04.2013
    Beiträge
    5.702
    Total Downloaded
    6,34 MB
    Total Downloaded
    6,34 MB
    ReceiverDankeAktivitäten
    Box 1:
    VuUno4K SE
     
     
    Box 2:
    Dinobot 4K
     
     
    Der slash ganz am Ende wird nicht benötigt.


    VuUno4kSE / Hisense H55MEC3050

    Unicable Dur-line DCR 5-1-8

  9. #18
    Senior Mitglied
    Registriert seit
    19.09.2014
    Ort
    Thüringer
    Beiträge
    1.809
    Total Downloaded
    229,02 MB
    Total Downloaded
    229,02 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mut@nt HD 51 UHD
     
     
    Box 2:
    Mut@nt HD 51 UHD
     
     
    Box 3:
    Mut@nt HD 51 UHD
     
     
    Box 4:
    GB Quad Plus
     
     
    Box 5:
    Octagon SF8008
     
     
    Zitat Zitat von Papi2000 Beitrag anzeigen
    @Anskar:
    wechsele mal in deiner /media/hdd/images/config/myrestore.sh in der ersten Zeile das "#!/bin/sh" gegen das aktuelle "#!/bin/bash".
    Das sollte Wunder gegen die Fehlermeldung "Interpreter nicht gefunden" bewirken.
    Testweise kannst du das Script vorher/ nachher auch mal auf der Konsole aufrufen:
    Code:
    ./media/hdd/images/config/myrestore.sh
    Dann siehst du gleich, ob es überhaupt laufen kann.
    Wenn das geht, wird es auch beim "fast restore" gehen. Ist mir nach dem Wechsel des Interpreters im Image auch erst passiert.

    Hallo Papi2000,
    habe das /sh gegen /bash per Notepad++ ersetzt.
    Sieht nun so aus in meiner myrestore.sh:

    Code:
    #!/bin/bash
    #
    # Install-Script für Plugins nach Image-Install
    #
    
    ###### VMC Dateien tauschen ######
    cp -f /media/hdd/images/ipk/VMC_BaseFunctions.py /usr/lib/enigma2/python/Plugins/Extensions/VMC
    
    # SICHERUNGEN
    cp -rf /media/hdd/flashdateien/subservices.xml /etc/enigma2
    cp -rf /media/hdd/flashdateien/templates-infobar-style-x1.xml /usr/lib/enigma2/python/Plugins/Extensions/KravenVB/data
    Habe den Befehl von Dir per Telnet eingegeben.
    Ausgabe ist so:

    Code:
      
     Welcome to openATV for mutant51_2  
    openatv 6.3 mutant51_2                                                                                                                                                                                                                                                                                                                                                                                                                                  mutant51_2 login: root  
    root@mutant51_2:~# ./media/hdd/images/config/myrestore.sh  
    -bash: ./media/hdd/images/config/myrestore.sh: No such file or directory
    In dem Ordner /media/hdd/flashdateien sieht es wie auf dem Screenshot aus.

    Habe nun das aktuelle oatv 6.3 installiert.
    Beim Start kam diesmal kein "Fast Restore in progress..." sondern es lief der komplette Erstassistent durch.

    Hänge auch mal meine "myrestore.sh" an.

    MfG

    Habe nun wieder meine alte myrestore.sh genommen (die nur wegen VMC) und nach Imageinstallation und Neustart wird "FastRestore in progress ..." wieder normal ausgeführt.

    MfG

    Irgendwie funktioniert doch das Wiederherstellen nicht so wie es soll, ist jedenfalls meine Feststellung.
    Ich habe folgendes unter Menü/.../Softwareverwaltung/Erweiterte Optionen/ Zusätzliche zu sichernde Dateien gespeichert:

    -"pstrCnvrt.py", "pstrRndr.py" und "templates-infobar-style-x1.xml" (alles wegen Poster im Skin)
    nach "FastRestore in Progress..." werden aber nur "pstrCnvrt.py", "pstrRndr.py" eingefügt
    "templates-infobar-style-x1.xml" ist die orginale vom Skin, wurde nicht ersetzt.

    -"SkyTheMovieDB.py", "SkyTheMovieDB.pyo" (alles wegen Skyrecorder-Plugin)
    diese Dateien werden ersetzt

    Wenn ich meine aktuelle "enigma2settingsbackup.tar.gz" am PC entpacke ist auch im /etc/enigma2 Ordner meine eigene "subservices.xml" enthalten.
    Laut willy01 soll ja diese auch ersetzt werden, tut es aber nicht, es ist immer die "orginale" im Ordner nach Imageinstallation.

    Die Datei "VMC_BaseFunctions.py" habe ich nicht per Softwareverwaltung gesichert.
    Die steht in meiner myrestore.sh und wird immer ersetzt.

    Ich verstehe nicht warum verschiedene Dateien per "enigma2settingsbackup.tar.gz" nicht ersetzt werden obwohl sie in der Sicherung enthalten sind.
    Genauso verstehe ich nicht warum auch die beiden .xml Dateien nicht per myrestore.sh ersetzt werden.

    Wäre schön wenn mir da geholfen werden kann.
    Hänge auch mal das aktuell letzte "FastRestore.log" an.


    MfG
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken Ballast entfernen-flashdateien.jpg  
    Angehängte Dateien Angehängte Dateien
    Geändert von Anskar (25.01.2020 um 15:53 Uhr)

  10. #19
    Avatar von Papi2000
    Registriert seit
    20.04.2013
    Beiträge
    14.260
    Total Downloaded
    593,97 MB
    Total Downloaded
    593,97 MB
    ReceiverDankeAktivitäten
    Box 1:
    GB Q4K-SC / UE4K-SC / UE4K-C
     
     
    Box 2:
    GigaBlue Q-SSC / Q+-SSC
     
     
    Box 3:
    DM900uhd-SS / Vu+Duo
     
     
    Box 4:
    E4HD FormF3 AX Triplex VIP2-CC
     
     
    Box 5:
    diverse andere . . .
     
     
    Sorry. Ich habe den Aufruf der myrestore.sh oben noch korrigert - war mit dem vorangestellten Punkt falsch.
    Ohne den Punkt wird es aufgerufen:
    Code:
    /media/hdd/images/config/myrestore.sh
    Grüßle
    Ralf
    ------------------------------------------------------------------------------------------------------------------------
    Gigablue Quad 4K-multi,Quad+-SSC,Quad-SSC, andere Gigas, Astra 19.2E, UniCable & KabelBW, oATV/ teamBlue
    (weitere: DM900uhd,Vu+Duo,Technisat,Edision),PC-DVB-S/C/T,PCH-A110,Xtreamer,BDP5200
    UE32C5700,UE65HU7590,LG42R51
    ---- Einen Receiver kann sich jeder kaufen - Eine stabile E²-Box muß man sich verdienen! ----



  11. #20
    Senior Mitglied
    Registriert seit
    19.09.2014
    Ort
    Thüringer
    Beiträge
    1.809
    Total Downloaded
    229,02 MB
    Total Downloaded
    229,02 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mut@nt HD 51 UHD
     
     
    Box 2:
    Mut@nt HD 51 UHD
     
     
    Box 3:
    Mut@nt HD 51 UHD
     
     
    Box 4:
    GB Quad Plus
     
     
    Box 5:
    Octagon SF8008
     
     
    Hallo Papi2000,

    nun folgend Ausgabe bei der "nur VMC" myrestore.sh

    Code:
       
    Welcome to openATV for mutant51_2
    openatv 6.3 mutant51_2                                                                                                                                                                                                                                                                                                                                                                                                                                 mutant51_2 login: root 
    root@mutant51_2:~# /media/hdd/images/config/myrestore.sh  
    -bash: /media/hdd/images/config/myrestore.sh: cannot execute binary file: Exec format error
    myrestore.sh
    Code:
    #!/bin/sh
    #
    # Install-Script für Plugins nach Image-Install
    #
    
    ###### VMC Dateien tauschen ######
    cp -f /media/hdd/images/ipk/VMC_BaseFunctions.py /usr/lib/enigma2/python/Plugins/Extensions/VMC
    wegen der Umstellung auf bash, Tip von Dir:

    Code:
    #!/bin/bash
    #
    # Install-Script für Plugins nach Image-Install
    #
    
    ###### VMC Dateien tauschen ######
    cp -f /media/hdd/images/ipk/VMC_BaseFunctions.py /usr/lib/enigma2/python/Plugins/Extensions/VMC
    
    # SICHERUNGEN
    cp -rf /media/hdd/flashdateien/subservices.xml /etc/enigma2
    cp -rf /media/hdd/flashdateien/templates-infobar-style-x1.xml /usr/lib/enigma2/python/Plugins/Extensions/KravenVB/data
    Ausgabe auch:

    Code:
    Welcome to openATV for mutant51_2
    openatv 6.3 mutant51_2                                                                                                                                                                                                                                                                                                                                                                                                                                 mutant51_2 login: root 
    root@mutant51_2:~# /media/hdd/images/config/myrestore.sh  
    -bash: /media/hdd/images/config/myrestore.sh: cannot execute binary file: Exec format error
    MfG
    Geändert von Anskar (25.01.2020 um 16:54 Uhr)


Seite 2 von 3 ErsteErste 123 LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 08:01 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2020 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 10,00%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com