Seite 101 von 134 ErsteErste ... 519199100101102103111 ... LetzteLetzte
Ergebnis 1.001 bis 1.010 von 1336

Thema: LCD4linux

  1. #1001
    Avatar von Mr.Servo
    Registriert seit
    10.08.2020
    Ort
    Pfalz / Palatinate
    Beiträge
    706
    Thanks (gegeben)
    435
    Thanks (bekommen)
    434
    Total Downloaded
    20,79 MB
    Total Downloaded
    20,79 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue UHD UE 4k Cable (OpenATV 6.4)
     
     
    Box 2:
    Mut@nt HD51 4k Cable (OpenATV 6.4)
     
     
    Zitat Zitat von 4l3x2k Beitrag anzeigen
    Was wird da bei dir für Audio angezeigt? Nicht dass das die fehlenden sechs Bilder sind.
    LCD4linux-dolby.png LCD4linux-dolbyplus.png LCD4linux-dts.png LCD4linux-dtshd.png

    Habe sämtliche .png's mal hier unten angehängt !

    Zitat Zitat von 4l3x2k Beitrag anzeigen
    Schließe doch mal einen Stick an. Ich kann hier nicht mit interner Platte testen. Es geht wahrscheinlich um das Standby des rotierenden Festwertspeichers oder USB ohne Power.
    Komme aber erst morgen dazu.

    Gruß......Mr.Servo
    Angehängte Dateien Angehängte Dateien
    Wissen ist das einzige Gut, das sich vermehrt, wenn man es teilt. / Knowledge is the only resource that increases when shared.

    •   Alt Advertising

       

  2. #1002

    Registriert seit
    20.12.2016
    Beiträge
    632
    Thanks (gegeben)
    175
    Thanks (bekommen)
    226
    Total Downloaded
    39,16 MB
    Total Downloaded
    39,16 MB
    ReceiverDankeAktivitäten
    Box 1:
    Vu+ Duo 2 oatv 6.3
     
     
    Box 2:
    Golden Interstar LX3 oatv 6.3
     
     
    Box 3:
    Mutant HD2400 oatv 6.3
     
     
    Box 4:
    Octagon SF8008 oatv 6.4 & 6.5, openvision 10.2, Define OS 6.3, OpenPLi 8 & develop
     
     
    Box 5:
    Raspberrypi3 TvHeadend TBS5520SE
     
     
    Mmmm ...

    ... ich muss zugeben das da was schief gegangen ist. r5? ist für oatv 6.4 und r7? ist für oatv 6.5.

    Daher kannst du meine Testergebnisse auch getrost ignorieren!

    Ich habe r7? unter 6.4 getestet!

    Dolby oder DTS Logos hatte ich definitiv nicht, obwohl ich schon so ein großes Display gewählt habe. Sprich das hätte ich auch ohne Brille sehen können.

    Unter 6.5 bekomme ich hier ständig "int" vs "str" Meldungen und damit bin ich raus.

    Die Programmnummer bekomme ich trotzdem nicht.

    Ich bin auch erstmal raus. Sorry.

  3. #1003

    Registriert seit
    20.12.2016
    Beiträge
    632
    Thanks (gegeben)
    175
    Thanks (bekommen)
    226
    Total Downloaded
    39,16 MB
    Total Downloaded
    39,16 MB
    ReceiverDankeAktivitäten
    Box 1:
    Vu+ Duo 2 oatv 6.3
     
     
    Box 2:
    Golden Interstar LX3 oatv 6.3
     
     
    Box 3:
    Mutant HD2400 oatv 6.3
     
     
    Box 4:
    Octagon SF8008 oatv 6.4 & 6.5, openvision 10.2, Define OS 6.3, OpenPLi 8 & develop
     
     
    Box 5:
    Raspberrypi3 TvHeadend TBS5520SE
     
     
    Zeile 4412
    So habe ich auch angefangen. Wir sollten einen anderen Weg gehen. Ein weiteres try: except: für "unser" bitrate ist besser, weil wir nichts ausbauen.
    Dazu sollten wir sowas wie PREFERRED_BITRATE und REGISTRED_BITRATE einführen.
    Beispiel:

    BITRATE_UNREGISTERED = 0
    BITRATEVIEWER = 1
    BITRATE = 2
    PREFERRED_BITRATE = BITRATE
    REGISTERD_BITEATE = BITRATEVIEWER

    try: import bitrareviewer; REGISTERD_BITRATE = BITRATEVIEWER
    except: REGISTERD_BITRATE = BITRATE_UNREGISTERD
    try: import bitrare; REGISTERD_BITRATE = BITRATE
    except: REGISTERD_BITRATE = BITRATE_UNREGISTERD

    if RIGISTERD_BITRATE == BITRATE ...

    Und so weiter. Wir ergänzen in diesem Fall und machen @jockel6m nichts kaputt. Das kann er auf seiner Dream genauso nutzen wie auf einer "Unnamed"-Box.

    Zeile 9167+9176
    Nope. Das wird so nicht funktionieren. Der Funktions-Aufruf ist anders! In diesem Fall ist es nicht mal ein Funktions-Aufruf. Wir lesen einfach eine Variable aus. Am besten die den Mittelwert angibt, also aavg und vavg. Wir haben nur ein 30 Sekunden Intervall.
    Wird sich mit den neuen Variablen sowieso ändern.

    Zeile 12723
    Das wird keinen Unterschied machen.

  4. Thanks zeini bedankten sich
  5. #1004
    Avatar von Mr.Servo
    Registriert seit
    10.08.2020
    Ort
    Pfalz / Palatinate
    Beiträge
    706
    Thanks (gegeben)
    435
    Thanks (bekommen)
    434
    Total Downloaded
    20,79 MB
    Total Downloaded
    20,79 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue UHD UE 4k Cable (OpenATV 6.4)
     
     
    Box 2:
    Mut@nt HD51 4k Cable (OpenATV 6.4)
     
     
    Zitat Zitat von 4l3x2k Beitrag anzeigen
    ... ich muss zugeben das da was schief gegangen ist. r5? ist für oatv 6.4 und r7? ist für oatv 6.5.
    Hi 4l3x2k,

    LCD4Linux V5.0-r5_OA läuft nur unter PY2, also bis OpenATV 6.4. (OA= oe-alliance)
    LCD4Linux V5.0-r5a_OA läuft nur unter PY2 und ist die um die rechteckigen Uhren erweiterte Version

    LCD4Linux V5.0-r7_OA ist eine unfertige Kombilösung für PY2/3, also für alle OpenATV wie 6.4+6.5
    LCD4Linux V5.0-r7g_OA ist die aktuelle lauffähige Testversion für PY2/3, also für alle OpenATV wie 6.4+6.5

    Nicht zu Verwechseln mit folgenden Versionen:
    LCD4Linux V5.0r7_IHAD ist die aktuelle Version von @jockelm6 nur für Dreamboxen, lauffähig nur unter PY2. Als Originalfassung ist das die Blaupause.

    Zitat Zitat von 4l3x2k Beitrag anzeigen
    Daher kannst du meine Testergebnisse auch getrost ignorieren!
    Ich habe r7? unter 6.4 getestet!
    War doch absolut korrekt was Du gemacht hast. LCD4Linux V5.0-r7x_OA ist eine PY2/3-Kombilösung, die läuft auf allen OpenATVs !!! Alles gut...

    Zitat Zitat von 4l3x2k Beitrag anzeigen
    Unter 6.5 bekomme ich hier ständig "int" vs "str" Meldungen und damit bin ich raus.
    Was für Meldungen? Wo kriegst Du die? Ich kann nicht folgen.

    Wenn Du einfach die neueste Testversion V5.0-r7g nimmst und unter OpenATV6.4 und/oder OpenATV6.5 testest, ist doch alles gut.
    Also ich finde keine Fehler mehr, die den Ablauf des Programme verhindern (also z.B. keine Crashs). Wenn Du irgendwo (wo denn genau?) Warnmeldungen erhälst, dann geb mir doch bitte Bescheid. Das kriegen wir dann doch auch noch in den Griff...

    Danke Dir & Gruß......Mr.Servo
    Wissen ist das einzige Gut, das sich vermehrt, wenn man es teilt. / Knowledge is the only resource that increases when shared.

  6. Thanks Papi2000, 4l3x2k bedankten sich
  7. #1005
    Avatar von Mr.Servo
    Registriert seit
    10.08.2020
    Ort
    Pfalz / Palatinate
    Beiträge
    706
    Thanks (gegeben)
    435
    Thanks (bekommen)
    434
    Total Downloaded
    20,79 MB
    Total Downloaded
    20,79 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue UHD UE 4k Cable (OpenATV 6.4)
     
     
    Box 2:
    Mut@nt HD51 4k Cable (OpenATV 6.4)
     
     
    Zitat Zitat von 4l3x2k Beitrag anzeigen
    Zeile 4412
    if RIGISTERD_BITRATE == BITRATE ...
    Und so weiter. Wir ergänzen in diesem Fall und machen @jockel6m nichts kaputt. Das kann er auf seiner Dream genauso nutzen wie auf einer "Unnamed"-Box.
    @jockelm6 und oe-alliance (=OA) haben ohnehin komplett getrennte Versionen!!! Will heißen: @jockelm6 kann unsere OA-Version ohnehin nicht 1:1 übernehmen/verwenden.

    Beispielsweise hat die OA-Version ein sogenanntes "Boxbranding", welches @jockelm6 in seiner IHAD eben nunmal nicht hat.

    Von daher können (und müssen) wir ohnehin unser eigenes OA-"bitrate" verwenden, so wie @jockelm6 sein IHAD-"bitrate" verwendet. Von daher müssen wir nicht auf die IHAD-Dreambox-Details eingehen und können/müssen in diesem Punkt unser eigenes Süppchen kochen.

    Zitat Zitat von 4l3x2k Beitrag anzeigen
    Zeile 9167+9176
    Nope. Das wird so nicht funktionieren. Der Funktions-Aufruf ist anders! In diesem Fall ist es nicht mal ein Funktions-Aufruf. Wir lesen einfach eine Variable aus. Am besten die den Mittelwert angibt, also aavg und vavg. Wir haben nur ein 30 Sekunden Intervall.Wird sich mit den neuen Variablen sowieso ändern.
    Du merkst ja schon, daß ich mit Python etwas kämpfe. Aber ich versuche täglich dazuzulernen! Von daher ist mir Deine Meinung sehr wichtig!!!

    Wie würdest Du denn die Abfrage aufbauen? Was würde Sinn machen mit dem Wissen: Wir brauchen auf IHAD und die Dreamboxen keine Rücksicht nehmen...

    Ich selbst bin nicht so fit in den Tiefen von Python und ich könnte Deine Unterstützung wirklich gut gebrauchen. Selbst wenn eine Idee in eine Sackgasse führen würde - na und? Dann findet sich ein anderer Weg. Ist doch nicht schlimm. Wir können uns auch gerne per PN austauschen, alles ist gut!

    Danke Dir & Gruß......Mr.Servo
    Geändert von Mr.Servo (27.02.2021 um 23:04 Uhr)
    Wissen ist das einzige Gut, das sich vermehrt, wenn man es teilt. / Knowledge is the only resource that increases when shared.

  8. Thanks Papi2000, zeini bedankten sich
  9. #1006

    Registriert seit
    20.12.2016
    Beiträge
    632
    Thanks (gegeben)
    175
    Thanks (bekommen)
    226
    Total Downloaded
    39,16 MB
    Total Downloaded
    39,16 MB
    ReceiverDankeAktivitäten
    Box 1:
    Vu+ Duo 2 oatv 6.3
     
     
    Box 2:
    Golden Interstar LX3 oatv 6.3
     
     
    Box 3:
    Mutant HD2400 oatv 6.3
     
     
    Box 4:
    Octagon SF8008 oatv 6.4 & 6.5, openvision 10.2, Define OS 6.3, OpenPLi 8 & develop
     
     
    Box 5:
    Raspberrypi3 TvHeadend TBS5520SE
     
     
    Zitat Zitat von Mr.Servo Beitrag anzeigen
    Was für Meldungen? Wo kriegst Du die? Ich kann nicht folgen.

    Wenn Du einfach die neueste Testversion V5.0-r7g nimmst und unter OpenATV6.4 und/oder OpenATV6.5 testest, ist doch alles gut.
    Also ich finde keine Fehler mehr, die den Ablauf des Programme verhindern (also z.B. keine Crashs). Wenn Du irgendwo (wo denn genau?) Warnmeldungen erhälst, dann geb mir doch bitte Bescheid. Das kriegen wir dann doch auch noch in den Griff...

    Danke Dir & Gruß......Mr.Servo
    Ja das war mein Fehler. Ich sollte natürlich die Version 7g hier aus dem Thema nehmen.

    Gestern oatv 6.5 sauber geflasht und dort das bitrate eingebaut. Dann wollte ich nochmal mit der Programm Nummer testen und erhielt
    Code:
    Traceback (most recent call last):
    File "/usr/lib/enigma2/python/Plugins/Extensions/LCD4linux/plugin.py", line 4568, in run
    para[0](para[1], para[2], para[3])
    File "/usr/lib/enigma2/python/Plugins/Extensions/LCD4linux/plugin.py", line 11842, in putChannelNum
    font = ImageFont.truetype(ConfigFont, ConfigSize, encoding='unic')
    File "/usr/lib/python3.8/site-packages/PIL/ImageFont.py", line 655, in truetype
    return freetype(font)
    File "/usr/lib/python3.8/site-packages/PIL/ImageFont.py", line 652, in freetype
    return FreeTypeFont(font, size, index, encoding, layout_engine)
    File "/usr/lib/python3.8/site-packages/PIL/ImageFont.py", line 193, in __init__
    self.font = core.getfont(
    TypeError: 'str' object cannot be interpreted as an integer
    Ich teste jetzt nochmal mit der 7g aus diesem Thema.

  10. Thanks Mr.Servo bedankten sich
  11. #1007
    Avatar von Mr.Servo
    Registriert seit
    10.08.2020
    Ort
    Pfalz / Palatinate
    Beiträge
    706
    Thanks (gegeben)
    435
    Thanks (bekommen)
    434
    Total Downloaded
    20,79 MB
    Total Downloaded
    20,79 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue UHD UE 4k Cable (OpenATV 6.4)
     
     
    Box 2:
    Mut@nt HD51 4k Cable (OpenATV 6.4)
     
     
    Zitat Zitat von 4l3x2k Beitrag anzeigen
    Code:
    Traceback (most recent call last):
    File "/usr/lib/enigma2/python/Plugins/Extensions/LCD4linux/plugin.py", line 4568, in run
    para[0](para[1], para[2], para[3])
    File "/usr/lib/enigma2/python/Plugins/Extensions/LCD4linux/plugin.py", line 11842, in putChannelNum
    font = ImageFont.truetype(ConfigFont, ConfigSize, encoding='unic')
    File "/usr/lib/python3.8/site-packages/PIL/ImageFont.py", line 655, in truetype
    return freetype(font)
    File "/usr/lib/python3.8/site-packages/PIL/ImageFont.py", line 652, in freetype
    return FreeTypeFont(font, size, index, encoding, layout_engine)
    File "/usr/lib/python3.8/site-packages/PIL/ImageFont.py", line 193, in __init__
    self.font = core.getfont(
    TypeError: 'str' object cannot be interpreted as an integer
    Hi 4l3x2k,

    der Fehler in line 11842 gehört zur "def putChannelNum(...)", und da gab es noch nie Probleme mit Fehlermeldungen. Komisch!

    Aber alle anderen Meldungen sind "nur" Kollateralfehler, also nur Nachfolgefehler..

    [Edit] Bitte deaktiviere das Element "Programm Nummer " damit es Dich nicht nervt!

    Und ignoriere den Fehler mal vorerst und mache ruhig weiter mit Deinen Analysen und ich schaue ich mir das mal genauer an...

    [Edit] Wobei ich bei mir unter OpenATV 6.5 gerade sehe, daß es einwandfrei läuft... komisch!

    Gruß......Mr.Servo
    Geändert von Mr.Servo (28.02.2021 um 09:13 Uhr) Grund: Erweiterungen
    Wissen ist das einzige Gut, das sich vermehrt, wenn man es teilt. / Knowledge is the only resource that increases when shared.

  12. #1008

    Registriert seit
    20.12.2016
    Beiträge
    632
    Thanks (gegeben)
    175
    Thanks (bekommen)
    226
    Total Downloaded
    39,16 MB
    Total Downloaded
    39,16 MB
    ReceiverDankeAktivitäten
    Box 1:
    Vu+ Duo 2 oatv 6.3
     
     
    Box 2:
    Golden Interstar LX3 oatv 6.3
     
     
    Box 3:
    Mutant HD2400 oatv 6.3
     
     
    Box 4:
    Octagon SF8008 oatv 6.4 & 6.5, openvision 10.2, Define OS 6.3, OpenPLi 8 & develop
     
     
    Box 5:
    Raspberrypi3 TvHeadend TBS5520SE
     
     
    Also mit der Version 5.0-r7g von LCD4Linux unter oatv 6.5 habe ich endlich meine Programm Nummer. Egal aus welchen Bouquets, Satelliten oder DVB-C. Ebenso habe ich nun Bildchen für Audio für das Element Audio/Video.

    Puhhh...

    Wer weiß was das war mit der Version 5.0-r7f unter oatv 6.4.

  13. #1009

    Registriert seit
    20.12.2016
    Beiträge
    632
    Thanks (gegeben)
    175
    Thanks (bekommen)
    226
    Total Downloaded
    39,16 MB
    Total Downloaded
    39,16 MB
    ReceiverDankeAktivitäten
    Box 1:
    Vu+ Duo 2 oatv 6.3
     
     
    Box 2:
    Golden Interstar LX3 oatv 6.3
     
     
    Box 3:
    Mutant HD2400 oatv 6.3
     
     
    Box 4:
    Octagon SF8008 oatv 6.4 & 6.5, openvision 10.2, Define OS 6.3, OpenPLi 8 & develop
     
     
    Box 5:
    Raspberrypi3 TvHeadend TBS5520SE
     
     
    Zitat Zitat von Mr.Servo Beitrag anzeigen
    LCD4linux-dolby.png LCD4linux-dolbyplus.png LCD4linux-dts.png LCD4linux-dtshd.png

    Habe sämtliche .png's mal hier unten angehängt !


    Komme aber erst morgen dazu.

    Gruß......Mr.Servo

    Das könntest du an deinen Post #772 oder wie der heißt anhängen. Eventuell löst es ja schon das Problem mit dem fehlenden Audio unter 6.4.

  14. #1010

    Registriert seit
    20.12.2016
    Beiträge
    632
    Thanks (gegeben)
    175
    Thanks (bekommen)
    226
    Total Downloaded
    39,16 MB
    Total Downloaded
    39,16 MB
    ReceiverDankeAktivitäten
    Box 1:
    Vu+ Duo 2 oatv 6.3
     
     
    Box 2:
    Golden Interstar LX3 oatv 6.3
     
     
    Box 3:
    Mutant HD2400 oatv 6.3
     
     
    Box 4:
    Octagon SF8008 oatv 6.4 & 6.5, openvision 10.2, Define OS 6.3, OpenPLi 8 & develop
     
     
    Box 5:
    Raspberrypi3 TvHeadend TBS5520SE
     
     
    Zitat Zitat von Mr.Servo Beitrag anzeigen
    Hi 4l3x2k,

    der Fehler in line 11842 gehört zur "def putChannelNum(...)", und da gab es noch nie Probleme mit Fehlermeldungen. Komisch!

    Aber alle anderen Meldungen sind "nur" Kollateralfehler, also nur Nachfolgefehler..

    [Edit] Bitte deaktiviere das Element "Programm Nummer " damit es Dich nicht nervt!

    Und ignoriere den Fehler mal vorerst und mache ruhig weiter mit Deinen Analysen und ich schaue ich mir das mal genauer an...

    [Edit] Wobei ich bei mir unter OpenATV 6.5 gerade sehe, daß es einwandfrei läuft... komisch!

    Gruß......Mr.Servo
    Das war mein Fehler!

    Hatte ja oatv 6.5 sauber geflasht und LCD4Linux frisch vom Feed installiert.

    _Nichts_ von dir aus dem Post #772 auf die Box kopiert.

    Das Bitrate Plugin eingebaut und dann wollte ich nochmal Programm Nummer checken. Da kam es zu dem Crash.

    In den offiziellen Quellen der OE-A für LCD4Linux python3 branch fehlt ja das ConfigSize = int(ConfigSize) und ConfigPos = int(ConfigPos) usw ...


Seite 101 von 134 ErsteErste ... 519199100101102103111 ... LetzteLetzte

Ähnliche Themen

  1. Antworten: 109
    Letzter Beitrag: 11.01.2017, 09:37

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Alle Zeitangaben in WEZ +1. Es ist jetzt 01:47 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2021 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 5,00%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com