Thanks Thanks:  4
Seite 1 von 7 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 69
  1. #1
    Anfänger
    Registriert seit
    17.03.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    7
    Total Downloaded
    386,3 KB
    Total Downloaded
    386,3 KB
    ReceiverDankeAktivitäten
    Box 1:
    Venton UniBox HD3
     
     
    Box 2:
    die gute alte Dbox2
     
     

    openvpn einrichten

    hallo,
    wie oben erwähnt möchte ich openvpn einrichten und komme mal wieder nicht klar.

    Das Plugin hab ich installiert über Menü->Netzwerk. Nur liegt in etc/openvpn keine einzige Datei.
    Auf der VPN-Seite gibt es so eine sample client.conf, welche ich nicht durchschaue.
    Ich möchte einen kostenlosen VPN-Anbieter nutzen z.B. auf ProxyPower und da sind ja nur die Zugangsdaten zu sehen, also keine Zertifikate, wie hier immer beschrieben wird.

    Wo muss ich denn nun die Zugangsdaten in dieser sample client.conf eintragen?

    Danke für eure Hilfe

    •   Alt Advertising

       

  2. #2
    Avatar von Alex-2.5
    Registriert seit
    05.04.2013
    Beiträge
    1.070
    Total Downloaded
    16,41 MB
    Total Downloaded
    16,41 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mut@nt HD2400
     
     
    Box 2:
    GigaBlue Quad+
     
     
    Box 3:
    GB IPBox
     
     
    Hallo,

    openvpn erstellt natürlich keine daten in /etc/openvpn

    das sind zertifikate und die config die da rein müssen. Die bekommst du von deinem VPN Anbieter oder wenn du selbst einen Server betreibst dann erstellst du die eben am Server und fügst diese in den Receiver ein.

    Das OpenVPN Plugin ist lediglich zum starten deiner config.
    GB Quad + DVB-C (2x) | GB UE+ + DVB-C | GB Quad Plus (White Edition ) + DVB-C (2x)
    Mut@nt 2400 HD (testing xbmc - so far so good - very good)
    E2BMC D-Cube (great with OpenATV - unusable with XBMC)

  3. #3
    Anfänger
    Registriert seit
    17.03.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    7
    Themenstarter
    Total Downloaded
    386,3 KB
    Total Downloaded
    386,3 KB
    ReceiverDankeAktivitäten
    Box 1:
    Venton UniBox HD3
     
     
    Box 2:
    die gute alte Dbox2
     
     
    Zitat Zitat von Alex-2.5 Beitrag anzeigen
    Hallo,

    openvpn erstellt natürlich keine daten in /etc/openvpn

    das sind zertifikate und die config die da rein müssen. Die bekommst du von deinem VPN Anbieter oder wenn du selbst einen Server betreibst dann erstellst du die eben am Server und fügst diese in den Receiver ein.

    Das OpenVPN Plugin ist lediglich zum starten deiner config.
    Danke für die schnelle Antwort,

    das weiß ich ja und habe ich oben geschrieben.

    edit: habe jetzt einen anderen freevpn gefunden, wo mir etliche xxx.ovpn Dateien heruntergeladen habe. Was muss ich damit machen?

    ABER. Ich will einen freeVPN Anbieter (z.B auf proxypower zu finden) nutzen und dort gibt es außer Server- User- Passwort kein Zertifikat. Darum meine frage, wo ich die zugangsdaten eintragen muss.

    Ich will keinen Server selbst betreiben, nur als Client laufen über einen FreeVPN .

    edit: habe jetzt einen anderen freevpn gesucht, wo mir etliche xxx.ovpn Dateien angezeigt sind. Was muss ich damit machen?

    nochmal edit: habe eine xxx.ovpn Datei in client.conf umbenannt und nach etc/openvpn kopiert und siehe da Openvpn läuft. Aber leider noch nicht so wie es soll. Unter wieistmeineip.de mit Operabrowser wird immer noch meine "richtige IP" angezeigt
    Geändert von wavemaster (21.09.2014 um 21:38 Uhr)

  4. #4
    Avatar von Alex-2.5
    Registriert seit
    05.04.2013
    Beiträge
    1.070
    Total Downloaded
    16,41 MB
    Total Downloaded
    16,41 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mut@nt HD2400
     
     
    Box 2:
    GigaBlue Quad+
     
     
    Box 3:
    GB IPBox
     
     
    OpenVPN ist ein thema für sich.

    Eine .ovpn Datei wird z.b. vom Windows OpenVPN (GUI) genutzt. Richtig, man kann sie in .conf umbenennen, der inhalt von ovpn und conf ist der selbe.

    Wenn Deine IP noch immer die selbe ist dann stimmt das routing vom Anbieter wohl nicht.

    Wenn User und Passwort zum login anstelle von zertifikaten genutzt werden dann ist hier in der ovpn bzw. conf datei eine weitere zeile mit dem Verweis auf die User/Pass Datei einzutragen.
    Dann eben diese Datei anlegen und User und Pass dort hinterlegen.

    Steht alles im "Handbuch" zum Thema Openvpn bzw. im Wiki dazu. Das ist aber wie gesagt nichts was das Image betrifft sondern ein komplett eigenes Thema nämlich OpenVPN

    P.S. ob die Verbindung steht siehst du mit dem telnetbefehl: ifconfig
    Damit sollte er dir entweder ein tun0 oder ein tap0 anzeigen, jenachdem was eben in der config steht.
    Wenn nur lo und eth0 mit "ifconfig" auftaucht dann steht auch keine Verbindung also kein Tunnel aufgebaut.
    GB Quad + DVB-C (2x) | GB UE+ + DVB-C | GB Quad Plus (White Edition ) + DVB-C (2x)
    Mut@nt 2400 HD (testing xbmc - so far so good - very good)
    E2BMC D-Cube (great with OpenATV - unusable with XBMC)

  5. Thanks Thomas4711, MrWoodway bedankten sich
  6. #5
    Anfänger
    Registriert seit
    17.03.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    7
    Themenstarter
    Total Downloaded
    386,3 KB
    Total Downloaded
    386,3 KB
    ReceiverDankeAktivitäten
    Box 1:
    Venton UniBox HD3
     
     
    Box 2:
    die gute alte Dbox2
     
     
    Zitat Zitat von Alex-2.5 Beitrag anzeigen
    OpenVPN ist ein thema für sich.

    Eine .ovpn Datei wird z.b. vom Windows OpenVPN (GUI) genutzt. Richtig, man kann sie in .conf umbenennen, der inhalt von ovpn und conf ist der selbe.

    Wenn Deine IP noch immer die selbe ist dann stimmt das routing vom Anbieter wohl nicht.

    Wenn User und Passwort zum login anstelle von zertifikaten genutzt werden dann ist hier in der ovpn bzw. conf datei eine weitere zeile mit dem Verweis auf die User/Pass Datei einzutragen.
    Dann eben diese Datei anlegen und User und Pass dort hinterlegen.

    Steht alles im "Handbuch" zum Thema Openvpn bzw. im Wiki dazu. Das ist aber wie gesagt nichts was das Image betrifft sondern ein komplett eigenes Thema nämlich OpenVPN

    P.S. ob die Verbindung steht siehst du mit dem telnetbefehl: ifconfig
    Damit sollte er dir entweder ein tun0 oder ein tap0 anzeigen, jenachdem was eben in der config steht.
    Wenn nur lo und eth0 mit "ifconfig" auftaucht dann steht auch keine Verbindung also kein Tunnel aufgebaut.

    Danke dir für die ausführliche Information.

    Es steht nur lo und th0 da, also kein Tunnel.

    Ich habe mir die .conf nochmal angeschaut und da steht in Zeile 9 = auth-user-pass. Soll sicher bedeuten, das die Authentifizierung über User und Passwort erfolgt.
    Du sagtest eine Datei anlegen und dort user und pass hinterlegen. Wie muss die denn heißen die Datei? Und was für eine Zeile muss in .conf hinzugefügt werden?

  7. #6
    Avatar von Alex-2.5
    Registriert seit
    05.04.2013
    Beiträge
    1.070
    Total Downloaded
    16,41 MB
    Total Downloaded
    16,41 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mut@nt HD2400
     
     
    Box 2:
    GigaBlue Quad+
     
     
    Box 3:
    GB IPBox
     
     
    Genau User und Pass fehlen.

    Das ganze siehst du und kannst du auch mit Abfrage im telnet starten.

    eingeben:
    Code:
    openvpn --config /etc/openvpn/client.conf
    teste das erstmal. Da gibst du dann User und Pass ein.
    Kommt am ende ein "Sequenze Complete" dann passt schonmal die verbindung.

    Mit STRG+C das ganze dann wieder stoppen/beenden (tunnel wird dabei abgebrochen)

    So dann legst du eine Textdatei an, am besten auch unter /etc/openvpn names userpass.txt
    Dort schreibst du Username und Passwort rein was du vom Anbieter erhalten hast. Jeweils in eine Zeile. Erste Zeile Username, Zweite Zeile Passwort.

    In der client.conf muss dann das noch mit rein:
    Code:
    auth-user-pass userpass.txt
    also der dateiname mit hinten dran in zeile 9.

    Viel Erfolg.
    GB Quad + DVB-C (2x) | GB UE+ + DVB-C | GB Quad Plus (White Edition ) + DVB-C (2x)
    Mut@nt 2400 HD (testing xbmc - so far so good - very good)
    E2BMC D-Cube (great with OpenATV - unusable with XBMC)

  8. #7
    Anfänger
    Registriert seit
    17.03.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    7
    Themenstarter
    Total Downloaded
    386,3 KB
    Total Downloaded
    386,3 KB
    ReceiverDankeAktivitäten
    Box 1:
    Venton UniBox HD3
     
     
    Box 2:
    die gute alte Dbox2
     
     
    Zitat Zitat von Alex-2.5 Beitrag anzeigen
    Genau User und Pass fehlen.

    Das ganze siehst du und kannst du auch mit Abfrage im telnet starten.

    eingeben:
    Code:
    openvpn --config /etc/openvpn/client.conf
    teste das erstmal. Da gibst du dann User und Pass ein.
    Kommt am ende ein "Sequenze Complete" dann passt schonmal die verbindung.

    Mit STRG+C das ganze dann wieder stoppen/beenden (tunnel wird dabei abgebrochen)

    So dann legst du eine Textdatei an, am besten auch unter /etc/openvpn names userpass.txt
    Dort schreibst du Username und Passwort rein was du vom Anbieter erhalten hast. Jeweils in eine Zeile. Erste Zeile Username, Zweite Zeile Passwort.

    In der client.conf muss dann das noch mit rein:
    Code:
    auth-user-pass userpass.txt
    also der dateiname mit hinten dran in zeile 9.

    Viel Erfolg.
    Ich DANKE dir rechtherzlich für deine Bemühungen mit mir.

    Jetzt funktioniert das ganze laut der Anleitung. Nochmals Mercie

    edit: allerdings steht bei mir in Telnet tun3. Ist das so richtig? Im Operabrowser wird mir schon mal eine andere IP angezeigt als ich wirklich hab.
    Geändert von wavemaster (22.09.2014 um 16:35 Uhr)

  9. #8
    Avatar von Alex-2.5
    Registriert seit
    05.04.2013
    Beiträge
    1.070
    Total Downloaded
    16,41 MB
    Total Downloaded
    16,41 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mut@nt HD2400
     
     
    Box 2:
    GigaBlue Quad+
     
     
    Box 3:
    GB IPBox
     
     
    Freut mich dass es klappt.

    tun3 kommt entweder daher dass du 4 mal openvpn gestartet hast, somit hast du tun0, tun1, tun2, tun3

    wenn das nicht der fall ist dann steht in der client.conf am anfang wohl tun3 drin. wenn man die zahl weg lässt also nur tun in der config hat so nimmt das system automatisch die niedrigste zahl. Sprich tun0 in dem fall.

    ist aber nicht tragisch wenn dort fest tun3 eingetragen ist.
    GB Quad + DVB-C (2x) | GB UE+ + DVB-C | GB Quad Plus (White Edition ) + DVB-C (2x)
    Mut@nt 2400 HD (testing xbmc - so far so good - very good)
    E2BMC D-Cube (great with OpenATV - unusable with XBMC)

  10. #9
    Anfänger
    Registriert seit
    27.11.2014
    Beiträge
    4
    Total Downloaded
    34,37 MB
    Total Downloaded
    34,37 MB
    ReceiverDankeAktivitäten
    Hi,

    ich bin den Anleitungen von Alex-2.5 zur Einrichtung des VPN gefolgt (vorher manuell über telnet getestet, gibt "sequence completed", dann mit der .txt-Datei). Bei den OpenVPN-Einstellungen ist Autostart aktiviert und Status ist grün (läuft).

    Nach reboot des Receivers antwortet mir telnet auf 'ifconfig' aber immernoch eth0 und l0, kein tun0...
    Ich nutze ATV 4.1 (letzte Version) auf einer Gigablue UE+.

    Kann mir jemand helfen warum mein openVPN mit den Einstellungen nicht läuft?
    Vielen Dank!


    ---edit
    Es ist kein reines Autostart-Problem. Auch über GUI lässt sich VPN nicht aktivieren. Lediglich über Kommandozeile
    Geändert von nothing toulouse (02.12.2014 um 14:48 Uhr)

  11. #10
    Anfänger
    Registriert seit
    11.02.2016
    Beiträge
    2
    Total Downloaded
    163,7 KB
    Total Downloaded
    163,7 KB
    ReceiverDankeAktivitäten
    eintrag gelöscht
    Geändert von danielle (13.02.2016 um 19:54 Uhr)


Seite 1 von 7 123 ... LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 04:23 Uhr.
Powered by vBulletin® Version 4.2.3 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 4,55%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com