Ergebnis 1 bis 5 von 5
  1. #1
    Avatar von Mr.Servo
    Registriert seit
    10.08.2020
    Ort
    Pfalz / Palatinate
    Beiträge
    959
    Thanks (gegeben)
    654
    Thanks (bekommen)
    677
    Total Downloaded
    25,66 MB
    Total Downloaded
    25,66 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue UHD UE 4k Cable (OpenATV 7.0)
     
     
    Box 2:
    Mut@nt HD51 4k Cable (OpenATV 7.0)
     
     

    NetSpeedTest crashed unter 6.5, aber warum?

    Hallo Zusammen,

    nachdem ich ja den Internetspeedtest "E2Speedtest" erfolgreich auf PY3 umgefummelt habe, bin ich gerade an dem etwas schickeren "NetSpeedTest" dran. Der eigentliche Test läuft gemäß der bekannten Software "Speedtest-cli" von Matt Martz. Soweit alles sehr gut!

    NetSpeedTest crashed unter 6.5, aber warum?-logo.png

    Und jetzt zum Problem: Ich habe den Code mal schön zusammengefaßt (soweit auf PY3 umgefummelt wie ich konnte) und er läuft unter 6.4 wie " 's Lottchen"

    Unter 6.5 (Skin: Metrix HD) crashed es aber gleich ganz fürchterlich mit folgender Meldung:
    Code:
    openATV Enigma2 crash log
    crashdate=Fr Feb 12 17:26:14 2021
    compiledate=Jan 14 2021
    skin=MetrixHD/skin.xml
    sourcedate=2020-12-28
    branch=6.5
    rev=2.8.0-22602-gfe28fe3
    component=Enigma2
    stbmodel=hd51
    stbmodel=hd51
    kernelcmdline=brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p8 rootsubdir=linuxrootfs2 kernel=/dev/mmcblk0p4 rw rootwait hd51_4.boxmode=1 brcm_cma=440M@328M brcm_cma=192M@768M console=ttyS0,115200
    nimsockets=NIM Socket 0:
    imageversion=box_type=mutant51
    imageissue=Welcome to openATV for %h
    [eDVBPESReader] Created. Opening demux
    [eDVBPESReader] Created. Opening demux
    ADD Peer gbue4k=gbue4k.local:8001
    ADD Peer gbue4k=gbue4k.local:8001
    [ePyObject] (PyObject_CallObject(<bound method ActionMap.action of <Components.ActionMap.ActionMap object at 0xa9fc9c28>>,('SetupActions', 'ok')) failed)
    dmesg
    Ich habe jetzt Stunden daran verbracht, aber ich habe partout keine Idee woran das nun wieder liegen kann. Sooooo dolle groß ist das Plugin inkl. Komponenten "default.py" und "speedtest.py" auch wieder nicht.

    Hinweis: Das Unterprogramm "Speedtest-cli" (bzw. "Speedtest.py") läuft als Standalone auch unter 6.5 ganz manierlich, das ist also nicht die Ursache!

    Wollt ihr mal selbst gucken? Die Sache ist supersimpel & schnell gemacht: entZIPpen, in "/usr/lib/enigma2/python/Plugins/Extensions/NetSpeedTest" reinkopieren und GUI-Neustart.

    --> Könnte sowas womöglich an einem Fehler im 6.5er Skin Metrix HD liegen?
    [Edit/Nachklapp] Das wirklich komische ist, daß es bei meinen vielen Versuchen keinerlei Fehlermeldung gab, sondern immer nur direkt den Vollcrash...

    Hat jemand eine Idee der ich nachgehen kann / sollte?

    Etwas ratlos aber Danke & Gruß.....Mr.Servo
    Angehängte Dateien Angehängte Dateien
    Geändert von Mr.Servo (12.02.2021 um 17:47 Uhr)
    Alle Menschen sind schlau! Die einen vorher - die anderen nachher... / All people are smart! Some before - others after...

    •   Alt Advertising

       

  2. #2
    Avatar von jogibär
    Registriert seit
    09.08.2016
    Beiträge
    2.481
    Thanks (gegeben)
    4125
    Thanks (bekommen)
    1078
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    Gigablue UE 4K 6.4 -7.0
     
     
    Box 2:
    Anadol Multibox4k UHD Combo 6.4
     
     
    Box 3:
    Anadol Multibox4k UHD Twin 6.4
     
     
    Für mein Verständnis, wenn du schreibst du hast es auf p3 gefummelt und läuft auf 6.4 wie lottchen,darf es das überhaupt? Ist 6.4 p3 kompatibel?
    Ex Highflyer

  3. #3
    Avatar von Mr.Servo
    Registriert seit
    10.08.2020
    Ort
    Pfalz / Palatinate
    Beiträge
    959
    Thanks (gegeben)
    654
    Thanks (bekommen)
    677
    Themenstarter
    Total Downloaded
    25,66 MB
    Total Downloaded
    25,66 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue UHD UE 4k Cable (OpenATV 7.0)
     
     
    Box 2:
    Mut@nt HD51 4k Cable (OpenATV 7.0)
     
     
    Hi Jogibär,

    es ist ja nicht so, daß es bei Python-Plugins gleich automatisch in die Schiene "entweder PY2 oder PY3" laufen muß. Gerade bei kleineren (simpleren) Plugins ohne tiefgreifende Strukturen besteht ja eine gute Chance, daß sie auf PY3 angepaßt werden und dann trotzdem noch unter PY2 laufen.

    Simpelstes Beispiel:
    Print 'Hello' läuft unter PY2, knallt aber unter PY3
    Print ("Hello") hingegen läuft unter PY2 und PY3 reibungslos (sogar ohne irgendwelche Behelfsbiliotheken)

    Erst bei tiefgreifenderen Strukturen (z.B. LCD4Linux) wird es ekelig bzw. unlösbar.

    Bei dem artverwandten "E2Speedtest" war die Umstellung auf P3 und immer noch lauffähig unter PY2 gar kein Problem.

    Gruß.....Mr.Servo
    Alle Menschen sind schlau! Die einen vorher - die anderen nachher... / All people are smart! Some before - others after...

  4. #4
    Avatar von jogibär
    Registriert seit
    09.08.2016
    Beiträge
    2.481
    Thanks (gegeben)
    4125
    Thanks (bekommen)
    1078
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    Gigablue UE 4K 6.4 -7.0
     
     
    Box 2:
    Anadol Multibox4k UHD Combo 6.4
     
     
    Box 3:
    Anadol Multibox4k UHD Twin 6.4
     
     
    Ok, aber genau so, wie du bei dem lcd4l gelernt hast das zu trennen , sollte das der ansatz für alle plugin an die du hand anlegst sein und sind sie auch noch so klein. Das ist auch user freundlicher da es nicht auf beiden feeds das gleiche plugin liegt. Nur meine bescheidene meinung ohne dein hingabe zu schmälern.
    Geändert von jogibär (12.02.2021 um 18:12 Uhr)
    Ex Highflyer

  5. #5
    Avatar von Mr.Servo
    Registriert seit
    10.08.2020
    Ort
    Pfalz / Palatinate
    Beiträge
    959
    Thanks (gegeben)
    654
    Thanks (bekommen)
    677
    Themenstarter
    Total Downloaded
    25,66 MB
    Total Downloaded
    25,66 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue UHD UE 4k Cable (OpenATV 7.0)
     
     
    Box 2:
    Mut@nt HD51 4k Cable (OpenATV 7.0)
     
     
    Sagen wir so: Ich fummle ein Plugin um auf PY3 und wenn es dann zufällig auch noch auf PY2 läuft, dann prima! Wenn es auf PY2 (also 6.4) dann nicht mehr läuft dann "Pech für die Kuh Elsa"

    Bei L4L verhielt es sich anders: Es gab ja schon eine aktuelle Version -r7 und ich dachte die läuft bereits unter PY3 (und PY2). Ich habe dort ganz einfach aufgesattelt und wie sich dann rausstellte: leider aufs falsche Pferd, weil die -r7 leider noch nicht zu Ende getestet war (steht aber auch so im Git, ich habs halt nicht gelesen - bin selbst Schuld).

    Gruß......Mr.Servo
    Alle Menschen sind schlau! Die einen vorher - die anderen nachher... / All people are smart! Some before - others after...

  6. Thanks jogibär bedankten sich

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Alle Zeitangaben in WEZ +1. Es ist jetzt 10:55 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2021 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 5,56%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com