Ich habe mal einen Film mit Untertitel mittels Subtitle-Edit versehen. Zuerst nur einfarbig und als srt im mkv Format eingebettet.
Alles prima beim abspielen auf meiner Vu+ SoloSE und OpenAtv 6.4.
Dann habe ich den Farbkasten ausgepackt und jeder Rolle im Film eine andere Farbe zugeteilt, sieht klasse aus am PC
allerdings wird die Farbe nicht auf der Box angezeigt, dafür aber das srt Kommando dafür also "<font...>" und "</font>.
Schade eigentlich und ein Blick auf OpenAtv Github gab mir die Bestätigung, dass hier wohl der Support fehlt.

Dann habe ich die Untertitel mittels Subtitle-Edit als grafische Bluray Untertitel gespeichert, da werden auch die Farben übernommen
und danach mit ffmpeg zu dvb Untertiteln konvertiert und zum mkv Film hinzugefügt. Läuft prima am PC, srt und dvb Untertitel kann ich
auswählen und ansehen. Auf der Box lässt sich allerdings nur der srt Untertitel auswählen und vom dvb Untertitel nichts zu sehen,
weder beim EMC noch beim FileCommander.

Dann habe ich den mkv Film mit ffmpeg ins ts Format, also mpeg2ts, umgewandelt. Am PC alles prima, dvb Untertitel kann ich auswählen
und ansehen. Auf der Box kann ich die dvb Untertitel auswählen, allerdings werden nur Schattenboxen angezeigt wo sonst Untertitel
erscheinen sollten.

Dann habe ich als Test einen Film, der auf ARD gesendet wurde und ich aufnahm mal abgespielt und dvb Untertitel eingeschaltet.
Da gab es Farbe und jetzt wird komisch, manche Dialoge hatten gar keinen Untertitel, nach einiger Zeit kamen sie wieder, danach
wieder paar Dialoge ohne Untertitel, usw.

Die selbe Aufnahme auf meinem PC hat allerdings bei allen Dialogen farbige Untertitel.

Ich würde mir wünschen, dass srt Untertitel auch in Farbe angezeigt werden und das Problem mit den dvb Untertiteln irgendwie
gelöst wird. Ich wollte einige Filme gerne mit Subtitle-Edit übersetzen und dann mit farbigen srt und dvb Untertiteln im mkv und
ts Format versehen,

Gruß

Jamie