Thanks Thanks:  0
Ergebnis 1 bis 5 von 5
  1. #1
    Senior Mitglied Avatar von b0mbasti
    Registriert seit
    01.04.2014
    Ort
    NRW
    Beiträge
    416
    Total Downloaded
    138,5 KB
    Total Downloaded
    138,5 KB
    ReceiverDankeAktivitäten
    Box 1:
    AX-ODiN OpenATV 4.2/750 MHz Bootloader
     
     

    OpenVPN Startet manchmal nicht

    Hi!

    Sporadisch startet OpenVPN bei mir nicht.

    Ich habe es auf Autostart gesetzt und überwiegend klappt es auch, aber hin und wieder halt nicht.

    Wundert mich etwas da ich in der client.conf die Verbindungsversuche auf infinite gesetzt habe.

    Starte ich OpenVPN Dienst über das Menü durch drücken der grünen Taste, startet der Dienst.

    Hier könnte ich doch eigentlich auch ein Skript nach dem Booten aufrufen, dass den Status von OpenVPN abruft und
    im Falle von "deaktiviert" einfach noch mal startet.

    Nur wie am besten?

    Weiß jemand Rat?

    Danke!

    b0mbasti

    edit:

    So, ich habe folgendes Skript im Netz gefunden.

    Code:
    #!/bin/bashexport PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
     
    ### Thanks Xream's Work XD
     
    # if you don't have several vpn servers to select, you can comment following line 
    # and use your openvpn config file name to replace "${host}.ovpn" in while loop.
     
    read -p "Select the host: " host
     
    function getStatus () {
        ifconfig | grep $1 && return 1
        return 0
    }
     
    while [[ 1 ]]; do
        getStatus tun0
        if [[ $? == 0 ]]; then
            echo "openvpn is not connected!"
            echo "Reconnecting!"
                    #Replace your_sudo_password to your real user sudo password.
            echo your_sudo_password | sudo -S openvpn --config /home/user/openvpn/${host}.ovpn
            sleep 6
        fi
        sleep 6
    done
    Läuft das so dauerhaft im Loop oder muss ich das über Crontimer regelmäßig ausführen?

    Und was mache ich mit den Echozeilen? Die werden doch nur im Shell angezeigt oder ?

    Sudo kann ich mir ja auch sparen, oder?

    Oder würde auch dieses kleinere Skript funktionieren?

    Code:
    #!/bin/bashwhile [ "true" ]
    do
    	VPNCON=$(nmcli con status)
    	if [[ $VPNCON != *MyVPNConnectionName* ]]; then
    		echo "Disconnected, trying to reconnect..."
    		(sleep 1s && nmcli con up uuid df648abc-d8f7-4ce4-bdd6-3e12cdf0f494)
    	else
    		echo "Already connected !"
    	fi
    	sleep 30
    done
    Geändert von b0mbasti (02.06.2014 um 11:13 Uhr)

    •   Alt Advertising

       

  2. #2
    Senior Mitglied
    Registriert seit
    14.04.2013
    Beiträge
    524
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Ich hab dafür einen Watchdog laufen der in Echtzeit arbeitet ohne Cron.
    Wenn OpenVPN wirklich mal abschmiert dauert es ~1 Sekunde und es startet neu.

  3. #3
    Senior Mitglied Avatar von b0mbasti
    Registriert seit
    01.04.2014
    Ort
    NRW
    Beiträge
    416
    Themenstarter
    Total Downloaded
    138,5 KB
    Total Downloaded
    138,5 KB
    ReceiverDankeAktivitäten
    Box 1:
    AX-ODiN OpenATV 4.2/750 MHz Bootloader
     
     
    Zitat Zitat von DarkStarXxX Beitrag anzeigen
    Ich hab dafür einen Watchdog laufen der in Echtzeit arbeitet ohne Cron.
    Wenn OpenVPN wirklich mal abschmiert dauert es ~1 Sekunde und es startet neu.
    Wie genau hast Du das realisiert?

  4. #4
    Avatar von -=niki=-
    Registriert seit
    07.04.2013
    Beiträge
    827
    Total Downloaded
    19,78 MB
    Total Downloaded
    19,78 MB
    ReceiverDankeAktivitäten
    Box 1:
    Gigablue Solo @ ATV4
     
     
    Box 2:
    Sogno 8800HD @ ATV4 / PLI4
     
     
    Box 3:
    diverse
     
     
    Du startest ganz schön viele Themen zu deinem Problem

    Crontabs .... hier mal einlesen.... ist kein Hexenwerk

    Code:
    #! /bin/bash
    
    # Testen ob OpenVPN Verbindung besteht mittels tun0 device
    if ifconfig | grep -q tun0
    then echo "VPN läuft" >> /dev/null
    else /etc/init.d/openvpn start &
    fi
    Den Crontab dann so

    Code:
    */1 *  *       *       * /path/to/OpenVPN_checker.sh
    Könnt mir vorstellen das des so gehen könnt..

    LG Niki

    Dann eben hier ...

  5. #5
    Senior Mitglied Avatar von b0mbasti
    Registriert seit
    01.04.2014
    Ort
    NRW
    Beiträge
    416
    Themenstarter
    Total Downloaded
    138,5 KB
    Total Downloaded
    138,5 KB
    ReceiverDankeAktivitäten
    Box 1:
    AX-ODiN OpenATV 4.2/750 MHz Bootloader
     
     
    Also mit "openvpn start" gibts irgendwie schon die ersten Störungen, sobald der Cronjob aktiv ist.

    Ich habe es jetzt geändert in "openvpn restart" - das scheint idiotensicher zu funktionieren

    edit:

    Wobei mir gerade aufgefallen ist, dass der Cronjob irgendwie nicht funktioniert.

    Das Skript funzt, wenn ich es starte, aber wenn ich OpenVPN beende, dann startet es nicht wieder automatisch. hmmm

    So, * * * * * funktioniert.
    Geändert von b0mbasti (03.06.2014 um 20:00 Uhr)


Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 16:55 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,76%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com