Thanks Thanks:  16
Seite 3 von 6 ErsteErste 12345 ... LetzteLetzte
Ergebnis 21 bis 30 von 59
  1. #21
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.840
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Hi b0mbasti,

    Hab ein bisschen weiter gebastelt und hab nun ne Art Zähler eingebaut damit man weiss wie oft das Script läuft
    (ich geh zwar davon aus das es im Normalfall nur einmal zu laufen braucht) aber man weiss ja nie...

    Also aktuelles Paket hier im Post downloaden und es gilt genau das selbe wie hier im Link beschrieben;
    http://www.opena.tv/openatv-4-1-ruec...html#post57735

    Hier noch der Output wenn das Script zum ersten mal startet;
    Code:
    Ausfuehrung des Scripts Nr: 1
    
    Netzwerk (eth0) bereit.
    Loesche Cronjob...
    Cronjob erfolgreich geloescht.
    und ein Bespiel wenn es öfter starten würde;
    Code:
    Ausfuehrung des Scripts Nr: 13
    
    Netzwerk (eth0) bereit.
    Loesche Cronjob...
    Cronjob erfolgreich geloescht.
    Habe das so provoziert mit meinen Tests - man kann also ab nun im Log sehen wie oft das Script durch den Cronjob gstartet werden muss
    bis Netzwerk klappt (will das jetzt nicht mehr näher erklären du wirst es selber sehen wenn du testest)
    wobei aber im Normalfall wie gesagt wirds eher immer nur die Zeile zu sehen geben;
    Ausfuehrung des Scripts Nr: 1 (also mit keiner höheren Zahl als der 1)
    da ich davon ausgehe das das Netzwerk meist eh gleich out of the box läuft oder eben wenn nicht wird ein Versuch des Scripts reichen um das Netzwerk zu starten
    (so sollte es jedenfalls sein).

    Soweit so gut - testen kannst nun eh recht einfach, nur die Box hochfahren bisschen warten und ins Log sehen was passiert ist
    wird dann entweder so sein das das Script einfach gleich den Cronjob gelöscht hat da dein Netzwerk eh out of the box klappte,
    oder wenn dein Netzwerk nicht out of the box klappte das das Script dann halt das Netzwerk gestartet hat (was hoffentlich immer gleich klappt)
    und danach gleich wieder der Cronjob gelöscht wurde.
    Ob der Cronjob wirklich gelöscht wurde bei funktionierenden Netzwerk kannst ja dann ebenfalls per Plugin Dream Explorer
    im File /etc/cron/crontabs/root nachsehen.
    Das sind halt die Tests die du am Anfang (mal ne Woche oder so) machen solltest und bitte Feedback mit Logs hier.


    Grüsse
    Biki3
    Angehängte Dateien Angehängte Dateien
    OpenATV-6.1

  2. Thanks Thomas4711, b0mbasti bedankten sich
    •   Alt Advertising

       

  3. #22
    Senior Mitglied Avatar von b0mbasti
    Registriert seit
    01.04.2014
    Ort
    NRW
    Beiträge
    416
    Themenstarter
    Total Downloaded
    138,5 KB
    Total Downloaded
    138,5 KB
    ReceiverDankeAktivitäten
    Box 1:
    AX-ODiN OpenATV 4.2/750 MHz Bootloader
     
     
    Ich gucke mal, ob ich heute abend Zeit zum Testen finde.

    Löscht der nur den Job für das Netzwerk aus dem root von Crontabs?

    Ich habe ja noch nen anderen Job drin.

    Und wo packe ich das autostartmässig am besten hin?

  4. #23
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.840
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Hi b0mbasti,

    Is so geschrieben das es per sed nur den Cronjob löscht den das Init Script anlegt also nur den der das Netzwerk startet wenn Netzwerk mal nicht klappt nach Hochbooten.
    Brauchst dir also keine Sorgen zu machen - andere Cronjobs bleiben erhalten.

    Was den Autostart betrifft - da brauchst nix weiter zu tun als genau das was hier steht;
    http://www.opena.tv/openatv-4-1-ruec...html#post57735
    Den Autostart macht ja das Init Script.
    Natürlich aber musst schon gucken das der Cron Dienst läuft (geht ja irgendwo im Menü im Info Panel zu starten - der braucht Autostart das er bei jedem Boot startet).

    Du solltest die Scripts aber von hier downloaden;
    http://www.opena.tv/openatv-4-1-ruec...html#post57781
    sind aktueller - hab da ja noch was zusätzlich eingebaut.


    Dann nochmal zum Testen selber;
    Du fährst die Box dann mal frisch hoch.
    Dann bisschen warten (Cronjob muss ja erst ausgeführt werden) und dann mal nachsehen ob in /tmp das Log mit Namen network_start.log liegt.
    Dieses wird in den allermeisten Fällen so ausehen;
    Code:
    Ausfuehrung des Scripts Nr: 1
    
    Netzwerk (eth0) bereit.
    Loesche Cronjob...
    Cronjob erfolgreich geloescht.
    Wenn das so ist und Netzwerk läuft is das gut so, denn dann is dein Netzwerk out of the box funktionsfähig gewesen.
    (ich geh je eher davon aus das dein Netzwerk nur ab und zu nach dem Hochbooten nicht funktioniert).


    Der zweite Fall der eintreten könnte wär wenn dein Problem mal auftritt und das Netzwerk nicht out of the box klappt nach dem Booten.
    Dann sollte in etwa diese Ausgabe kommen (bei Erfolg);
    Code:
    Ausfuehrung des Scripts Nr: 1
    
    Netzwerk (eth0) nicht bereit.
    Starte Netzwerk per Script...
    Netzwerk erfolgreich gestartet.
    Loesche Cronjob...
    Cronjob erfolgreich geloescht.
    Dies wär quasi der echte Test denn da wüsstest du das dein Netzwerk nicht out of the box funktioniert hat nach dem Booten und das Script
    aber das Netzwerk nun erfolgreich starten konnte.
    Wenn nun das Netzwerk auch funktioniert is das perfekt.

    In beiden Fällen wärs gut wennst dir am Anfang (ein paar Tage halt) danach noch das File /etc/cron/crontabs/root ansiehst
    und wenn da drin jedesmal nur noch dein anderer Cronjob steht sollte alles passen.
    Dann wüssten wir das alles läuft wies soll.

    Allein schon wenn das Log also das network_start.log in /tmp liegt wüssten wir das das Init Script auch funktioniert
    und auch erfolgreich den Cronjob eintragen konnte, und auch das das Hauptscript gearbeitet hat.

    Es kann aber natürlich auch ne etwas andere Ausgabe im Log auftauchen, aber nur in nem Fehlerfall
    deshalb baut man Logging ja auch ein damit man testen und sehen kann was Sache ist.


    Also bitte testen und Feedback




    Grüsse
    Biki3
    Geändert von Pike_Bishop (05.06.2014 um 16:45 Uhr)
    OpenATV-6.1

  5. #24
    Senior Mitglied Avatar von b0mbasti
    Registriert seit
    01.04.2014
    Ort
    NRW
    Beiträge
    416
    Themenstarter
    Total Downloaded
    138,5 KB
    Total Downloaded
    138,5 KB
    ReceiverDankeAktivitäten
    Box 1:
    AX-ODiN OpenATV 4.2/750 MHz Bootloader
     
     
    Axo, ich muss nur das cronjob dingen starten und das macht den Rest, richtig?

    Aber wie gesagt, wo soll ich das starten, also an welcher Stelle?

    Irgendwo bei rc3.d als Nr. 99 wie?

  6. #25
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.840
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Hi,

    Axo, ich muss nur das cronjob dingen starten und das macht den Rest, richtig?
    Ja genau wenn du das mit den Scripts alles korrekt eingerichtet hast, nur den Cron Dienst starten.

    Aber wie gesagt, wo soll ich das starten, also an welcher Stelle?

    Irgendwo bei rc3.d als Nr. 99 wie?
    Versteh ich jetzt nicht, hab aber grade auch kein OpenAtv an der Box - was meinst mit Irgendwo bei rc3.d als Nr. 99 wie?
    Das macht ja eh schon das Init Script in rcS.d mit S96.
    Du musst den Cron Dienst nur starten und auch Autostart aktivieren, mehr nicht
    denn das was du da beschreibst klingt nach anlegen eines Cronjobs und auch das macht das Init Script ja selbst schon.


    Hatte ja mal das OpenAtv-3.0 am Laufen und da musste man nur den Dienst Cron anschalten mehr nicht - sollte sich das geändert haben ?
    Am Besten du machst mal ein paar Screenshots - alle was es zum Cron gibt im Ino Panel unter Dienste nehm ich an, so das ich mir ein Bild machen kann.
    Ein Screenshot Plugin (gibt ja verschiedene wirst ja haben auf der Box oder ?)


    Mach erstmal alles das wie hier beschrieben;
    http://www.opena.tv/openatv-4-1-ruec...html#post57735
    (aber mit den aktuellsten Scripts - hab gesehen hast die eh schon downgeloadet nun)
    und dann gib mir Screenshots zum Cron im Info Panel bzw. generell zu den Diensten.


    Grüsse
    Biki3
    Geändert von Pike_Bishop (05.06.2014 um 20:05 Uhr)
    OpenATV-6.1

  7. Thanks Thomas4711 bedankten sich
  8. #26
    Senior Mitglied Avatar von b0mbasti
    Registriert seit
    01.04.2014
    Ort
    NRW
    Beiträge
    416
    Themenstarter
    Total Downloaded
    138,5 KB
    Total Downloaded
    138,5 KB
    ReceiverDankeAktivitäten
    Box 1:
    AX-ODiN OpenATV 4.2/750 MHz Bootloader
     
     
    Dein Cronjob Script fügt ja einen Cronjob hinzu, aber wie soll ich dieses Script ausführen bzw. wann?

    Und warum lassen wir das Netscript nicht direkt über einen Cronjob laufen?
    Geändert von b0mbasti (05.06.2014 um 20:19 Uhr)

  9. #27
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.840
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    phhuuu - du machst es mir jetzt wirklich nicht leicht

    Dein Cronjob Script fügt ja einen Cronjob hinzu, aber wie soll ich dieses Script ausführen bzw. wann?
    Du musst selber kein Script ausführen das geht automatisch dann !
    Is ja ein Init Script das startet automatisch beim Booten wenn mans in nen Runlevel (in dem Fall in den Startlevel) verlinkt wie im langen Post erklärt (beschrieben).

    Und warum lassen wir das Netscript nicht direkt über einen Cronjob laufen?
    Ja was denkst du denn wie das abläuft - genau so.
    Ich hab dir ja zwei Scripts gebaut oder nicht ?

    Das eine ist das Init Script - dieses erstellt nen Cronjob der wiederum das zweite Script startet welches dein Netzwerk startet falls das nicht von alleine gestartet werden konnte
    das hab ich alles aber jetzt schon mehrfach erklärt wie das abläuft.
    (ich schreib ja eh alles immer mega genau auf).

    Du musst nur noch sehen das der Cron Dienst selber läuft (kann sein das der im OpenAtv eh out of the box so eingestellt ist)
    Das kannst ja prüfen irgendwo im InfoPanel gibts die Dienste wenn da der Cron angehakt ist läuft der auch ansonsten Dienst starten das er angehakt oder grün ist
    (weiss eben nicht hab grade kein OpenAtv)
    Würdest du Screenshots posten wär das bestimmt schon geklärt.



    Grüsse
    Biki3
    Geändert von Pike_Bishop (05.06.2014 um 20:52 Uhr)
    OpenATV-6.1

  10. Thanks Thomas4711 bedankten sich
  11. #28
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.840
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Hi,

    Ich seh schon da kommen keine Screenshots, aber na gut ich bin mal nicht so

    Mach erstmal alles ganz genau so wie hier im folgenden Link beschrieben;
    http://www.opena.tv/openatv-4-1-ruec...html#post57735
    natürlcih aber mit den aktuellsten Scripts von hier;
    http://www.opena.tv/openatv-4-1-ruec...html#post57781


    Dann kannst den Cron Dienst (Daemon) auch per telnet wie folgt dazu veranlassen das er automatisch startet (also Autostart bekommt)
    falls das im OpenAtv nicht eh von Haus aus so eingestellt ist;
    Code:
    update-rc.d busybox-cron defaults
    sollte dann die folgende Meldung kommen (was aber eh keinerelei Problem darstellt);
    Code:
    System startup links for /etc/init.d/busybox-cron already exist.
    dann war der Cron Dienst schon von Haus aus auf Autostart eingestellt.

    Danach kannst die Box einfach gleich in telnet rebooten mit;
    Code:
    reboot

    UND DAS WAR DANN ALLES - DU MUSST DICH UM NIX ANDERES WEITER KÜMMERN - NUR NOCH TESTEN !

    Hab mir deshalb grade in nem Pli-4.0 den Cron eingerichtet und werd das mit den Scripts jetzt gleich selber auch mal testen.

    EDIT !
    So hab nun den einen Fall getestet, nämlich wenn das Netzwerk eh out of the box klappt
    und die Ausgabe dazu sieht hier so aus;
    Code:
    Ausfuehrung des Scripts Nr: 2
    
    Netzwerk (eth0) bereit.
    Loesche Cronjob...
    Cronjob erfolgreich geloescht.
    und das File root in /etc/cron/crontabs ist leer (hatte ja keinen anderen Cronjob noch extra da eingetragen) also wurde der Cronjob korrekt angelegt vom Init Script
    und das Hauptscript gestartet welches erkannt hat das Netzwerk eh out of the box klappt und so einfach den Cronjob wieder gelöscht hat.
    Ich würde sagen perfekt genauso soll das Laufen einzig hatte ich statt;
    Ausfuehrung des Scripts Nr: 2
    eher;
    Ausfuehrung des Scripts Nr: 1
    erwartet aber da kanns durchaus sein das das Netzwerk trotz dem das es weit früher autostartet als die Scripts noch nicht ganz bereit war nach dem Hochbooten so das
    das Hauptscript eben zweimal anlief dank dem Cronjob.
    Aber das is auch ok - is ja kein echtes Problem
    (kann ja mal nen sleep 10 einbauen, aber is nicht eilig - jedenfalls wenn ich das Hauptscript nur so im Betrieb aufrufe kommts immer richtig mit;
    Ausfuehrung des Scripts Nr: 1 wenn ich jedesmal zuvor das Log File manuell lösche.

    Den zweiten Fall also wenn dein Netzwerk mal nicht out of the box klappt kannst nur du selbst testen.


    Grüsse
    Biki3
    Geändert von Pike_Bishop (06.06.2014 um 16:35 Uhr)
    OpenATV-6.1

  12. Thanks Thomas4711 bedankten sich
  13. #29
    Senior Mitglied Avatar von b0mbasti
    Registriert seit
    01.04.2014
    Ort
    NRW
    Beiträge
    416
    Themenstarter
    Total Downloaded
    138,5 KB
    Total Downloaded
    138,5 KB
    ReceiverDankeAktivitäten
    Box 1:
    AX-ODiN OpenATV 4.2/750 MHz Bootloader
     
     
    Sorry, ich werde das heute abend mal antesten, Bei dem Wetter spannen mich Frau und Kind voll ein.

    Mir ist mal aufgefallen, dass meine Iptables Regeln gelöscht sind, wenn ich das Netzwerk neu starte. Kann ich das Script für die Iptables Regeln dann einfach in dem Netzwerkstart Script von Dir
    mit & aufrufen?

  14. #30
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.840
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Mir ist mal aufgefallen, dass meine Iptables Regeln gelöscht sind, wenn ich das Netzwerk neu starte. Kann ich das Script für die Iptables Regeln dann einfach in dem Netzwerkstart Script von Dir
    mit & aufrufen?
    Normal ja (is ein Shell Script nehm ich an oder ?) - man muss den Aufruf dazu halt an der richtigen Stelle einbauen.
    OpenATV-6.1


Seite 3 von 6 ErsteErste 12345 ... LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 15:34 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 10,53%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com