Thanks Thanks:  4
Ergebnis 1 bis 8 von 8
  1. #1
    Avatar von Topfi
    Registriert seit
    05.04.2013
    Beiträge
    587
    Total Downloaded
    5,76 MB
    Total Downloaded
    5,76 MB
    ReceiverDankeAktivitäten

    Shutdown Probleme (WebIF, Power Timer, Shutdown nach Power Failure, etc)

    Hi,
    mir ist gerade aufgefallen, dass die Zero unter bestimmten Umständen nicht sauber runterfährt, z.B. Shutdown per WebIF und bei der Einstellung "Deep Standby nach Power Failure".
    Hier ein Log (Deep Standby via Webserver):

    Code:
    [OpenWebif] page '/ajax/powerstate' ok (cheetah template)
    __seekableStatusChanged
    statfs failed!
    statfs failed!
    [SKIN] Parsing embedded skin <embedded-in-'QuitMainloopScreen'>
    [SKIN] Parsing embedded skin <embedded-in-'TryQuitMainloop'>
    [OpenWebif] page '/api/powerstate?newstate=1' ok (json)
    connectionLost? [Failure instance: Traceback (failure with no frames): <class 'twisted.internet.error.ConnectionLost'>: Connection to the other side was lost in a non-clean fashion: Connection lost.
    ]
    normal shutdown
    wakeupList []
    ---- saving lame channel db
    saved 200 channels and 3796 services!
    release cached channel (timer timeout)
    - (41) eServiceFactoryDVD
    - (41) eServiceFactoryM2TS
    - (41) eServiceFactoryMP3
    - (41) eServiceFactoryFS
    - (41) eServiceFactoryDVB
    - (40) eServiceCenter
    - (36) Stream server
    - (35) CI Slots
    - (35) CA handler
    - (30) eActionMap
    - (22) Hdmi CEC driver
    - (21) input device driver
    main thread is non-idle! display spinner!
    INFO: rcu_sched detected stall on CPU 1 (t=60000 jiffies)
    INFO: rcu_sched detected stalls on CPUs/tasks: { 1} (detected by 0, t=60002 jiffies)
    Call Trace:
    [<805262d0>] dump_stack+0x8/0x34
    [<8007db98>] __rcu_pending+0x520/0x528
    [<8007ef70>] rcu_check_callbacks+0x78/0x180
    [<80036214>] update_process_times+0x40/0x6c
    [<800690d8>] tick_sched_timer+0x78/0x340
    [<8004d31c>] __run_hrtimer.isra.20+0x64/0x140
    [<8004dd7c>] hrtimer_interrupt+0x198/0x4ac
    [<8000d0d8>] c0_compare_interrupt+0x50/0x88
    [<80076394>] handle_irq_event_percpu+0x78/0x310
    [<8007abb4>] handle_percpu_irq+0x8c/0xc0
    [<800759ac>] generic_handle_irq+0x3c/0x5c
    [<80006d14>] do_IRQ+0x18/0x24
    [<800027dc>] plat_irq_dispatch+0xa8/0x104
    [<80004f44>] ret_from_irq+0x0/0x4
    [<80005180>] r4k_wait+0x20/0x40
    [<80007034>] cpu_idle+0x7c/0xa4
    [<8065e8f4>] start_kernel+0x3a0/0x3c0
    
    Call Trace:
    [<805262d0>] dump_stack+0x8/0x34
    [<8007d830>] __rcu_pending+0x1b8/0x528
    [<8007f010>] rcu_check_callbacks+0x118/0x180
    [<80036214>] update_process_times+0x40/0x6c
    [<800690d8>] tick_sched_timer+0x78/0x340
    [<8004d31c>] __run_hrtimer.isra.20+0x64/0x140
    [<8004dd7c>] hrtimer_interrupt+0x198/0x4ac
    [<8000d0d8>] c0_compare_interrupt+0x50/0x88
    [<80076394>] handle_irq_event_percpu+0x78/0x310
    [<8007abb4>] handle_percpu_irq+0x8c/0xc0
    [<800759ac>] generic_handle_irq+0x3c/0x5c
    [<80006d14>] do_IRQ+0x18/0x24
    [<800027dc>] plat_irq_dispatch+0xa8/0x104
    [<80004f44>] ret_from_irq+0x0/0x4
    [<80060958>] current_kernel_time+0x38/0x54
    [<e0711b00>] __func30__+0x324/0x410 [dvbdrive]
    [<800481e8>] kthread+0x90/0x98
    [<80006e58>] kernel_thread_helper+0x10/0x18
    Darauf gekommen bin ich, weil ich in einem eigenen Plugin folgenden Aufruf verwende:
    Code:
    self.session.open(TryQuitMainloop,retvalue=1)
    Auf allen Boxen außer der Zero funktioniert das problemlos, die Zero bleibt aber einfach hängen und reagiert nicht mehr.
    Die Nachricht, dass die Box heruntergefahren wird erscheint aber noch. Dachte erst, es liegt an meinem Plugin, da es aber auch bei anderen Gelegenheiten auftritt, scheint es wohl ein generelles Problem zu sein?

    •   Alt Advertising

       

  2. #2
    Avatar von Captain
    Registriert seit
    03.04.2013
    Beiträge
    10.768
    Total Downloaded
    162,35 MB
    Total Downloaded
    162,35 MB
    ReceiverDankeAktivitäten
    Fehler an Hersteller weiter gegeben, den hatten wir immer mal wieder konnten den aber nicht Reproduzieren, über den weg mit den webif geht es, denke das hilft

  3. Thanks Topfi bedankten sich
  4. #3
    Avatar von Topfi
    Registriert seit
    05.04.2013
    Beiträge
    587
    Themenstarter
    Total Downloaded
    5,76 MB
    Total Downloaded
    5,76 MB
    ReceiverDankeAktivitäten
    Super. Bin auf die Reaktion des Herstellers gespannt.

  5. #4
    Avatar von Captain
    Registriert seit
    03.04.2013
    Beiträge
    10.768
    Total Downloaded
    162,35 MB
    Total Downloaded
    162,35 MB
    ReceiverDankeAktivitäten
    gefixt seit dem Image 31.5 !

  6. Thanks Topfi, Black_64 bedankten sich
  7. #5
    Avatar von Topfi
    Registriert seit
    05.04.2013
    Beiträge
    587
    Themenstarter
    Total Downloaded
    5,76 MB
    Total Downloaded
    5,76 MB
    ReceiverDankeAktivitäten
    Wow, das ging ja fix. Das war's dann mit dem letzten Topf.

  8. #6
    Avatar von Topfi
    Registriert seit
    05.04.2013
    Beiträge
    587
    Themenstarter
    Total Downloaded
    5,76 MB
    Total Downloaded
    5,76 MB
    ReceiverDankeAktivitäten
    Getestet -> Funktioniert.
    Ein Online Update hat allerdings nicht ausgereicht. Nach Neu Flashen war dann alles OK.

  9. Thanks Captain bedankten sich
  10. #7
    Avatar von Topfi
    Registriert seit
    05.04.2013
    Beiträge
    587
    Themenstarter
    Total Downloaded
    5,76 MB
    Total Downloaded
    5,76 MB
    ReceiverDankeAktivitäten
    Hi,
    ich habe leider schlechte Neuigkeiten: Entweder war der Fehler nie wirklich weg oder er ist wieder da (getestet mit dem Image von heute, neu geflasht).
    Das Problem tritt immer noch auf, allerdings nicht jedes Mal. Es passiert immer noch beim Shutdown per Webserver, allerdings nicht immer an der gleichen Stelle. Mal kommt er relativ weit, mal passiert es gleich zu Beginn des Shutdown Vorganges:

    Code:
    reached rl -1
    INFO: rcu_sched detected stall on CPU 1 (t=60000 jiffies)
    INFO: rcu_sched detected stalls on CPUs/tasks: { 1} (detected by 0, t=60002 jiffies)
    Call Trace:
    [<805262d0>] dump_stack+0x8/0x34
    [<8007db98>] __rcu_pending+0x520/0x528
    [<8007ef70>] rcu_check_callbacks+0x78/0x180
    [<80036214>] update_process_times+0x40/0x6c
    [<800690d8>] tick_sched_timer+0x78/0x340
    [<8004d31c>] __run_hrtimer.isra.20+0x64/0x140
    [<8004dd7c>] hrtimer_interrupt+0x198/0x4ac
    [<8000d0d8>] c0_compare_interrupt+0x50/0x88
    [<80076394>] handle_irq_event_percpu+0x78/0x310
    [<8007abb4>] handle_percpu_irq+0x8c/0xc0
    [<800759ac>] generic_handle_irq+0x3c/0x5c
    [<80006d14>] do_IRQ+0x18/0x24
    [<800027dc>] plat_irq_dispatch+0xa8/0x104
    [<80004f44>] ret_from_irq+0x0/0x4
    [<80005180>] r4k_wait+0x20/0x40
    [<80007034>] cpu_idle+0x7c/0xa4
    [<8065e8f4>] start_kernel+0x3a0/0x3c0
    
    Call Trace:
    [<805262d0>] dump_stack+0x8/0x34
    [<8007d830>] __rcu_pending+0x1b8/0x528
    [<8007f010>] rcu_check_callbacks+0x118/0x180
    [<80036214>] update_process_times+0x40/0x6c
    [<800690d8>] tick_sched_timer+0x78/0x340
    [<8004d31c>] __run_hrtimer.isra.20+0x64/0x140
    [<8004dd7c>] hrtimer_interrupt+0x198/0x4ac
    [<8000d0d8>] c0_compare_interrupt+0x50/0x88
    [<80076394>] handle_irq_event_percpu+0x78/0x310
    [<8007abb4>] handle_percpu_irq+0x8c/0xc0
    [<800759ac>] generic_handle_irq+0x3c/0x5c
    [<80006d14>] do_IRQ+0x18/0x24
    [<800027dc>] plat_irq_dispatch+0xa8/0x104
    [<80004f44>] ret_from_irq+0x0/0x4
    [<8002c394>] mktime+0xac/0xd0
    [<e0711944>] __func30__+0x168/0x410 [dvbdrive]
    [<800481e8>] kthread+0x90/0x98
    [<80006e58>] kernel_thread_helper+0x10/0x18

  11. #8
    Avatar von Topfi
    Registriert seit
    05.04.2013
    Beiträge
    587
    Themenstarter
    Total Downloaded
    5,76 MB
    Total Downloaded
    5,76 MB
    ReceiverDankeAktivitäten
    Nur zur Info:
    Problem besteht immer noch, auch mit dem neuesten Image (wo ja die neuesten Treiber drin sein sollten) von heute.


Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 16:13 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,11%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com