Thanks Thanks:  0
Ergebnis 1 bis 10 von 10
  1. #1
    Mitglied
    Registriert seit
    13.11.2013
    Beiträge
    65
    Total Downloaded
    1,48 MB
    Total Downloaded
    1,48 MB
    ReceiverDankeAktivitäten

    Lauferke vertauscht

    Hallo,
    ich betreibe an einer Quad+ eine Festplatte intern und einen USB-Stick mit Openmultiboot.
    Seit einiger Zeit sind nach dem Booten immer mal wieder die Laufwerke vertauscht,
    obwohl diese in der fstab eingetragen sind:

    rootfs / auto defaults 1 1
    proc /proc proc defaults 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    usbdevfs /proc/bus/usb usbdevfs noauto 0 0
    tmpfs /var/volatile tmpfs defaults 0 0
    usbfs /proc/bus/usb usbfs defaults 0 0
    UUID=dde645f0-f9eb-4f57-9182-852b1d2b355c /media/hdd auto defaults 0 0
    UUID=7a65f3b1-05a0-4153-a772-86b778746fff /media/sdb1 auto defaults 0 0

    Jemand ne Idee was da falsch läuft?
    Gigablue Quad Plus 2x DVB-S2 TeamBlue 6.1 im Flash, OpenATV 6.3 Multiboot
    TOSHIBA MQ01ABB2 SATA 2TB
    Panasonic TXP50GW20

    •   Alt Advertising

       

  2. #2
    Avatar von Papi2000
    Registriert seit
    20.04.2013
    Beiträge
    12.468
    Total Downloaded
    593,12 MB
    Total Downloaded
    593,12 MB
    ReceiverDankeAktivitäten
    Box 1:
    GB Q4K-SC / UE4K-SC / UE4K-C
     
     
    Box 2:
    GigaBlue Q-SSC / Q+-SSC
     
     
    Box 3:
    DM900uhd-SS / Vu+Duo
     
     
    Box 4:
    E4HD FormF3 AX Triplex VIP2-CC
     
     
    Box 5:
    diverse andere . . .
     
     
    Den Mount "UUID=7a65f3b1-05a0-4153-a772-86b778746fff /media/sdb1 auto defaults 0 0" ändern, und nach /media/usb mounten.
    NIE nach /dev/sd... selbst mounten, da das vom System beim Starten zufällig (abhängig vom Timing aller Komponenten) benutzt wird.
    Grüßle
    Ralf
    ------------------------------------------------------------------------------------------------------------------------
    Gigablue Quad 4K-multi,Quad+-SSC,Quad-SSC, andere Gigas, Astra 19.2E, UniCable & KabelBW, oATV/ teamBlue
    (weitere: DM900uhd,Vu+Duo,Technisat,Edision),PC-DVB-S/C/T,PCH-A110,Xtreamer,BDP5200
    UE32C5700,UE65HU7590,LG42R51
    ---- Einen Receiver kann sich jeder kaufen - Eine stabile E²-Box muß man sich verdienen! ----



  3. #3
    Mitglied
    Registriert seit
    13.11.2013
    Beiträge
    65
    Themenstarter
    Total Downloaded
    1,48 MB
    Total Downloaded
    1,48 MB
    ReceiverDankeAktivitäten
    Ok, danke.
    Gigablue Quad Plus 2x DVB-S2 TeamBlue 6.1 im Flash, OpenATV 6.3 Multiboot
    TOSHIBA MQ01ABB2 SATA 2TB
    Panasonic TXP50GW20

  4. #4
    Senior Mitglied
    Registriert seit
    05.12.2015
    Beiträge
    370
    Total Downloaded
    1,74 MB
    Total Downloaded
    1,74 MB
    ReceiverDankeAktivitäten
    Box 1:
    VU+ Uno 4K SE openPLi 7.0
     
     
    Box 2:
    VU+ Uno 4K SE openPLi 7.0
     
     
    Box 3:
    ET9200 openPLi 4.0
     
     
    Du hast doch gar nicht nach /dev gemountet.

    Stimmen die UUIDs denn noch?


    Kannst du mit

    blkid

    Auf der Kommandozeile prüfen

    Die UUID ändert sich ja bei jedem neuen mkfs bzw formatieren

  5. #5
    Avatar von Papi2000
    Registriert seit
    20.04.2013
    Beiträge
    12.468
    Total Downloaded
    593,12 MB
    Total Downloaded
    593,12 MB
    ReceiverDankeAktivitäten
    Box 1:
    GB Q4K-SC / UE4K-SC / UE4K-C
     
     
    Box 2:
    GigaBlue Q-SSC / Q+-SSC
     
     
    Box 3:
    DM900uhd-SS / Vu+Duo
     
     
    Box 4:
    E4HD FormF3 AX Triplex VIP2-CC
     
     
    Box 5:
    diverse andere . . .
     
     
    Das ist egal. /dev/sd... wird automatisch zu /media/sd... weitergereicht.
    Also nicht benutzen.
    /media am besten garnicht selbst bevölkern, damit es nicht mit Auto-Regeln kollidiert.
    Grüßle
    Ralf
    ------------------------------------------------------------------------------------------------------------------------
    Gigablue Quad 4K-multi,Quad+-SSC,Quad-SSC, andere Gigas, Astra 19.2E, UniCable & KabelBW, oATV/ teamBlue
    (weitere: DM900uhd,Vu+Duo,Technisat,Edision),PC-DVB-S/C/T,PCH-A110,Xtreamer,BDP5200
    UE32C5700,UE65HU7590,LG42R51
    ---- Einen Receiver kann sich jeder kaufen - Eine stabile E²-Box muß man sich verdienen! ----



  6. #6
    Mitglied
    Registriert seit
    13.11.2013
    Beiträge
    65
    Themenstarter
    Total Downloaded
    1,48 MB
    Total Downloaded
    1,48 MB
    ReceiverDankeAktivitäten
    Nachdem ich das geändert habe, waren die Laufwerke heute wieder vertauscht.

    rootfs / auto defaults 1 1
    proc /proc proc defaults 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    usbdevfs /proc/bus/usb usbdevfs noauto 0 0
    tmpfs /var/volatile tmpfs defaults 0 0
    usbfs /proc/bus/usb usbfs defaults 0 0
    UUID=dde645f0-f9eb-4f57-9182-852b1d2b355c /media/hdd auto defaults 0 0
    UUID=7a65f3b1-05a0-4153-a772-86b778746fff /media/usb auto defaults 0 0

    Die UUID stimmen noch. Die Box fährt mit dem Powertimer hoch und runter.
    Könnte es evtl noch einen Zusammenhang mit dem Openmultiboot geben?
    Bzw welche fstab wird verwendet? Die vom Flash oder vom gebootetem Image?
    Geändert von vsync (07.01.2019 um 20:40 Uhr)
    Gigablue Quad Plus 2x DVB-S2 TeamBlue 6.1 im Flash, OpenATV 6.3 Multiboot
    TOSHIBA MQ01ABB2 SATA 2TB
    Panasonic TXP50GW20

  7. #7
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    3.572
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Tja dieses Problem kenn ich sowohl von meiner Mutant HD 2400 als auch von der VU Ultimo 4k und das Problem hat auch gar nix mit den verwendeten Mounts wie z.b: sdax zu tun
    denn mdev checkt ja eh auch die fstab, das Problem liegt an Openmultiboot.
    Probiers mal ein paar Tage aus mit nur einem Image im Flash und gänzlich ohne Openmultiboot und du wirst sehen das die Mounts halten.

    Bzw welche fstab wird verwendet? Die vom Flash oder vom gebootetem Image?
    Natürlich die vom Image welches du hochgefahren bist (also wenns Image vom Flash läuft dann deren fstab, wenn Image vom Openmultiboot (Stick) dann die fstab vom Stick),

    Datenträger per uuid in der fstab eingetragen sollten 100 % halten, das vertauschen der Mounts trotz uuid Einträgen in der fstab kenn ich nur bei Verwendung von Openmultiboot
    , und das liegt dann wohl daran das so manche Box nicht komplett korrekt bzw. gar nicht von Openmultiboot unterstützt wird, mit meiner alten ET9000 hatte ich z.b: mit Openmultiboot niemals solche Probleme.
    Ich hatte insgesamt als ich Openmultiboot verwendet hatte (is schon länger her) drei Images am Laufen , davon war das OpenATV im Flash und die anderen beiden
    Images auf Stick (da ich aber viele Datenträger an der Box hatte) war das mit den vertauschten Mounts nicht mehr praktikabel denn da waren ja mehrere Mounts vertauscht
    als nur zwei - seit dem verwende ich kein Openmultiboot mehr.
    Kannst auch mal probieren die Imges zu vertauschen also das welches du jetzt im Flash hast auf Stick und das was jetzt am Stick is in den Flash
    , vielleicht wirds da besser, aber ich glaubs nicht wirklich.

    Wie auch immer, man könnte als Workarround ein Script schreiben das nach dem Start der Box per cron aufgerufen würde und die Mounts zuerst checkt und wenn vertauscht
    werden halt die beiden Datenträger umountet und neu richtig gemountet - is aber die Mühe eigentlich nicht wert und auch sicher keine schöne Lösung.


    Grüsse
    Pike
    Geändert von Pike_Bishop (07.01.2019 um 21:51 Uhr)
    OpenATV-6.2

    Script Collection

  8. #8
    Avatar von Papi2000
    Registriert seit
    20.04.2013
    Beiträge
    12.468
    Total Downloaded
    593,12 MB
    Total Downloaded
    593,12 MB
    ReceiverDankeAktivitäten
    Box 1:
    GB Q4K-SC / UE4K-SC / UE4K-C
     
     
    Box 2:
    GigaBlue Q-SSC / Q+-SSC
     
     
    Box 3:
    DM900uhd-SS / Vu+Duo
     
     
    Box 4:
    E4HD FormF3 AX Triplex VIP2-CC
     
     
    Box 5:
    diverse andere . . .
     
     
    Wenn ich das richtig verstanden habe, bringt dir ein Script doch nichts, wenn garnicht das richtige Image wie erwartet gestartet wurde.
    Das hängt aber auch mit der Erkennung der Laufwerke schon zum Bootzeitpunkt zusammen. Ich weiß jetzt nicht, wie man dem beikommen könnte. Oder wo das abgefangen ist, welches das eigentliche MultiBoot-Device mit den zu startenden Images sein soll.
    Geändert von Papi2000 (07.01.2019 um 22:59 Uhr)
    Grüßle
    Ralf
    ------------------------------------------------------------------------------------------------------------------------
    Gigablue Quad 4K-multi,Quad+-SSC,Quad-SSC, andere Gigas, Astra 19.2E, UniCable & KabelBW, oATV/ teamBlue
    (weitere: DM900uhd,Vu+Duo,Technisat,Edision),PC-DVB-S/C/T,PCH-A110,Xtreamer,BDP5200
    UE32C5700,UE65HU7590,LG42R51
    ---- Einen Receiver kann sich jeder kaufen - Eine stabile E²-Box muß man sich verdienen! ----



  9. #9
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    3.572
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Wenn ich da richtig verstanden habe, bringt dir ein Script doch nichts, wenn garnicht das richtige Image wie erwartet gestartet wurde.
    Also bei mir wars damals zum Glück so das gerade der Stick mit Openmultiboot darauf immer korrekt gemountet wurde.
    Kann jetzt gar nicht sagen was passiert wenn ein Openmultiboot Image am Stick liegt dessen Mount jedoch zu z.b: /media/hdd vertauscht wird
    ob das Image am Stick dann dennoch hochfährt ?

    Aber stimmt, Workarround mit Script wird in dem Fall eh nicht klappen denn man müsste ja z.b: wenn Image von Stick hochgefahren ist den Mount auf dem das Image läuft ja umounten
    Ich würd ganz einfach auf Openmultiboot verzichten - is wohl das einfachste, oder jemand passt das mal für die Problemboxen an dann
    müsste das allerdings in jedem Image passieren denn Openmultiboot im Oatv unterscheidet sich ja auch zu Openmultiboot im PLi und anderen Images.


    Grüsse
    Pike
    OpenATV-6.2

    Script Collection

  10. #10
    Mitglied
    Registriert seit
    13.11.2013
    Beiträge
    65
    Themenstarter
    Total Downloaded
    1,48 MB
    Total Downloaded
    1,48 MB
    ReceiverDankeAktivitäten
    Komischerweise steht seit neuestem beim Booten wieder an der Gigablue "VU+ OpenMultiboot" im Display.
    Ob da was verdreht ist?
    Gigablue Quad Plus 2x DVB-S2 TeamBlue 6.1 im Flash, OpenATV 6.3 Multiboot
    TOSHIBA MQ01ABB2 SATA 2TB
    Panasonic TXP50GW20


Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 04:18 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2019 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,11%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com