Thanks Thanks:  0
Ergebnis 1 bis 8 von 8
  1. #1
    Anfänger
    Registriert seit
    19.09.2015
    Beiträge
    5
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten

    OpenATV 5.1 does not keep EPG language setting after restart

    There is an option to select the EPG language on channels that provide multilingual EPG. While the option does make a change when set, after enigma2 restart it is not applied. Here in Greece we have some DVB-T channels that have English and Greek EPG. If I set the EPG prefer language as Greek, enigma2 on OpenATV starts showing the EPG in Greek (before it was in English). But after enigma2 restart, it is again English. You have to go to the setting again and change it to some other language, then back to Greek to make it work.
    If you want to test this, there are also Greek channels with dual language EPG on Hotbird (Nova package) and on Eutelsat 9A (OTE TV package).
    On enigma2 fron OpenPLi this works correctly even after a reboot.

    I guess an initialization based on the saved option is not done on enigma2 startup.

    •   Alt Advertising

       

  2. #2
    Anfänger
    Registriert seit
    19.09.2015
    Beiträge
    5
    Themenstarter
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    I have tried to fix this myself by examining the code. I really can't find why it doesn't work on OpanATV. At startup, Components.UsageConfig.InitUsageConfig() is called, which reads the config.autolanguage.audio_epglanguage = ConfigSelection(audio_language_choices[:1] + audio_language_choices [2:], default="---") and calls eServiceEvent.setEPGLanguage(configElement.value) in event.h, which sets m_language in eServiceEvent class, which is then used in event.cpp eServiceEvent:ParseFrom . So everything looks correct. I haven't put debug code in event.cpp yet. Is it possible that when InitUsageConfig() is called, the eServiceEvent object does not exist?

    EPG language is set correctly after init (if you go to menu and change the setting again). Any hint?

  3. #3
    Anfänger
    Registriert seit
    25.12.2014
    Beiträge
    2
    Total Downloaded
    32,27 MB
    Total Downloaded
    32,27 MB
    ReceiverDankeAktivitäten
    Kai ego to idio provlima me epg se epigio digea eno ta ert ehoun panta elliniko epg. To open atv den einai kalo gia dreambox. Einai to much. Wale openpli einai ligo kalitero. Genika thanks gia ta atoma pou ftiaxnoun ta image. Pali kala einai!

  4. #4
    Avatar von Thomas4711
    Registriert seit
    07.04.2013
    Ort
    OpenATV - Wien
    Beiträge
    13.165
    Total Downloaded
    51,16 MB
    Total Downloaded
    51,16 MB
    ReceiverDankeAktivitäten
    please use english here. I don't understand anything



  5. #5
    Anfänger
    Registriert seit
    19.09.2015
    Beiträge
    5
    Themenstarter
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    He wrote that the same problem exists on multilingual EPG from Greek DVB-T provider Digea. EPG is transmitted in two languages, English and Greek, and the option of preferred language is not configured on startup.

    @DrNickRivierra: I know it works on OpenPLi, I mentoned that above. The weird thing is that I don't see any differences on the code between OpenPLi and OpenATV concerning this issue.

  6. #6
    Anfänger
    Registriert seit
    26.12.2015
    Beiträge
    9
    Total Downloaded
    27,33 MB
    Total Downloaded
    27,33 MB
    ReceiverDankeAktivitäten
    I have same problem . any solutions
    Geändert von tyro (26.12.2015 um 14:19 Uhr)

  7. #7
    Anfänger
    Registriert seit
    26.12.2015
    Beiträge
    9
    Total Downloaded
    27,33 MB
    Total Downloaded
    27,33 MB
    ReceiverDankeAktivitäten
    thaaaanks
    Geändert von tyro (25.01.2016 um 16:51 Uhr)

  8. #8
    Anfänger
    Registriert seit
    30.07.2014
    Beiträge
    12
    Total Downloaded
    113,5 KB
    Total Downloaded
    113,5 KB
    ReceiverDankeAktivitäten
    Box 1:
    DM800SE
     
     
    Box 2:
    Miniplus
     
     
    Box 3:
    Zgemma H1/ H2
     
     
    Box 4:
    Zgemma LC
     
     
    hi,

    i am using openatv 5.3 for miniplus and i faced this problem too.
    I added my own language in by editing E2. it works for openpli and openatv 5.3 for LC
    Any hint?
    I did the same for openpli and opeatv for LC and it works.


Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 17:04 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2018 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,76%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com