Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14
  1. #1
    Mitglied
    Registriert seit
    15.10.2015
    Beiträge
    41
    Thanks (gegeben)
    3
    Thanks (bekommen)
    3
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    Edision OSmini S2 (Single)
     
     

    Power-Timer Problem

    Hallo die Experten,

    Bei mir wird die OSmini fast nur für Radioempfang benutzt, und kürzlich habe ich auf OpenATV 6.1 umgestellt, weil mit meinem älteren 5.3 die 'Radio France' Sender nur noch zerhackt wiedergegeben wurden - mit der letzten 5.3 und mit 6.1 ist das aber wieder in Ordnung.

    Aber mit 6.1 funktioniert das Power-Timer gesteuerte "Aufwachen und in Standby gehen" nicht mehr richtig. Die Box wacht zwar richtig auf und geht in Standby; wenn man sie dann aber mit der FB einschaltet, bleibt sie öfter stumm. Erst, wenn man einen Kanal wählt, geht sie wieder.

    Wenn sie stumm bleibt, steht bei SNR N/A, und auch in allen Kanaleinträgen (z. B. Multiplex und PIDs) steht nichts bzw. N/A.

    Beim Aufwachen mit der FB passiert das nicht, aber mir ist aufgefallen, daß nach dem Aufwachen 1-2 Sekunden auch N/A bei SNR steht, bevor der Kanal startet. Das legt den Verdacht nahe, daß bei dem Timer-gesteuerten 'Aufwachen und in Strandby gehen' zu früh in Standby geschaltet wird.

    Als Versuch zur Lösung des Problems habe ich den 'Workaround zum Aufwachen aus dem Deepstandby' eingechaltet. In der Tat scheint damit der Kanal richtig nach dem Aufwachen initialisiert und er funktioniert, aber dafür gibt es ein anderes Problem: Nach dem Timer-gesteuerten 'Aufwachen und in Standby gehen' geht die Box öfter nicht in Standby, sondern sie wird voll eingeschaltet.

    Jetzt bin ich ziemlich ratlos, was ich noch machen könnte (außer, wieder auf 5.3 zurückzugehen).


    Viele Grüße, ZC4BR

    •   Alt Advertising

       

  2. #2
    Hautdenlucas
    Gast
    bei mir atv 6.1 ging die box kurz vor 1 Uhr plötzlich an. habe einen cron timer entdeckt, der da einfach drinn war. den habe ich entfernt, mal schaun ob es geholfen hat.

  3. #3

    Registriert seit
    08.06.2014
    Beiträge
    2.600
    Thanks (gegeben)
    778
    Thanks (bekommen)
    1497
    Total Downloaded
    22,11 MB
    Total Downloaded
    22,11 MB
    ReceiverDankeAktivitäten
    @ZC4BR

    Der Workaround sollte dein Problem nicht lösen. Die Ursache, das sie wenn er aktiviert ist manchmal nicht in den Standby geht, ist die ungenaue Weckzeit. Oder er bekommt keine aktuelle Zeit und befindet sich somit nicht in dem Zeitfenster damit ein timergesteuertes aufwachen erkannt wird.

    Du könntest aber mal einen normalen Aufwachtimer erstellen und bei Beendigung in den Standby gehen eintragen - so 1 min später. Löst das dein Problem?

  4. #4
    Mitglied
    Registriert seit
    15.10.2015
    Beiträge
    41
    Thanks (gegeben)
    3
    Thanks (bekommen)
    3
    Themenstarter
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    Edision OSmini S2 (Single)
     
     
    Vielen Dank für die Rückmeldungen.

    @iPkay: Obwohl mir nicht ganz klar ist, warum die Box bei dem Workaround nicht in jedem Fall wieder in Standby geht, würde sicher der normale Aufwachtimer und später ein weiterer Timer in Standby das Problem lösen. Ist bei mir aber unschön, weil ich mit dem Betrieb manchmal Minidisc-Aufnahmen erzeuge, und das gibt dann einen unnötigen Vorlauf.

    Obwohl das Problem von Hautdenlucas scheinbar nichts mit meinem Problem zu tun hat, habe ich mir trotzdem mal die Cron-Timer angeschaut. Und in der Tat war bei mir auch ein Cron-Timer gesetzt, der stündlich einen nptdate-synch durchführte. Da ich die meiste Zeit das Netzwerk ohnehin nicht aktiviert habe, läuft der natürlich ins Leere, und er könnte mit seiner Latenz bis zu seinem timeout das Aufwachen stören. Ich habe ihn daher gelöscht, aber leider hat das das Problem auch nicht gelöst: es kommt immer noch vor, daß die Box nach dem Aufwachen mit nicht-initialisiertem Kanal stumm bleibt.

    Grüße ZC4BR

  5. #5

    Registriert seit
    08.06.2014
    Beiträge
    2.600
    Thanks (gegeben)
    778
    Thanks (bekommen)
    1497
    Total Downloaded
    22,11 MB
    Total Downloaded
    22,11 MB
    ReceiverDankeAktivitäten
    Workaround: Manche Boxen liefern kein zuverlässiges Signal wenn sie durch einen Timer aufgewacht werden. Somit würden diese unzuverlässig oder nie in den Standby gehen. Aktiviert man den Workaround so existiert nun ein Zeitfenster (Aufwachzeit +- Minuten). Befindet sich die Box beim starten in diesem Zeitbereich so wird das als Wecken durch einen Timer interpretiert. Damit das funktioniert muss die Box auch zur passenden Zeit aufwachen. Manche Boxen starten aber früher oder später und bei allen ist 1970. Also kommt noch die Uhrzeitsynchronisation dazu die unter Umständen auch mal fehlschlägt. Die genaue Ursache ist in jedem Fall nur in einem e2 Log zu sehen.

    Ich verstehe das mit den Aufnahmen nicht. Beim Powertimer mit Aufwachen und in den Standby gehen kannst ja sowieso nichts aufnehmen weil die Tuner nicht aktiv sind. Ich meinte auch keine zwei Timer sondern einen. Jeder Timer hat eine Start- und Endaktion. Also z.B. Timer 19:00 Aufwachen, 19:01 in den Standby gehen. Wäre zumindest einen Test wert. Wäre auch interessant ob es nur bei dem Radiosender oder auch bei anderen Sendern (auch TV) auftritt.

    Alternativ: Wenn du dir zutraust eine Datei zu ändern + zu ersetzen dann wäre diese Zeile eine Möglichkeit das Abschalten in den Standby zu verzögern.

  6. #6
    Mitglied
    Registriert seit
    15.10.2015
    Beiträge
    41
    Thanks (gegeben)
    3
    Thanks (bekommen)
    3
    Themenstarter
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    Edision OSmini S2 (Single)
     
     
    Hallo iPkay,

    vielen Dank für die Erklärung des Workaround. Allerdings ist mir nicht klar, auf welchen der beiden Fehler beim "Aufwachen und in Standby gehen" sich Dein Lösungsvorschlag bezieht:
    a.) Ohne Workaround wird gelegentlich der Kanal nicht initialisiert.
    b.) Mit Workaround geht die Box gelegentlich nicht in Standby.

    Wenn man mit einem Timer Aufwachen und dann in Standby gehen will, muß mindestens 5 Minuten zwischen den beiden Zeiten liegen. Das geht zwar, aber mit den 5 Minuten Vorlauf beim Aufwachen kommen so mindestens zehn Minuten Betrieb zustande. Ich habe eine Hardware, die den Betrieb erkennt und damit meine ganze Anlage einschaltet und auch ggf. Minidisc-Aufnahmen startet - mit oder ohne Tuner. Daher ist dieser Weg für mich nicht sehr brauchbar. Da der Fehler nicht immer auftritt, sind 5-10 Test erforderlich, um halbwegs sicher zu sein, daß sich etwas verändert hat. Das kostet viel Zeit. Daher versuche ich lieber erst einmal durch genaues Hinschauen den Fehler einzugrenzen, wobei ich mich auf die Situation ohne Workaround beschränke, weil da ja bis auf die Kanalinitialisierung der Timer richtig funktioniert.

    Beim 'Aufwachen und in Standby gehen' wird bei 5.3 nach dem Booten der Kanal für einige Sekunden eingeschaltet, bevor die Box in Standby geht (um die Zeit von Transponder zu holen?). Bei 6.1 zählt die Box bis 100 hoch und geht dann sofort in Standby - ziemlich genau nach 60s.

    Ich habe kein Problem damit, die Datei wie vorgeschlagen zu hacken, aber im Moment verstehe ich nicht, warum Dein Hack das Problem lösen soll. Ich würde eher vermuten, daß in Zeile 161 die 60 auf 70 oder 75 erhöht werden müsste, um das gleiche Verhalten wie bei 5.3 zu erzielen.?

    Vielen Dank für Deine Geduld!

    Grüße, ZC4BR

  7. #7

    Registriert seit
    08.06.2014
    Beiträge
    2.600
    Thanks (gegeben)
    778
    Thanks (bekommen)
    1497
    Total Downloaded
    22,11 MB
    Total Downloaded
    22,11 MB
    ReceiverDankeAktivitäten
    Also am Powertimer hat sich ja schon ewig nichts in dieser Richtung geändert. Möglich ist auch das neue Treiber oder anderes die Probleme verursacht.

    Die Zeile 161 ist für Timer die nicht in den Standby starten, das mit den 5 Minuten Zeitunterschied hatte ich vergessen. Würde aber sicher auch nichts bringen...
    Setze mal den Wert in 141 auf 10 oder 15 oder ... Damit verzögert sich das Standby entprechend in Sekunden.

  8. #8
    Mitglied
    Registriert seit
    15.10.2015
    Beiträge
    41
    Thanks (gegeben)
    3
    Thanks (bekommen)
    3
    Themenstarter
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    Edision OSmini S2 (Single)
     
     
    Hallo iPkay,

    in Zeile 141 steht ein Printbefehl, aber keine einstellbare Zahl.
    ????

    Gruß, ZC4BR

  9. #9

    Registriert seit
    08.06.2014
    Beiträge
    2.600
    Thanks (gegeben)
    778
    Thanks (bekommen)
    1497
    Total Downloaded
    22,11 MB
    Total Downloaded
    22,11 MB
    ReceiverDankeAktivitäten
    Ich meinte 126 wie ich vorher schon geschrieben hatte, keine Ahnung wie ich auf 141 gekommen bin...

  10. #10
    Mitglied
    Registriert seit
    15.10.2015
    Beiträge
    41
    Thanks (gegeben)
    3
    Thanks (bekommen)
    3
    Themenstarter
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDankeAktivitäten
    Box 1:
    Edision OSmini S2 (Single)
     
     
    Hallo iPkay,

    ok, alles klar. Die nächsten drei Wochen sind bei mir sehr voll, und es wird ein bisschen dauern, bis ich das angehen kann. Auch, weil ich erst mal lernen muss, wie ich am bequemsten die .pyo erzeuge bzw. ersetze.
    Ich gebe Rückmeldung, sobald ich das gemacht habe. Vorläufig habe ich erst einmal wieder auf 5.3 geflashed.
    Noch einmal meinen herzlichen Dank für die Unterstützung!

    Grüße, ZC4BR


Seite 1 von 2 12 LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Alle Zeitangaben in WEZ +1. Es ist jetzt 10:29 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2021 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 6,25%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com