Thanks Thanks:  9
Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 34
  1. #11
    Avatar von Captain
    Registriert seit
    03.04.2013
    Beiträge
    11.420
    Total Downloaded
    162,35 MB
    Total Downloaded
    162,35 MB
    ReceiverDankeAktivitäten
    gerade das image noch mal neu installiert, hatte das image heute Abend noch mal neugebaut also der fix ist heute schon enthalten...

    -bt.jpg


    openATV we are open Source

    Boykott GPL violator

    •   Alt Advertising

       

  2. #12
    Anfänger
    Registriert seit
    18.10.2014
    Beiträge
    26
    Themenstarter
    Total Downloaded
    79,93 MB
    Total Downloaded
    79,93 MB
    ReceiverDankeAktivitäten
    Perfekt, nach einem Softwareupdate funktioniert das jetzt!

    Super Arbeit mal wieder ;-)

    greetz giniman

  3. #13
    Senior Mitglied
    Registriert seit
    16.10.2015
    Beiträge
    107
    Total Downloaded
    46,68 MB
    Total Downloaded
    46,68 MB
    ReceiverDankeAktivitäten
    Box 1:
    Technisat Digicorder isio s
     
     
    Box 2:
    Edision os mini S2 + S2
     
     
    Hmm, bei mir tuts nicht zuverlässig:

    1. Koppeln: Klappt erst nach mehreren Versuchen. Das liegt wohl an meiner Bluetooth-Tastatur (eine Air-Mouse von ipazzport). Aber nach 4..5x klappts.
    2. Nicht alle Tasten funktionieren, genauer: Die Zifferntasten und die Multimedia-Tasten funktionieren prima direkt in OpenATV. Ich hatte gehofft, daß man z.B. in OpenOpera die URLs direkt eintippen kann. Im ASCII-Keyboard funktibonieren aber nur die Kursortasten. Bei jedem Buchstaben wird ein "G" erzeugt.
    3. Es erfolgt kein automatisches Verbinden, etwa wenn ich die Settop-Box gebootet habe oder die Tastatur aus/einschalte.

    Ich habe die zwei verschiedenen Keyboar-Mappings (German keyboard, USB german keyboard) ausprobiert (sicherheitshalber mit Neuboot) - ohne Verbesserung.

    Gerade mal meine Bluetooth-Tastatur unter OpenSuse/KDE 13.2 aktiviert, da funktionieren alle Tasten wie erwartet. Falls es hilft, hier mal der OpenSuse-Log:

    Okt 26 11:10:24 purzel.home kernel: Bluetooth: RFCOMM TTY layer initialized
    Okt 26 11:10:24 purzel.home kernel: Bluetooth: RFCOMM socket layer initialized
    Okt 26 11:10:24 purzel.home kernel: Bluetooth: RFCOMM ver 1.11
    Okt 26 11:11:21 purzel.home kernel: Bluetooth: HIDP (Human Interface Emulation) ver 1.2
    Okt 26 11:11:21 purzel.home kernel: Bluetooth: HIDP socket layer initialized
    Okt 26 11:11:21 purzel.home bluetoothd[739]: Can't get HIDP connection info
    Okt 26 11:11:21 purzel.home kernel: hid-generic 0005:0A5C:8502.0001: unknown main item tag 0x0
    Okt 26 11:11:21 purzel.home kernel: input: bluetooth iPazzport as /devices/pci0000:00/0000:00:13.1/usb6/6-3/6-3:1.0/bluetooth/hci0/hci0:12/0005:0A5C:8502.0001/input/input20
    Okt 26 11:11:21 purzel.home kernel: hid-generic 0005:0A5C:8502.0001: input,hidraw0: BLUETOOTH HID v1.1b Keyboard [bluetooth iPazzport] on 00:21:86:dd:60:c7
    Okt 26 11:11:21 purzel.home upowerd[1172]: (upowerd:1172): UPower-Linux-WARNING **: no valid voltage value found for device /sys/devices/pci0000:00/0000:00:13.1/usb6/6-3/6-3:1.0/bl
    Okt 26 11:12:18 purzel.home kernel: fuse init (API version 7.23)


    Beim Koppeln mußte ich eine mehrstellige Zahlenfolge über meine Tastatur eingeben, die KDE angezeigt hat. [das klärt vermutlich Punkt 1 meiner "Probleme", meine Tastatur kann auch über 0000 gekoppelt werden, da muß ich mal die Bedienungsanleitung lesen].

    Hauptproblem ist aber, daß alle Buchstabeneingaben in Plugins als "G" gesehen werden. Selbst die Ziffern erzeugen in plugins ein "G", funktionieren aber prima in OpenATV zum Kanalwählen.


    Grüßle, Michael

  4. #14
    Avatar von madie
    Registriert seit
    05.04.2013
    Beiträge
    9.161
    Total Downloaded
    289,07 MB
    Total Downloaded
    289,07 MB
    ReceiverDankeAktivitäten
    Box 1:
    AX HD51
     
     
    das ist aber ein anderes problem. da wird die tastatur nicht korrekt erkannt.


    Du kannst niemals alle mit deinem Tun begeistern. Selbst wenn du übers Wasser laufen kannst, kommt einer daher und fragt, ob du zu blöd zum Schwimmen bist.

  5. #15
    Avatar von Captain
    Registriert seit
    03.04.2013
    Beiträge
    11.420
    Total Downloaded
    162,35 MB
    Total Downloaded
    162,35 MB
    ReceiverDankeAktivitäten
    wegen hid device kannst du dir mal das tools evtest vom feed holen und testen

    muss man sich halt alles selber anpassen die keymaps und co passend zur tastertur layout , joypad und co, vielleicht bekommen wir mal mehr infos zusammen das es für zuküftige user dann einfacher wird aber das is leider linux da wird es kompliziert


    openATV we are open Source

    Boykott GPL violator

  6. #16
    Anfänger
    Registriert seit
    18.10.2014
    Beiträge
    26
    Themenstarter
    Total Downloaded
    79,93 MB
    Total Downloaded
    79,93 MB
    ReceiverDankeAktivitäten
    Zitat Zitat von olwaldi Beitrag anzeigen
    Hmm, bei mir tuts nicht zuverlässig:

    ...

    Hauptproblem ist aber, daß alle Buchstabeneingaben in Plugins als "G" gesehen werden. Selbst die Ziffern erzeugen in plugins ein "G", funktionieren aber prima in OpenATV zum Kanalwählen.


    Grüßle, Michael
    Meine Logitech Tastatur verhält sich genau gleich wie bei dir. Wenn ich im Mediaportal nach etwas suchen möchte, dann werden nur große "G" übermittelt, egal welche Taste ich auf der Tastatur betätige. Innerhalb der OpenATV Menüs kann ich mit den Pfeiltasten und Return ohne Probleme navigieren.

  7. Thanks olwaldi bedankten sich
  8. #17
    Senior Mitglied
    Registriert seit
    16.10.2015
    Beiträge
    107
    Total Downloaded
    46,68 MB
    Total Downloaded
    46,68 MB
    ReceiverDankeAktivitäten
    Box 1:
    Technisat Digicorder isio s
     
     
    Box 2:
    Edision os mini S2 + S2
     
     
    Zitat Zitat von madie Beitrag anzeigen
    das ist aber ein anderes problem. da wird die tastatur nicht korrekt erkannt.
    Dann ist das vielleicht ein Mißverständnis: Meine LOGs sind von OpenSuse mit derselben Tastatur und NICHT vom OS mini. Unter OpenSuse funktionieren alle Zeichen inkl. der Sonderzeichen. Unter Android 3.2 - ich weiß, uralt - funktionieren hingegen z.B. die Mediakeys nicht, wohl aber y bzw. z.

    Das Koppeln an sich funktioniert beim OS mini (nach 2..3 Versuchen). Dann funktionieren die Zifferntasten in OpenATV problemlos.

    Da man in OpenATV das Tastaturlayout einstellen kann, würde ich vermuten, daß dort, wo eine virtuelle Tastutau angeboten wird, mit Bluetooth-Tastatur eben die Buchstabentasten funktionieren sollten (und nicht konstant auf "G" bei jeder BUCHSTABENtaste ein großes G).
    An meiner Tastatur scheints nicht zu liegen, giniman hat mit seiner Logitech-Tastatur genau dasselbe Problem. Ich könnte mir z.B. vorstellen, daß ein keyevent in ein mehrbytiges Wort umgesetzt wird, und daß da ggf. immer das falsche Byte an die Apps weitergegeben wird. Es gibt ja vermutlich nicht soviele Anwender, die eine Tastatur an ihren OS mini anschließen wollen:-)

    Anders siehts m.E. aus, wenn in der OpenATV-GUI Textstrings abgefragt werden. Dort gibt es den Handy-Modus (also Zifferntasten mehrmals drücken, um ein Zeichen auszuwählen). Da müßte vermutlich OpenATV erweitert werden, damit eine direkte Zeicheneingabe funktioniert (wäre ein Erweiterungsvorschlag für eine 5.2, aber wirklich nur absolute low priority).


    Ich werde morgen mal den Tip von Captain umsetzen mit evtest (Danke @Captain).


    Grüßle, Michael

  9. #18
    Senior Mitglied
    Registriert seit
    16.10.2015
    Beiträge
    107
    Total Downloaded
    46,68 MB
    Total Downloaded
    46,68 MB
    ReceiverDankeAktivitäten
    Box 1:
    Technisat Digicorder isio s
     
     
    Box 2:
    Edision os mini S2 + S2
     
     
    Habe jetzt mal mit evtest die Tastaturevents gelesen - sieht für mich gut aus. Jede Taste löst m.E. genau das gewünschte Zeichen aus. Allerdings werden "Y" und "Z" vertauscht. Trotzdem wird jeder Buchstaben-Tastendruck von den "virtuellen" OpenATV-Keyboards konsequent in "G" gemappt.

    Auch meine Koppelprobleme habe ich vermutlich geklärt: Meine Tastatur ist eine Airmouse und sendet bei Bewegung Mauszeiger-Events (die man super in evtest sieht). Wenn ich das in meiner Airmouse abschalte, klappt das Koppeln zuverlässiger.

    [Die Mauszeiger-Events meiner Airmouse werden übrigens prima weggefiltert von OpenATV (gibt ja keinen Mauszeiger).]

    D.h. ich vermute ein Problem in dem Modul, das in OpenATV die "virtuelle" Tastatur anzeigt (das GGGG-Problem hat auch ein anderer Anwender im Mediaportal-Plugin gemeldet). Noch weiter vermutet: auch ein normales USB-Keyboard würde bei Buchstabeneingabe immer nur ein "G" ausgeben.


    Bitte bei Gelegenheit mal danach gucken (kein wirklich ernstes Problem).

    Danke schonmal vorab, Michael

  10. #19
    Avatar von madie
    Registriert seit
    05.04.2013
    Beiträge
    9.161
    Total Downloaded
    289,07 MB
    Total Downloaded
    289,07 MB
    ReceiverDankeAktivitäten
    Box 1:
    AX HD51
     
     
    Nicht Äpfel und Birnen durcheinander werfen. Der/die User haben das Problem nur im Mediaportal. Ansonsten funktioniert es mit der virtuellen Tastatur im Image. Und es ist auch nur eine Box betroffen.
    Ich würde sagen das ist ein anderes Problem.

    Gesendet von meinem SM-G800F mit Tapatalk


    Du kannst niemals alle mit deinem Tun begeistern. Selbst wenn du übers Wasser laufen kannst, kommt einer daher und fragt, ob du zu blöd zum Schwimmen bist.

  11. #20
    Senior Mitglied
    Registriert seit
    16.10.2015
    Beiträge
    107
    Total Downloaded
    46,68 MB
    Total Downloaded
    46,68 MB
    ReceiverDankeAktivitäten
    Box 1:
    Technisat Digicorder isio s
     
     
    Box 2:
    Edision os mini S2 + S2
     
     
    Ich hab' natürlich nicht alle virtuellen Tastaturen ausprobiert, aber das GGGG Problem habe ich in
    - Mediaportal
    - OpenOpera (bei Direkteingabe einer URL)

    In OpenATV selber bin ich bisher nirgends auf eine virtuelle Tastatur gestoßen - da gibts in der GUI die SMS-Tastatur, und die funktioniert prima mit meinem Bluetooth-Keyboar.d. Das Problem sehe ich eben immer nur dann, wenn eine ASCII-Tastatur angezeigt wird, die man durch Cursorbewegung und OK bedienen kann, auch dann nur mit Buchstaben/Zifferntasten (wird immer zu "G"). Diese virtuelle ASCII-Tastatur kann ich auch mit der Bluetooth-Tastatur bedienen, solange ich nur Cursur-Tasten oder Enter verwende.

    Ich vermute mal, daß außer ganz wenigen Anwendern kaum jemand eine Tastatur am SAT-Receiver betreibt. Ich würde mich daher freuen, wenn jemand berichtet, wenn er problemlos Buchstaben via physikalischer Tastatur eingeben kann. Dann wäre klar, daß es an meiner Hardware liegt.


    Grüßle, Michael


Seite 2 von 4 ErsteErste 1234 LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 01:46 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2018 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 10,53%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com