Thanks Thanks:  6
Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 39
  1. #1
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     

    Wie kann ich hier die Laustärke verringern?

    Hallo!

    Ich habe folgendes Skript:
    Code:
    if [ -e /usr/share/bootvideo.mkv ]; then
     if [ -e /usr/bin/eplayer4 ]; then
      if [ "$(grep config.audio.volume /etc/enigma2/settings)" ]; then
       vol=`grep config.audio.volume /etc/enigma2/settings | cut -d"=" -f2`
      else
       vol=50
      fi
      voldb=$((63-vol*63/100))
      if [ -e /proc/stb/avs/0/volume ]; then
       echo $voldb > /proc/stb/avs/0/volume
      fi
      (sleep 30; killall eplayer4) & 
      /usr/bin/eplayer4 "/usr/share/bootvideo.mkv" -n 
     fi
    fi
    [ -e /etc/dropbear/dropbear_rsa_host_key ] &&  /usr/bin/showiframe /usr/share/bootlogo.mvi || /usr/bin/showiframe /usr/share/bootlogo_wait.mvi
    Und wollte da gerne die Lautstärke ändern.

    config.audio.volume /etc/enigma2/settings bedeutet, das er die Lautstärke aus den settings nimmt.
    Wenn ich dort 50 statt 100 eintippe, wird die Receiver LS insgesamt leiser.
    Das möchte ich nicht.

    Außer ich kann die danach direkt wieder auf 100 setzen.

    Wie ihr vielleicht erkennt, wird ein player gestartet, der ein bootvideo lädt.
    Und das ist viel zu laut.
    Ich habe schon versucht, die Lautstärke der mkv zu verringern, aber dass geht dann leider nur mit einem Qualitätsverlust des Videos.

    DANKE EUCH!

    •   Alt Advertising

       

  2. #2
    Avatar von Papi2000
    Registriert seit
    20.04.2013
    Beiträge
    9.528
    Total Downloaded
    592,83 MB
    Total Downloaded
    592,83 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue Q-SSC / Q+-SSC / weitere
     
     
    Box 2:
    DM900uhd-SS / Vu+Duo
     
     
    Box 3:
    Sogno 800HD Revo Triple 8800HD-SS
     
     
    Box 4:
    E4HD FormF3 AX Triplex VIP2-CC
     
     
    Box 5:
    diverse andere . . .
     
     
    Du darfst deinen Wunschwert einfach nicht hinter die "else"-Bedingung setzen. Wenn Di eLautstärke in den Settings gesetzt ist, wird dein Wunsch nicht beachtet. Also nicht:
    Code:
    ...
      if [ "$(grep config.audio.volume /etc/enigma2/settings)" ]; then
       vol=`grep config.audio.volume /etc/enigma2/settings | cut -d"=" -f2`
      else
       vol=50
      fi
    ...
    sondern
    Code:
    ...
      if [ "$(grep config.audio.volume /etc/enigma2/settings)" ]; then
       vol=`grep config.audio.volume /etc/enigma2/settings | cut -d"=" -f2`
       vol=50
       else
       fi
    ...
    Grüßle
    Ralf
    ------------------------------------------------------------------------------------------------------------------------
    Gigablue Quad 4K-multi,Quad+-SSC,Quad-SSC, andere Gigas, Astra 19.2E, UniCable & KabelBW, oATV/ OpenMips
    (weitere: DM900uhd,Vu+Duo,Technisat,Edision),PC-DVB-S/C/T,PCH-A110,Xtreamer,BDP5200
    UE32C5700,UE65HU7590,LG42R51
    ---- Einen Receiver kann sich jeder kaufen - Eine stabile E²-Box muß man sich verdienen! ----



  3. #3
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.827
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Hi,

    Wie sieht das Script denn überhaupt aus - wo is die Shebang in Zeile 1 also das;
    Code:
    #!/bin/sh
    hat das denn überhaupt mal funktioniert ?

    Hab dir mal ein paar Variablen gemacht (besser lesbar das Ganze dann)
    Code:
    #!/bin/sh
    
    PLAYER=/usr/bin/eplayer4
    SHOWIFRAME=/usr/bin/showiframe
    BOOTLOGO=/usr/share/bootlogo.mvi
    BOOTLOGO_WAIT=/usr/share/bootlogo_wait.mvi
    BOOTVIDEO=/usr/share/bootvideo.mkv
    RSA_KEY=/etc/dropbear/dropbear_rsa_host_key
    SETTINGS=/etc/enigma2/settings
    VOLUME=/proc/stb/avs/0/volume
    
    if [ -e $BOOTVIDEO ]; then
        if [ -e $PLAYER ]; then
    
            if [ "$(grep config.audio.volume $SETTINGS)" ]; then
                VOL="$(grep config.audio.volume $SETTINGS | cut -d"=" -f2)"
                VOL=50
            fi
        
            VOLDB=$((63-VOL*63/100))
    
            if [ -e $VOLUME ]; then
                echo $VOLDB > $VOLUME
            fi
    
            (sleep 30; killall eplayer4) &
            $PLAYER $BOOTVIDEO -n
        fi
    fi
    [ -e $RSA_KEY ] &&  $SHOWIFRAME $BOOTLOGO || $SHOWIFRAME $BOOTLOGO_WAIT
    Teste mal (was dir @Papi2000 zuvor gepostet hat is schon berücksichtigt - den else Zweig hab ich da rausgenommen, brauchst nicht).

    So wie das Script jetzt aber ist kapier ich allerdings grad nicht für was du dann überhaupt das;
    Code:
    if [ "$(grep config.audio.volume $SETTINGS)" ]; then
                VOL="$(grep config.audio.volume $SETTINGS | cut -d"=" -f2)"
                VOL=50
    fi
    und die nachfolgende Berechnung brauchst (musst du das überhaupt abhängig davon machen welche Lautstärke in den Settings eingestellt ist ?)
    denn wenn nicht, und du gleich die $VOLDB auf das Gewünschte setzt sollte das ja auch reichen.

    Lautstärke also $VOLDB wär dann 32 mit den Vorgaben;
    VOL=50
    VOLDB=$((63-VOL*63/100))



    Grüsse
    Biki3
    Geändert von Pike_Bishop (09.06.2014 um 18:06 Uhr)
    OpenATV-6.1

  4. #4
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.827
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Hi,

    So jetzt weiss ich wo du das her hast (hab ein bisschen gesucht und gefunden)
    Das hat @babsy98 mal im et-view gepostet heisst bootvideo und sieht so aus;
    Code:
    if [ -e /usr/share/bootvideo.mkv ]; then
        if [ "$(grep config.audio.volume /etc/enigma2/settings)" ]; then
            vol=`grep config.audio.volume /etc/enigma2/settings | cut -d"=" -f2`
        else
            vol=50
        fi
        voldb=$((63-vol*63/100))
        if [ -e /proc/stb/avs/0/volume ]; then
            echo $voldb > /proc/stb/avs/0/volume
        fi
        (sleep 30; killall gst-launch) & 
        gst-launch playbin2 uri=file:///usr/share/bootvideo.mkv
    fi
    [ -e /etc/dropbear/dropbear_rsa_host_key ] &&  /usr/bin/showiframe /usr/share/bootlogo.mvi || /usr/bin/showiframe /usr/share/bootlogo_wait.mvi
    Dann braucht das wohl keine Shebang - trotzdem versteh ich den Sinn von folgendem nicht da ich keine Ahnung hab wie das mit dem Bootvideo abläuft;
    Code:
    if [ "$(grep config.audio.volume /etc/enigma2/settings)" ]; then
            vol=`grep config.audio.volume /etc/enigma2/settings | cut -d"=" -f2`
        else
            vol=50
        fi
    Denn wenn ich nun die Einstellung zum Ton aus der /etc/enigma2/settings rausgreppe und die is z.b: voll aufgedreht da also auf 100
    dann kommt klarerweise bei der Variablen $voldb was ganz anderes raus als wenn else greift mit vol=50
    (ich versteh den Code schon, is ja nur ne einfache Fallunterscheidung aber was ist der Zweck dieser in diesem Fall ?)

    Ich würd das für deinen Fall dann mal so (jetzt mal ohne Variablen) probieren;
    Code:
    if [ -e /usr/share/bootvideo.mkv ]; then
    
        if [ -e /usr/bin/eplayer4 ]; then
            vol=32
            
                if [ -e /proc/stb/avs/0/volume ]; then
                    echo $vol > /proc/stb/avs/0/volume
                fi
            
        (sleep 30; killall eplayer4) & 
        /usr/bin/eplayer4 "/usr/share/bootvideo.mkv" -n
        
        fi
    fi
    [ -e /etc/dropbear/dropbear_rsa_host_key ] &&  /usr/bin/showiframe /usr/share/bootlogo.mvi || /usr/bin/showiframe /usr/share/bootlogo_wait.mvi
    Also das is dann quasi ne Fixvorgabe für die Lautstärke nämlich immer 32, wenns ned klappt @babsy98 is ja auch hier
    vielleicht kann er ja mal was dazu sagen - und dein Problem gleich lösen.


    Grüsse
    Biki3
    Geändert von Pike_Bishop (09.06.2014 um 21:48 Uhr)
    OpenATV-6.1

  5. #5
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    @Papi
    DANKE.
    Hat aber leider NICHT funktioniert!

    @ Biki
    Danke, dass Du Dich der Sache angenommen hast.

    Ich teste das mal.
    Aber ich meine, ich hab das auch schonmal so versucht.

    -> Nein, war auch nichts...
    Geändert von Klaus_Günther (09.06.2014 um 23:09 Uhr)

  6. #6
    Avatar von Papi2000
    Registriert seit
    20.04.2013
    Beiträge
    9.528
    Total Downloaded
    592,83 MB
    Total Downloaded
    592,83 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue Q-SSC / Q+-SSC / weitere
     
     
    Box 2:
    DM900uhd-SS / Vu+Duo
     
     
    Box 3:
    Sogno 800HD Revo Triple 8800HD-SS
     
     
    Box 4:
    E4HD FormF3 AX Triplex VIP2-CC
     
     
    Box 5:
    diverse andere . . .
     
     
    Dann rufe das Script auf der Konsole bei gestopptem E2 mal händisch auf. Da siehst du ja, welche Fehlermeldungen kommen, und wie die Ausgabe auf Änderungen am Script reagiert.
    Grüßle
    Ralf
    ------------------------------------------------------------------------------------------------------------------------
    Gigablue Quad 4K-multi,Quad+-SSC,Quad-SSC, andere Gigas, Astra 19.2E, UniCable & KabelBW, oATV/ OpenMips
    (weitere: DM900uhd,Vu+Duo,Technisat,Edision),PC-DVB-S/C/T,PCH-A110,Xtreamer,BDP5200
    UE32C5700,UE65HU7590,LG42R51
    ---- Einen Receiver kann sich jeder kaufen - Eine stabile E²-Box muß man sich verdienen! ----



  7. #7
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.827
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Hi,

    Was genau heisst denn;
    @Papi
    DANKE.
    Hat aber leider NICHT funktioniert!
    und;
    Ich teste das mal.
    Aber ich meine, ich hab das auch schonmal so versucht.

    -> Nein, war auch nichts...
    läuft das bootvideo gar nicht oder wirds nur nicht leiser ?


    Grüsse
    Biki3
    OpenATV-6.1

  8. #8
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    ???
    ÄH, jetzt wirds mir ein bischen zu hoch!

    Telnet
    init 3 oder 4 oder was das war (ich habs mir irgendwo aufgeschrieben)
    und wie starte ich das dann?

    Doch, laufen tut´s!
    Aber die Lautstärke ändert sich nicht.

  9. #9
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.827
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Ich starte Scripts immer per sh - wie heisst das Script denn nun wirklich bootvideo ?
    dann probier mal;
    Code:
    cd /zum pfad wo das Script liegt
    ./bootvideo
    EDIT !
    Ach so, klar zuvor telnet Verbindung zur Box erstmal ala;
    telnet XXX.XXX.XXX.XX
    wobei die XXX.XXX.XXX.XX mit der Ip zu deiner Box zu ersetzen sind.
    Dann anmelden mit;
    root
    und Passwort (wenn kein Passwort gesetzt wurde einfach leer lassen und nur die Enter Taste drücken).
    Geändert von Pike_Bishop (10.06.2014 um 01:20 Uhr)
    OpenATV-6.1

  10. #10
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    Das passiert:
    Code:
    root@et10000:~# cd /etc/init.d
    root@et10000:/etc/init.d# ./bootvideo
    eplayer4.c >
    File=/usr/share/bootvideo.mkv
    URI=file:///usr/share/bootvideo.mkv
    ./bootvideo: line 10:  1766 Terminated              /usr/bin/eplayer4 "/usr/shar
    e/bootvideo.mkv" -n
    /dev/dvb/adapter0/video0: Device or resource busy
    /usr/share/bootlogo_wait.mvi: No such file or directory


Seite 1 von 4 123 ... LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 16:23 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,76%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com