Thanks Thanks:  6
Seite 4 von 4 ErsteErste ... 234
Ergebnis 31 bis 39 von 39
  1. #31
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.830
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Wieso verwendest du eigentlich noch die alte Version mit eplayer4 die zweite Version (Nachfolgeversion) sieht ja so aus;
    Code:
    if [ -e /usr/share/bootvideo.mkv ]; then
        if [ "$(grep config.audio.volume /etc/enigma2/settings)" ]; then
            vol=`grep config.audio.volume /etc/enigma2/settings | cut -d"=" -f2`
        else
            vol=50
        fi
        voldb=$((63-vol*63/100))
        if [ -e /proc/stb/avs/0/volume ]; then
            echo $voldb > /proc/stb/avs/0/volume
        fi
        (sleep 30; killall gst-launch) & 
        gst-launch playbin2 uri=file:///usr/share/bootvideo.mkv
    fi
    [ -e /etc/dropbear/dropbear_rsa_host_key ] &&  /usr/bin/showiframe /usr/share/bootlogo.mvi || /usr/bin/showiframe /usr/share/bootlogo_wait.mvi
    geht die nicht ? (ich verwend grade zum Testen auch die alte Version).


    Grüsse
    Biki3
    OpenATV-6.1

    •   Alt Advertising

       

  2. #32
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.830
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Ok, gehen wir mal von dem Fall aus das Script is so wie im letzten Post, und in der etc/enigma2/settings steht das;
    config.audio.volume=100
    dann würde das Script bei der Berechnung das rausbekommen;
    0
    und die sollte nach /proc/stb/avs/0/volume geschrieben werden
    hier die einfach nachgestellte Berechnung mit Ergebnis dazu,
    Code:
    root@et9x00:~# vol=100
    root@et9x00:~# voldb=$((63-vol*63/100))
    root@et9x00:~# echo $voldb
    0
    Somit müsste also (da wir ja bereits wissen je niedriger die Zahl desto höher die Lautstärke) das Bootvideo mit voller Lautstärke laufen
    (wenn das wirklich richtig ist und dieser Eintrag den das Script da tätigt für das Bootvideo greift).


    Aber wieso macht man das abhängig davon;
    Code:
    if [ "$(grep config.audio.volume /etc/enigma2/settings)" ]; then
    also eigentlich davon das in der etc/enigma2/settings überhaupt ne Zeile mit config.audio.volume=x vorhanden ist ?
    Denn das würde ja voraussetzen das es Bedingungen gibt wo so ne Zeile gar nicht in der etc/enigma2/settings steht
    und wo dann;
    Code:
    vol=50
    greifen muss und das Script dann das bei der nachfolgenden Berechnung rausbekommt;
    32
    hier die einfach nachgestellte Berechnung mit Ergebnis dazu,
    Code:
    root@et9x00:~# vol=50
    root@et9x00:~# voldb=$((63-vol*63/100))
    root@et9x00:~# echo $voldb
    32
    Nimmt man dann also quasi die Hälfte der voll möglichen Lautstärke oder wie ?
    Welchen Sinn hat das ? Da könnt ich doch gleich genauso gut immer nen bestimmten Wert wie z.B. 50 nehmen
    und erspar mir etwas an Code und auch die Berechnung.

    Ich geh davon aus das @babsy98 ja weiss was er da geschrieben hat und sich dabei sicher was gedacht hat
    also muss das alles nen Sinn haben, aber den kennt wohl nur @babsy98 und so wirds schwer da weiter zu kommen ohne ihn.


    Grüsse
    Biki3
    Geändert von Pike_Bishop (11.06.2014 um 20:52 Uhr)
    OpenATV-6.1

  3. #33
    Avatar von Papi2000
    Registriert seit
    20.04.2013
    Beiträge
    9.556
    Total Downloaded
    592,83 MB
    Total Downloaded
    592,83 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue Q-SSC / Q+-SSC / weitere
     
     
    Box 2:
    DM900uhd-SS / Vu+Duo
     
     
    Box 3:
    Sogno 800HD Revo Triple 8800HD-SS
     
     
    Box 4:
    E4HD FormF3 AX Triplex VIP2-CC
     
     
    Box 5:
    diverse andere . . .
     
     
    Die 100 sind die Lautstärke-Digits, die beim Steuern am TV angezeigt, oder im WebIF verwendet werden:
    Null = Leise (Aus), 100 = Vollanschlag.
    Increment = 5.
    Die Teilung durch 63 soll wohl dB-Darstellung der Dämpfung sein:
    0dB Dämpfung = Volle Lautstärke, 63dB Dämpfung gilt als Stille.
    Grüßle
    Ralf
    ------------------------------------------------------------------------------------------------------------------------
    Gigablue Quad 4K-multi,Quad+-SSC,Quad-SSC, andere Gigas, Astra 19.2E, UniCable & KabelBW, oATV/ OpenMips
    (weitere: DM900uhd,Vu+Duo,Technisat,Edision),PC-DVB-S/C/T,PCH-A110,Xtreamer,BDP5200
    UE32C5700,UE65HU7590,LG42R51
    ---- Einen Receiver kann sich jeder kaufen - Eine stabile E²-Box muß man sich verdienen! ----



  4. Thanks Pike_Bishop bedankten sich
  5. #34
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    Hi!

    Genau!
    Die 100 in den Settings is die RECEIVEREIGENE Lautstärke.

    Ich verwende ja die 2. Version!
    Die wurde nur mittlerweile so gekürzt!
    Schau doch mal den Startpost an! ;-)

  6. #35
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.830
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Die 100 - ja . aber wieso haben die sich vorhin bei mir verstellt zu 0;
    Hmm, plötzlich steht da nicht mehr 100 sondern;
    config.audio.volume=0
    Muss sich also doch im Betrieb auch geändert haben.
    und ich hatte dennoch Ton am TV - hab die settings extra per FTP neu geholt und angesehen
    da dürfte bei 0 doch dann nix mehr zu hören sein.


    Grüsse
    Biki3
    OpenATV-6.1

  7. #36
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    Ich weiß es nicht!

    Gerade getestet!
    Stimmt, wenn ich den runterdrehe ist es gaaaanz ruhig!

  8. #37
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.830
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Hi,

    Also hab nun mal den Code statt so;
    Code:
    if [ -e /usr/share/bootvideo.mkv ]; then
        if [ -e /usr/bin/eplayer4 ]; then
            if [ "$(grep config.audio.volume /etc/enigma2/settings)" ]; then
                vol=`grep config.audio.volume /etc/enigma2/settings | cut -d"=" -f2`
            else
                vol=50
            fi
            voldb=$((63-vol*63/100))
            if [ -e /proc/stb/avs/0/volume ]; then
                echo $voldb > /proc/stb/avs/0/volume
            fi
            (sleep 30; killall eplayer4) & 
            /usr/bin/eplayer4 "/usr/share/bootvideo.mkv" -n 
        fi
    fi
    [ -e /etc/dropbear/dropbear_rsa_host_key ] &&  /usr/bin/showiframe /usr/share/bootlogo.mvi || /usr/bin/showiframe /usr/share/bootlogo_wait.mvi
    so probiert;
    Code:
    if [ -e /usr/share/bootvideo.mkv ]; then
        if [ -e /usr/bin/eplayer4 ]; then
            (sleep 30; killall eplayer4) & 
            /usr/bin/eplayer4 "/usr/share/bootvideo.mkv" -n 
        fi
    fi
    [ -e /etc/dropbear/dropbear_rsa_host_key ] &&  /usr/bin/showiframe /usr/share/bootlogo.mvi || /usr/bin/showiframe /usr/share/bootlogo_wait.mvi
    Nun wird also gar nix aus /etc/enigma2/settings ausgelesen oder überhaupt etwas nach /proc/stb/avs/0/volume geschrieben.
    Ergebnis: keinerlei Änderung - Bootvideo funktioniert genauso und in immer derselben Lautstärke wie auch mit dem Original Code (oben) - E2 hat auch normalen Ton danach.
    Da stellt sich nun die Frage wozu is der restliche Code also;
    Code:
    if [ "$(grep config.audio.volume /etc/enigma2/settings)" ]; then
                vol=`grep config.audio.volume /etc/enigma2/settings | cut -d"=" -f2`
            else
                vol=50
            fi
            voldb=$((63-vol*63/100))
            if [ -e /proc/stb/avs/0/volume ]; then
                echo $voldb > /proc/stb/avs/0/volume
            fi
    überhaupt gut - jedenfalls wird damit nicht die Lautstärke des Bootvideos beeinflusst.

    So wies ausieht is das was du da gerne hättest so eher nicht mal machbar @Klaus_Günther - mir is der Sinn dieses Codes jedenfalls teilweise ein Rätsel.
    @babsy98 wird sich dazu hier eher auch nicht melden sonst hätte er das bestimmt schon getan.


    Grüsse
    Biki3
    Geändert von Pike_Bishop (12.06.2014 um 15:35 Uhr)
    OpenATV-6.1

  9. Thanks Klaus_Günther bedankten sich
  10. #38
    Senior Mitglied
    Registriert seit
    06.04.2013
    Beiträge
    1.172
    Themenstarter
    Total Downloaded
    2,86 MB
    Total Downloaded
    2,86 MB
    ReceiverDankeAktivitäten
    Box 1:
    Xtrend ET10000 4xDVB-S2
     
     
    Alles klar!

    Dann Danke ich erst mal recht herzlich für Deine Hilfe.
    Desweiteren ist dann vieles im Skript auch unnötiger Ballast oder?

    Dann muss ich wohl doch eher noch mit dem Video selbst spielen...

  11. #39
    Avatar von Pike_Bishop
    Registriert seit
    05.09.2013
    Ort
    here and there
    Beiträge
    2.830
    Total Downloaded
    155,15 MB
    Total Downloaded
    155,15 MB
    ReceiverDankeAktivitäten
    Box 1:
    Mutant HD 2400
     
     
    Box 2:
    VU+ Ultimo 4K
     
     
    Box 3:
    VDR
     
     
    Box 4:
    VDR
     
     
    Desweiteren ist dann vieles im Skript auch unnötiger Ballast oder?
    Sieht jedenfalls danach aus.

    Grüsse
    Biki3
    OpenATV-6.1


Seite 4 von 4 ErsteErste ... 234

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 16:01 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,11%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com