Ergebnis 1 bis 5 von 5
  1. #1
    Anfänger
    Registriert seit
    02.10.2022
    Beiträge
    6
    Thanks (gegeben)
    2
    Thanks (bekommen)
    1
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDanke
    Box 1:
    Vu+ Solo SE V2
     
     

    Samba Server auf einem raspberry Anzeige unter Netzwerk

    Hallo zusammen,


    ich betreibe einen Samba-Server auf einem Raspberry Pi und verbinde mich von einem Windows 11-Rechner über die IP-Adresse des Raspberry Pi. Was ich zusätzlich gerne erreichen würde, ist, dass auf dem Windows-Rechner im Netzwerk ein Symbol für den Raspberry Pi angezeigt wird.


    Auf meiner VU+ Set-Top-Box läuft ebenfalls ein Samba-Server mit dem openATV-Image. Wenn ich den Samba-Server dort deaktiviere, verschwindet das Symbol im Netzwerk, und wenn ich ihn wieder aktiviere, erscheint das Symbol erneut. Ich habe versucht, die Konfigurationen des openATV-Images auf meinen Raspberry Pi zu übertragen, aber leider ohne Erfolg.

    Samba Server auf einem raspberry Anzeige unter Netzwerk-screenshot-2024-06-09-112743.png

    Meine Frage ist nun: Welche zusätzlichen Einstellungen oder Dienste sind im openATV-Image integriert, die dafür sorgen, dass der Samba-Server auf dem Windows-Rechner im Netzwerk angezeigt wird? Hat jemand eine Idee, wie ich das auch auf meinem Raspberry Pi realisieren kann?


    Vielen Dank im Voraus!
    Geändert von YaYaHomeOffice (09.06.2024 um 10:29 Uhr)

    •   Alt Advertising

       

  2. #2
    Avatar von Captain
    Registriert seit
    03.04.2013
    Beiträge
    14.980
    Thanks (gegeben)
    787
    Thanks (bekommen)
    21236
    Total Downloaded
    162,47 MB
    Total Downloaded
    162,47 MB
    ReceiverDanke
    wir habe noch ein service in samba damit Windows 10/11 deine Box sieht

    oe-alliance-core/meta-oe/recipes-connectivity/samba/wsdd.bb at 5.4 . oe-alliance/oe-alliance-core . GitHub


    openATV we are open Source

    Boykott GPL violator

  3. Thanks YaYaHomeOffice bedankten sich
  4. #3
    Senior Mitglied Avatar von RickX
    Registriert seit
    30.05.2022
    Ort
    NRW
    Beiträge
    328
    Thanks (gegeben)
    145
    Thanks (bekommen)
    163
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDanke
    Box 1:
    Vu+ Uno 4K SE (OpenATV 7.0)
     
     
    Box 2:
    Vu+ Duo 2 (VTI 15)
     
     
    Du solltest den wsdd im Software-Feed deines Raspberry-Betriebssystems finden.

  5. Thanks YaYaHomeOffice bedankten sich
  6. #4
    Anfänger
    Registriert seit
    02.10.2022
    Beiträge
    6
    Thanks (gegeben)
    2
    Thanks (bekommen)
    1
    Themenstarter
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDanke
    Box 1:
    Vu+ Solo SE V2
     
     
    Danke!!!! ich dreh durch, wsdd war es was noch gefehlt hat, dazu noch zwei ports öffnen und der pi ist sichtbar in windows!

    Code:
    sudo apt-get install wsdd
    
    sudo iptables -A INPUT -i eth0 -p udp --destination-port 3702 -j ACCEPT
    sudo iptables -A INPUT -i eth0 -p tcp --destination-port 5357 -j ACCEPT

  7. Thanks RickX bedankten sich
  8. #5
    Anfänger
    Registriert seit
    02.10.2022
    Beiträge
    6
    Thanks (gegeben)
    2
    Thanks (bekommen)
    1
    Themenstarter
    Total Downloaded
    0
    Total Downloaded
    0
    ReceiverDanke
    Box 1:
    Vu+ Solo SE V2
     
     
    Hallo zusammen,

    ich brauche noch einmal Eure Hilfe. Der Samba-Server auf meinem Raspberry Pi ist zwar im Windows-Netzwerk sichtbar, aber wenn ich die Firewall auf "scharf" schalte und `:INPUT DROP` einstelle, erhalte ich keine Aufforderung zur Eingabe der Netzwerkanmeldeinformationen (Benutzername und Passwort). Wenn ich die iptables-Regel auf `:INPUT ACCEPT` setze, erscheint die Aufforderung zur Eingabe von Benutzername und Passwort wie gewohnt.

    Ich habe bereits zahlreiche UDP- und TCP-Ports freigegeben, aber leider ohne Erfolg. Hat jemand einen Tipp, welche Einstellungen ich vornehmen muss, damit ich auch bei aktivierter Firewall zur Eingabe der Anmeldeinformationen aufgefordert werde?

    Vielen Dank im Voraus!

    /edit gefunden der udp 5353 war es, aktuell läuft es

    Code:
    -A INPUT -i eth0 -p tcp -m tcp --dport 445 -j ACCEPT -m comment --comment "samba"
    -A INPUT -i eth0 -p udp -m udp --dport 3702 -j ACCEPT -m comment --comment "wsdd service"
    -A INPUT -i eth0 -p tcp -m tcp --dport 5353 -j ACCEPT -m comment --comment "multicast dns"
    -A INPUT -i eth0 -p udp -m udp --dport 5353 -j ACCEPT -m comment --comment "multicast dns"
    -A INPUT -i eth0 -p tcp -m tcp --dport 5357 -j ACCEPT -m comment --comment "wsdd service"
    Geändert von YaYaHomeOffice (12.06.2024 um 04:48 Uhr)


Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Alle Zeitangaben in WEZ +1. Es ist jetzt 06:02 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2024 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 5,56%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com