Thanks Thanks:  0
Ergebnis 1 bis 5 von 5
  1. #1
    Senior Mitglied
    Registriert seit
    06.05.2013
    Beiträge
    775
    Total Downloaded
    241,41 MB
    Total Downloaded
    241,41 MB
    ReceiverDankeAktivitäten
    Box 1:
    AX Quadbox 2xDVB-S, 1x DVB-T2 OpenATV 6.0
     
     
    Box 2:
    Protek 9910LX 2x DVB-S OpenATV 6.0
     
     

    was passt hier nicht?

    Auf der VU+ mit openAtv hats noch geklappt, jetzt nicht mehr

    Code:
    #!/bin/sh
    file="status"
    
    remove_tmp ()
    {
            [ -e /tmp/.status.info ] && rm -rf /tmp/.status.info
    }
        
    case "$1" in
        start)
            echo "[SCRIPT] $1: $file"
            remove_tmp
               touch /tmp/.status.info 
                    echo status > /tmp/.status.info    
            /usr/scripts/status.sh &
            ;;
        stop)
            echo "[SCRIPT] $1: $file"
            killall -9 status.sh 2>/dev/null
            remove_tmp
            ;;
        restart)
            $0 stop
            sleep 2
            $0 start
            exit
            ;;
        *)
            $1 stop
            exit 1
            ;;
    esac
    
    exit 0
    beim start kommt folgendes:
    Code:
    root@xpeedlx3:~# /etc/init.d/info.sh start
    -sh: /etc/init.d/info.sh: /bin/sh^M: bad interpreter: No such file or directory
    das script status.sh läuft aber bei manuelem start.

    •   Alt Advertising

       

  2. #2
    Avatar von arn354
    Registriert seit
    06.04.2013
    Beiträge
    2.651
    Total Downloaded
    147,3 KB
    Total Downloaded
    147,3 KB
    ReceiverDankeAktivitäten
    Ist das Script mit Zeilenende LF gespeichert (Unix-konform)?
    Grüßle


  3. #3
    Senior Mitglied
    Registriert seit
    06.05.2013
    Beiträge
    775
    Themenstarter
    Total Downloaded
    241,41 MB
    Total Downloaded
    241,41 MB
    ReceiverDankeAktivitäten
    Box 1:
    AX Quadbox 2xDVB-S, 1x DVB-T2 OpenATV 6.0
     
     
    Box 2:
    Protek 9910LX 2x DVB-S OpenATV 6.0
     
     
    im notepade++

  4. #4
    Avatar von Captain
    Registriert seit
    03.04.2013
    Beiträge
    10.764
    Total Downloaded
    162,35 MB
    Total Downloaded
    162,35 MB
    ReceiverDankeAktivitäten
    da must du im n++was passt hier nicht?-.png

  5. #5
    Senior Mitglied
    Registriert seit
    06.05.2013
    Beiträge
    775
    Themenstarter
    Total Downloaded
    241,41 MB
    Total Downloaded
    241,41 MB
    ReceiverDankeAktivitäten
    Box 1:
    AX Quadbox 2xDVB-S, 1x DVB-T2 OpenATV 6.0
     
     
    Box 2:
    Protek 9910LX 2x DVB-S OpenATV 6.0
     
     
    ist bei mir ausgegraut

    klappt. habe es nochmals neu angelegt, und deinen tip befolgt.
    thx.
    Geändert von satfee (17.04.2014 um 18:39 Uhr)


Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 10:18 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,11%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com