Thanks Thanks:  0
Ergebnis 1 bis 6 von 6
  1. #1
    Mitglied
    Registriert seit
    26.12.2013
    Beiträge
    57
    Total Downloaded
    45,11 MB
    Total Downloaded
    45,11 MB
    ReceiverDankeAktivitäten

    Reverse-DNS-Abfrage verzögert Login

    Mir ist aufgefallen, dass die Gigablue Quad mit dem aktuellen OpenATV-Image bei jedem Telnet-Login eine ReverseDNS-Abfrage absetzt wodurch sich der Login um einige Sekunden verzögert. Meine alte Vu+ Duo mit VTI-Image macht das nicht, da funktioniert der Login "sofort".

    •   Alt Advertising

       

  2. #2
    Avatar von Captain
    Registriert seit
    03.04.2013
    Beiträge
    10.767
    Total Downloaded
    162,35 MB
    Total Downloaded
    162,35 MB
    ReceiverDankeAktivitäten
    ich hab da keine Verzögerung wie hast du das gesehen das es Reverse-DNS-Abfrage sind

  3. #3
    Mitglied
    Registriert seit
    26.12.2013
    Beiträge
    57
    Themenstarter
    Total Downloaded
    45,11 MB
    Total Downloaded
    45,11 MB
    ReceiverDankeAktivitäten
    Ich sehe das im TCPDump auf der Gigablue (über opkg installieren und dann über "tcpdump -s 1500 -i eth0 -w /tmp/dump.pcap" Log-File erzeugen und in Wireshark am PC laden, kommt dann sowas raus dump.zip). Die RDNS-Abfrage wird gestellt, sobald man die Telnet-Verbindung aufbaut und bescheuerterweise wird da nicht einfach nur die IP abgefragt sondern IP+(dynamischer) Port. Wenn man nun ziemlich schnell "root" eingibt und Enter drückt muss man fast 3s warten bis man wirklich was tun kann. Man merkts zudem auch wenn man per Telnet-Script vom fli4l drauf zugreift.
    Ich hatte schon versucht, meine PC-IP in die /etc/hosts einzutragen aber das hilft irgendwie nichts weil eben auch sinnloserweise der Port in der DNS-Abfrage drinsteckt. Ich vermute (!), dass es an dem Codepart des telnetd in der busybox liegt:
    Code:
    if (ENABLE_FEATURE_UTMP) { len_and_sockaddr *lsa = get_peer_lsa(sock);
    
     char *hostname = NULL;
    
     if (lsa) {
    
     hostname = xmalloc_sockaddr2dotted(&lsa->u.sa);
    
     free(lsa);
    
     }
    
     write_new_utmp(pid, LOGIN_PROCESS, tty_name, /*username:*/ "LOGIN", hostname);
    
     free(hostname);
    
     }
    Scheinbar war/ist auf der VU mit VTI dieses ENABLE_FEATURE_UTMP nicht aktiviert wobei ich keine Ahnung habe wo das aktiviert wird (evtl. zur Compile-Zeit?). Die Infos landen dann wohl unter /var/run/utmp und werden angezeigt über "who" bzw. "last".

    Edit: Wenn ich den Log genau anschaue dann braucht der AAAA-DNS-Lookup so lange...der ist für IPv6 zuständig. Vielleicht könnte ich auch den irgendwie disablen weil IpV6 habe ich eh nicht hier...

    Edit2: Scheint wohl bei im VTI wirklich irgendwie rausgepatch zu sein (hostname einfach komplett leer):
    Code:
    root@bm750:~# who
    USER       TTY      IDLE      TIME            HOST
    root       pts/0    00:00     Jan  1 17:33:07
    Code:
    root@gbquad:~# who
    root            pts/0           00:00   Jan  1 17:33:55  192.168.1.5:6286
    Geändert von Chuscha (01.01.2014 um 17:35 Uhr)

  4. #4
    Mitglied
    Registriert seit
    26.12.2013
    Beiträge
    57
    Themenstarter
    Total Downloaded
    45,11 MB
    Total Downloaded
    45,11 MB
    ReceiverDankeAktivitäten
    Hatte hier vorher was Längeres gepostet aber sehe den Post jetzt seltsamerweise nicht mehr (habt ihr technische Probleme?)....also getestet wars mit tcpdump. Ich habe jetzt noch weiter gesucht: Wenn ich das ipv6.ko-Kernelmodul umbenenne, dann erfolgen gar keine DNS-Anfragen mehr und der Login ist wirklich sofort analog VTI...

  5. #5
    Avatar von Papi2000
    Registriert seit
    20.04.2013
    Beiträge
    9.524
    Total Downloaded
    592,83 MB
    Total Downloaded
    592,83 MB
    ReceiverDankeAktivitäten
    Box 1:
    GigaBlue Q-SSC / Q+-SSC / weitere
     
     
    Box 2:
    DM900uhd-SS / Vu+Duo
     
     
    Box 3:
    Sogno 800HD Revo Triple 8800HD-SS
     
     
    Box 4:
    E4HD FormF3 AX Triplex VIP2-CC
     
     
    Box 5:
    diverse andere . . .
     
     
    Einfach rauspatchen würde es aber nicht. Es macht doch Sinn, zu sehen was geht:
    Code:
    ...
    root@GBquad-3:~# who
    root            pts/0           00:19   Jan  1 17:55:48  192.168.0.2:58781
    root            pts/1           00:00   Jan  1 18:15:42  192.168.0.2:59050
    root@GBquad-3:~# lsmod
    Module                  Size  Used by
    boxmodel                 818  0
    ipv6                  339310  16
    dvb                 13699620  30
    Allerdings ist tatsächlich das ipv6 geladen, obwohl ich eigentlich auch nur ipv4 nutze.

    EDIT: Geladen wird das ipv6 beim Start der Box über /etc/modules.
    Dort müßte es deaktivierbar sein (dann muß man nicht umbennen).
    Geändert von Papi2000 (01.01.2014 um 18:26 Uhr)
    Grüßle
    Ralf
    ------------------------------------------------------------------------------------------------------------------------
    Gigablue Quad 4K-multi,Quad+-SSC,Quad-SSC, andere Gigas, Astra 19.2E, UniCable & KabelBW, oATV/ OpenMips
    (weitere: DM900uhd,Vu+Duo,Technisat,Edision),PC-DVB-S/C/T,PCH-A110,Xtreamer,BDP5200
    UE32C5700,UE65HU7590,LG42R51
    ---- Einen Receiver kann sich jeder kaufen - Eine stabile E²-Box muß man sich verdienen! ----



  6. #6
    Mitglied
    Registriert seit
    26.12.2013
    Beiträge
    57
    Themenstarter
    Total Downloaded
    45,11 MB
    Total Downloaded
    45,11 MB
    ReceiverDankeAktivitäten
    Ich hatte die /etc/modules-load.d/ipv6.conf gelöscht aber das ipv6 wurde trotzdem geladen...


Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Diese Website benutzt Cookies
Wir benutzen Cookies um Sitzungsinformationen zu speichern. Dies erleichtert es uns z.B. Dich an Deine Login zu erinnern, Einstellungen der Webseite zu speichern, Inhalte und Werbung zu personalisieren, Social Media Funktionen anzubieten und unser Datenaufkommen zu analysieren. Wir teilen diese Informationen ebenfalls mit unseren Social Media-, Werbe- und Analysepartnern.
     
Alle Zeitangaben in WEZ +1. Es ist jetzt 20:41 Uhr.
Powered by vBulletin® Version 4.2.5 (Deutsch)
Copyright ©2017 Adduco Digital e.K. und vBulletin Solutions, Inc. Alle Rechte vorbehalten.
Resources saved on this page: MySQL 11,11%
Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)
vBulletin Skin By: PurevB.com